FFe: time-admin and indicator-datetime-preferences shouldn't both be installed by default

Bug #732757 reported by Michael Terry
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Seeds
Fix Released
Undecided
Unassigned
gnome-system-tools (Ubuntu)
Fix Released
Undecided
Michael Terry

Bug Description

Binary package hint: gnome-system-tools

Now that indicator-datetime-preferences is about to get a .desktop file, (https://code.launchpad.net/~mterry/indicator-datetime/fix-show-clock/+merge/52890), it and time-admin look similar and do the same thing to the user.

We should not install time-admin in the Ubuntu seed. However, it is currently bundled together as part of gnome-system-tools. So it should be split out and made its own package. Then seeds can adjust accordingly.

Revision history for this message
Milan Bouchet-Valat (nalimilan) wrote :

I think we should even stop installing the gnome-system-tools, and use the new account-dialog (or it's GNOME control center panel version) to replace users-admin. Other tools are not needed in default install.

Michael Terry (mterry)
Changed in gnome-system-tools (Ubuntu):
assignee: nobody → Michael Terry (mterry)
Michael Terry (mterry)
summary: - time-admin and indicator-datetime-preferences overlap in appearance and
- functionality
+ FFe: time-admin and indicator-datetime-preferences shouldn't both be
+ installed by default
Revision history for this message
Michael Terry (mterry) wrote :

OK, just discovered that we're not actually feature-compatible with time-admin. If ntpd isn't installed, time-admin will offer to install it. indicator-datetime-preferences should do that too. Unsubscribing ubuntu-release for now.

Revision history for this message
Michael Terry (mterry) wrote :

Oh, I can't. Well, ubuntu-release, ignore this for now.

Revision history for this message
Milan Bouchet-Valat (nalimilan) wrote :

I'd say let's just install ntpd by default, and stop running ntpdate automatically, because it 1) only runs when (re)connecting, which is kind of misleading and not correct on servers and 2) isn't currently reported in the GUI as automated Internet time sync, while it's actually doing this in the background. The new time & date tool in GNOME Control Center 3.0 also relies on the fact that ntpd is present to sync time.

Revision history for this message
Michael Terry (mterry) wrote :

Nevermind. After discussing how the "automatically set time from Internet" option works, we don't quite want to replicate time-admin's feature. See bug 734894. But this FFe can be considered again once that is fixed.

Revision history for this message
Michael Terry (mterry) wrote :

Milan, servers will have ntpd installed. But for normal Ubuntu, it's a bit overkill. Hence ntpdate. The plan so far is to have the dialog control whichever is installed (or both). But that's a discussion for bug 734894.

Then new time & date tool for GNOME 3.0 assumes nptd because that's installed by default in Fedora.

Revision history for this message
Martin Pitt (pitti) wrote :

Ack for splitting out gnome-time-admin similar to the already existing gnome-network-admin splitout.

Changed in gnome-system-tools (Ubuntu):
status: New → Confirmed
Revision history for this message
Michael Terry (mterry) wrote :

gnome-system-tools (2.32.0-0ubuntu6) natty; urgency=low

  * Split time-admin into its own package, gnome-time-admin, so we can
    include it in certain flavors but not others. LP: 732757

Changed in gnome-system-tools (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Michael Terry (mterry) wrote :
Changed in ubuntu-seeds:
assignee: nobody → Michael Terry (mterry)
status: New → In Progress
Revision history for this message
Michael Terry (mterry) wrote :

All flavors have now merged the seed changes. Closing this out.

Changed in ubuntu-seeds:
assignee: Michael Terry (mterry) → nobody
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers