time-admin crashed with SIGSEGV in e_map_point_get_location()

Bug #697974 reported by Greg Colburn
58
This bug affects 10 people
Affects Status Importance Assigned to Milestone
gnome-system-tools (Ubuntu)
Medium
Mathieu Trudel-Lapierre

Bug Description

Binary package hint: gnome-system-tools

Time Admin crashed after I select my timezone America/Denver from the map. If I select my timezone from the drop down list time admin changes my timezone appropriately.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: gnome-system-tools 2.32.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
Uname: Linux 2.6.37-11-generic i686
Architecture: i386
CrashCounter: 1
Date: Thu Jan 6 05:46:15 2011
ExecutablePath: /usr/bin/time-admin
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110105)
ProcCmdline: time-admin
ProcEnviron:
 SHELL=/bin/bash
 LC_MESSAGES=en_AG.utf8
 LANGUAGE=en_US.UTF-8:en
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x8056fa9 <e_map_point_get_location+9>: fldl 0x4(%eax)
 PC (0x08056fa9) ok
 source "0x4(%eax)" (0x00000004) not located in a known VMA region (needed readable region)!
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-system-tools
StacktraceTop:
 e_map_point_get_location ()
 ?? ()
 ?? ()
 ?? () from /usr/lib/libgtk-x11-2.0.so.0
 g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
Title: time-admin crashed with SIGSEGV in e_map_point_get_location()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Revision history for this message
Greg Colburn (gcolb) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 e_map_point_get_location (point=0x0, longitude=0xbf8187e8,
 e_tz_map_location_from_point (tzmap=<value optimized out>,
 button_pressed (w=0x8fd59c8, event=0x8ee0ea0,
 _gtk_marshal_BOOLEAN__BOXED (closure=0x90041c8,
 ?? ()

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in gnome-system-tools (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Revision history for this message
Michael Terry (mterry) wrote :

I can also reproduce by clicking on America/Chicago.

visibility: private → public
Revision history for this message
Milan Bouchet-Valat (nalimilan) wrote :

And only when clicking on that point? Here I'm not able to reproduce the crash...

Revision history for this message
Milan Bouchet-Valat (nalimilan) wrote :

This bug is weird because we seem to be passing NULL as location point. This can only happen if no point was highlighted when you clicked; the pointer must get out of the map for the point to be set to NULL. Do different effects happen if e.g. you hover a different point before clicking on Chicago? Are the points colored in yellow in all cases?

Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

Milan,

The only way I can reproduce this is while running unity (but I do expect it's actually related to running with compiz).

I already have a fix for it, which is to compute the closest point for the selected point when it gets clicked... either way the longitude and latitude are already available to zoom the map.

Changed in gnome-system-tools (Ubuntu):
status: New → In Progress
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Revision history for this message
Milan Bouchet-Valat (nalimilan) wrote :

Thanks for the debugging and for the patch, but I don't think it fixes the root cause. tzmap->point_hover should already contain the point that was retrieved using e_map_get_closest_point() when the pointer moved. So if tzmap->point_hover isn't valid, we have to find out why. The questions I asked in my last comment might help understanding this.

I don't see what Compiz could be doing that makes this fail - maybe we don't get events when the pointer moves, but this would be a real failure from Compiz. Or is the crash only triggered when you click without the pointer having moved too much on the map? or when it hasn't gone out of the map once?

Also, please don't commit the fix to Natty. If we choose this patch, I'd rather push it upstream first, rather than diverging, which will create packaging work when the next release is out (this is not a problem for Maverick, though).

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-tools - 2.32.0-0ubuntu4

---------------
gnome-system-tools (2.32.0-0ubuntu4) natty; urgency=low

  * debian/patches/95_timezone_point_selection.patch: Fix selecting a timezone
    while running on compiz: compute the point we're at when the map gets
    clicked. (LP: #697974)
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 14 Jan 2011 03:16:03 +0000

Changed in gnome-system-tools (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

Heh, sorry, I didn't see your message. I understand how it's more work, but I'm prepared to take care of it (although I didn't and can't upload this myself).

Milan, further debugging was showing that the issue seems to be that compiz may be causing leave-notify-event signals to be sent, which would cause tzmap->point_hover to be nullified. I haven't noticed any special causes for this like moving lots or not much around the map, or having the pointer get out of the map.

Revision history for this message
Milan Bouchet-Valat (nalimilan) wrote :

The problem isn't that I fear people won't do the work, as I know packaging will happen anyway. It's just that the way Ubuntu devs consider patching is plain wrong: there's generally no hurry pushing a fix to the development release, so downstream patching only generates useless work. I wish Ubuntu would turn to upstream when they have a patch before even thinking of applying it: very often, feedback and discussion can help understanding the best solution. Plus, if I hadn't been around, would upstream have even heard of this patch one day? This is not against you at all, it's more a general state of mind that I consider slightly counter-productive.

I've tried to reproduce this with Compiz, and I can't. Weird. If under Compiz we're getting leave-notify-event signals, something is really wrong. Did you notice when these signals are sent? When simply moving the pointer, when clicking... ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers