[time-admin] "Synchronize Now" work only when ntp-server is installed

Bug #62745 reported by Patrice Vetsel on 2006-09-28
40
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GST
Unknown
Medium
gnome-system-tools (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

By default on fresh edgy uptodate install with g-s-t 2.15.4-0ubuntu3 when you go to "Adjust Date & time" on time applet. Clicking on "Synchronize Now" do nothing.
If you select "Keep clock synchronized with internet servers", ubuntu install required packages, after that you can deselect "Keep clock synchronized with internet servers" and cliking now on "Synchronize Now" button works !

So :
1/ "Synchronize Now" have to be grayed if packages required are not installed
or
2/ Clicking on "Synchronize Now" must install packages required if they are not already installed
or
3/ Packages required have to be installed by default

I think that 2/ is the better way to solve that. 3/ is the easy way.

Step to reproduce :
install edgy
right click on time applet
select "Adjust Date&Time"
change your Time
click on "Synchronize Now" -> nothing append

description: updated
Vassilis Pandis (pandisv) wrote :

I can confirm this on current Edgy. Regression from bug 37230 . 13890 describes a similar issue.

Changed in gnome-system-tools:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

I've forwarded that bug upstream: http://bugzilla.gnome.org/show_bug.cgi?id=358625

Changed in gst:
status: Unknown → Unconfirmed
Cédric M. Campos (cedricmc) wrote :

That's true also for Xubuntu 6.10. But I disagree with the original suggestions, time-admin must be able to synchronize with ntp servers without need of server being installed, like using "ntpdate ntp.server.com".

MrRio (rio-x5g) wrote :

Confirmed on Feisty 7.04 pre-release (17 March 2007)

I can confirm this on Ubuntu 6.10.

The synchronisation did work after checking and unchecking the "Keep clock synchronized with internet servers", installing the suggested packages and clicking on "Synchronize now". It would be nice if the "Synchronize now" button worked out-of-the-box.

Feisty beta (german) also affected
Linux version 2.6.20-12-generic (root@palmer) (gcc version 4.1.2 (Ubuntu 4.1.2-0ubuntu4)) #2 SMP Wed Mar 21 20:55:46 UTC 2007

Patrice Vetsel (vetsel-patrice) wrote :

Gutsy 2.18.1-1ubuntu1 also affected

Changed in gst:
status: New → Invalid
Pedro Villavicencio (pedro) wrote :

Ubuntu related issue according to upstream: "It's ubuntu's patches to g-s-t which install packages, not upstream, so the problem looks like it's theirs. Also, the "Synchronize now" button has always used ntpdate, so please file a new bug if ntpdate usage in g-s-t isn't correct"

Changed in gnome-system-tools:
status: Confirmed → Triaged

8.04.1 also affected…

Ulf Adams (ulf-ofahrt) wrote :

I'm on 8.04 and the 'synchronize now' button does nothing, with or without ntp installed. On a 8.10 machine next to it, the 'synchronize now' button does nothing, with or without ntp installed. I'm not sure if it's the same bug as this, or even the same bug on both machines. I can synchronize using ntpdate <server> or ntpdate-debian (after hacking /etc/default/ntpdate) on the terminal.

This is fixed in Karmic (if not earlier) since ubuntu-minimal depends on ntpdate. There are other bugs about the Synchronize Now button, but they come from different problems (just search for synchronize in the bugs for package gnome-system-tools). Thus closing.

Changed in gnome-system-tools (Ubuntu):
status: Triaged → Fix Released
Changed in gst:
importance: Unknown → Medium
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.