[users-admin] "Properties" in users context menu has no effect

Bug #586080 reported by Felix Nawothnig
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-system-tools (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-system-tools

fnawothnig@simson:~$ lsb_release -rd
Description: Ubuntu 10.04 LTS
Release: 10.04
fnawothnig@simson:~$ apt-cache policy gnome-system-tools
gnome-system-tools:
  Installed: 2.30.0-0ubuntu2
  Candidate: 2.30.0-0ubuntu2
  Version table:
 *** 2.30.0-0ubuntu2 0
        500 http://de.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
fnawothnig@simson:~$

To reproduce:

Go through main menu: System / Administration / Users and Groups

"Users Settings" dialog opens up

Right-click on any user, select "Properties".

Expected behavior:

Not sure exactly, the account type and password can be changed on the right pane and buttons for "Groups" and "Advanced Settings" exist there too. But I suppose I'd expect some dialog, with some properties.

Observed behavior:

Nothing happens.

Given the options for changing all that stuff are present the actual bug may be the pure existence of the menu item and it should be removed.

Revision history for this message
deuxpi (philippe-gauthier) wrote :

Good catch! The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in gnome-system-tools (Ubuntu):
status: New → Confirmed
Revision history for this message
Milan Bouchet-Valat (nalimilan) wrote :

Yeah, the problem is that the menu is shared with the groups, so fixing this would require splitting it from there. It may be easier to remove completely this menu, since it's mainly redundant. But definitely not a very serious issue...

Don't bother reporting this upstream, I manage the bugs here as well, no need to duplicate the work.

Changed in gnome-system-tools (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
summary: - (Users Settings) "Properties" has no effect
+ [users-admin] "Properties" in users context menu has no effect
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-tools - 3.0.0-3ubuntu5

---------------
gnome-system-tools (3.0.0-3ubuntu5) utopic; urgency=medium

  * Hide "Properties" in users context menu (LP: #586080).
 -- Thaddaeus Tintenfisch <email address hidden> Wed, 24 Sep 2014 11:49:36 +0100

Changed in gnome-system-tools (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers