Automatic login fails and computer hangs (Lucid)

Bug #577563 reported by A. Meerkerk on 2010-05-08
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gnome-system-tools (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gdm

1) Ubuntu 10.04 LTS

2)
gdm:
  Installed: 2.30.0-0ubuntu5
  Candidate: 2.30.0-0ubuntu5
  Version table:
 *** 2.30.0-0ubuntu5 0
        500 http://nl.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

3) I expected Ubuntu to login "automatically" when booting:
In the screen System > Administration > Users and Groups > Password > Change I select the box 'Don't ask for password on login' (automatic login).

4) Instead, when I boot the computer:

- It boots fine until the login screen is loaded

- Then I select my account on the login screen.

- Next, I get a bunch of different error messages, in the following order:

(1) "Could not update ICEauthority file /home/user/.ICEauthority"
(2) Error message that reads something like: Problem with the configuration server, ....
(3) Error from Nautilus: (translated from dutch): Cannot create mandatory directories: /home/user/Desktop
/home/user/.nautilus
(4) Update Window: "Record your encryption passphrase" > No idea what I have to do with this, if I execute the suggested action, this has no effect, and the system doesn't respond as indicated in the window itself.
(5) Now I get the blank default Desktop background, with nothing on it (no menu's, links, etc.)
I am sort of logged in however, because I can get a screen to shut down, restart etc., when pushing my computer's on/off button. And after a break I get the normal login window that asks my password. If I enter it, the system hangs.

> Maybe this bug has to do with messed up file permissions? I have no idea. Maybe it's related to the fact that my home directory is encrypted (encryptfs)

Work-around to be able to login again and turn autmatic login off: boot with recovery mode, log in manually from the command prompt, and run 'startx' to start up ubuntu.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, it's not likely a gdm bug though but rather a local issue, changing to a question where triagers can help to get the issue debugged

Changed in gdm (Ubuntu):
importance: Undecided → Low
status: New → Invalid
karenng (karen-dee-dee) wrote :

I also confirm such a bug - I almost had to reinstall my ubuntu . How can we get someone remove such an problematic option from the login screen preference window??

zohar (zoharsnir) wrote :

I have this too.

Happens when gdm's autologon or timedlogon is true.

What happens is when system is booting gdm is auto/timed loging the user in and the "could not update ICEauthority file" error appears, if OK is clicked I get another message (usr/lib/libgconf2-4/gconf-sanity-check-2 has quit with state 256) and then just an empty wallaper.

To get in to the system I move to a free text tty and run "sudo /etc/init.d/gdm restart". When gdm restarts everything is ok.

zohar (zoharsnir) wrote :

Some forum told me to chown <username>:<username> the ICEauthority file and give it 644 permissions.
Did nothing for me.

Jesse Katzman (j-kat) wrote :

This is a bug in the way Users and Groups (users-admin), gdm, and ecryptfs react with each other.

Jesse Katzman (j-kat) wrote :

From duplicate bug #581303:

You cannot automatically login or do a passwordless login if your home directory is encrypted. When you switch to the terminal and log in, you're decrypting your home directory. Thus, once you've logged in through the terminal, you can log in to your desktop by going back to the login screen through "ctrl+alt+F8" or a "sudo service gdm restart".

I went to "Users and Groups" and selected "Don't ask for password on login". When "Login Screen Settings" wouldn't let me log in automatically (my username was not selectable), I assumed it was a bug, not a warning, so I manually edited the /etc/gdm/custom.conf file to let me log in automatically. Because I still wanted my computer to be (mostly) secure, I enabled the lock screen after login. But when gdm tried to automatically log in, the screen would go blank and then I would be kicked back to the login screen because my home directory was encrypted.

In reply to comment #1: the bug is not invalid, and this is not a local issue. See bug #888355 for detailed steps to reproduce. The combination of these two preferences makes login impossible. The user administration tool should make such combinations impossible (bug #888355), but if they do occur somehow, gdm should ask for the password so that it can decrypt the home directory. At the very least, it should raise a clear error message. Currently it gives very cryptic errors and login hangs (on Ubuntu 11.04), or it gives no error message at all and just returns you to the login screen (on Ubuntu 11.10). There's definitely room for improvement here.

Changed in gdm (Ubuntu):
status: Invalid → Confirmed
status: Confirmed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdm (Ubuntu):
status: New → Confirmed
Milan Bouchet-Valat (nalimilan) wrote :

Speaking as the (former) maintainer, this is really a bug in users-admin, but it's no longer developed since it's been replaced with the new GNOME control center applet upstream. (The new applet doesn't allow setting a password-less account.) If the bug had been reported against the gnome-system-tools, I'd had fixed the bug back in 2010, but now, it's too late for me... :-/

I don't think the workaround should be added in GDM, because I don't think it would be easy due to how PAM works.

affects: gdm (Ubuntu) → gnome-system-tools (Ubuntu)
Changed in gnome-system-tools (Ubuntu):
importance: Low → Medium
status: Confirmed → Triaged

So does Ubuntu plan to switch to the new upstream applet in a future version?

Isn't it already the case in 11.10?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers