[time-admin] Value of "Configuration" doesn't change on initial switch to "Keep synchronized with Internet servers"

Bug #551936 reported by Ali Asad Lotia on 2010-03-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
gnome-system-tools (Ubuntu)
Low
Canonical Desktop Team

Bug Description

Binary package hint: gnome-system-tools

When initially changing the value of the "Configuration" dropdown in the Time and Date Settings window to "Keep synchronized with Internet servers" on a newly set up machine, a dialog pops up informing the user that NTP is required but it isn't installed. It gives the user the option to install it. After selecting that option and installing NTP support, the user is brought back to the Time and Date Settings window, but the value of "Configuration" drop down is still "Manual". Checking the process list shows that ntpd is in fact running. The value of the "Configuration" drop down should be changed to "Keep synchronized with Internet Servers" to indicate to the user that the change made has taken effect.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-system-tools 2.29.92-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-18.27-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-18-generic i686
Architecture: i386
Date: Tue Mar 30 14:11:05 2010
ExecutablePath: /usr/bin/time-admin
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-system-tools
XsessionErrors:
 (polkit-gnome-authentication-agent-1:1380): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-terminal:1743): Gtk-CRITICAL **: gtk_accel_map_unlock_path: assertion `entry != NULL && entry->lock_count > 0' failed

Ali Asad Lotia (ali-asad-lotia) wrote :
Victor Vargas (kamus) on 2010-03-30
Changed in gnome-system-tools (Ubuntu):
importance: Undecided → Low
Milan Bouchet-Valat (nalimilan) wrote :

Yeah, I noticed that yesterday too. Shouldn't be too hard to fix.

Changed in gnome-system-tools (Ubuntu):
status: New → Triaged
summary: - value of "Configuration" doesn't change on initial switch to "Keep
- synchronized with Internet servers"
+ [time-admin] Value of "Configuration" doesn't change on initial switch
+ to "Keep synchronized with Internet servers"
Xiegai Shan (xiegaishan) on 2010-04-11
Changed in gnome-system-tools (Ubuntu):
assignee: nobody → Xiegai Shan (xiegaishan)
Changed in gnome-system-tools (Ubuntu):
assignee: Xiegai Shan (xiegaishan) → Canonical Desktop Team (canonical-desktop-team)
tags: added: patch
Milan Bouchet-Valat (nalimilan) wrote :

I think this one is worth some attention if you're looking for last-minute fixes.

Xiegai, could you update the Ubuntu patch "82_gst-packages-time-admin.patch" by adding your fix, so that it's easy to apply? Thanks!

Changed in hundredpapercuts:
status: New → In Progress
Milan Bouchet-Valat (nalimilan) wrote :

Here's a merged version of the Ubuntu patch.

Didier Roche (didrocks) on 2010-04-14
Changed in hundredpapercuts:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-tools - 2.30.0-0ubuntu2

---------------
gnome-system-tools (2.30.0-0ubuntu2) lucid; urgency=low

  * debian/patches/82_gst-packages-time-admin.patch:
    - Switch time combobox to "Keep synchronized with Internet servers" after
      having installed NTP support (Xiegai Shan) (LP: #551936)
 -- Didier Roche <email address hidden> Wed, 14 Apr 2010 21:27:37 +0200

Changed in gnome-system-tools (Ubuntu):
status: Triaged → Fix Released
Milan Bouchet-Valat (nalimilan) wrote :

I've actually identified the root cause of this bug, which is in liboobs: runlevels list for the NTP service wasn't cleared when updating, which caused the script to be disabled when trying to enable it. This is fixed with liboobs 2.30.1, so the hack in 82_gst-packages-time-admin.patch (one line) can be removed in Maverick.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers