When creating a new user, "Shortname" should really be "Username" .

Bug #529744 reported by Anzenketh
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GST
Fix Released
Low
One Hundred Papercuts
Low
Unassigned
gnome-system-tools (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-system-tools

Description: Ubuntu lucid (development branch)
Release: 10.04

gnome-system-tools
  Installed: 2.29.91-0ubuntu1
  Candidate: 2.29.91-0ubuntu1
  Version table:
 *** 2.29.91-0ubuntu1 0
        500 http://us.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status
Expected:
When creating a user I expected to be asked to fill out user-name

What happened instead.
Instead I was prompted to put in shortname.

I have talked to people in ubuntu-discuss mailing list and they agree this needs to be changed.

ProblemType: Bug
Architecture: i386
Date: Sun Feb 28 16:30:41 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
Package: gnome-system-tools 2.29.91-0ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SourcePackage: gnome-system-tools
Uname: Linux 2.6.32-14-generic i686

Revision history for this message
Anzenketh (anzenketh) wrote :
Revision history for this message
Anzenketh (anzenketh) wrote :
Revision history for this message
Anzenketh (anzenketh) wrote :

Well I was thinking of writing a patch for this but I could not find the line to change.

Revision history for this message
Anzenketh (anzenketh) wrote :

Found the lines to change will work on a patch.

Changed in hundredpapercuts:
status: New → In Progress
Changed in gnome-system-tools (Ubuntu):
status: New → In Progress
Changed in hundredpapercuts:
assignee: nobody → Anzenketh (anzenketh)
Changed in gnome-system-tools (Ubuntu):
assignee: nobody → Anzenketh (anzenketh)
Revision history for this message
Anzenketh (anzenketh) wrote :

Got the patch completed.

Changed in hundredpapercuts:
assignee: Anzenketh (anzenketh) → nobody
Changed in gnome-system-tools (Ubuntu):
assignee: Anzenketh (anzenketh) → nobody
Changed in hundredpapercuts:
status: In Progress → New
Changed in gnome-system-tools (Ubuntu):
status: In Progress → New
tags: added: patch
Anzenketh (anzenketh)
Changed in hundredpapercuts:
assignee: nobody → Anzenketh (anzenketh)
Changed in gnome-system-tools (Ubuntu):
assignee: nobody → Anzenketh (anzenketh)
Vish (vish)
summary: - When creating a user shortname should really be username.
+ When creating a new user, "Shortname" should really be "Username" .
Changed in gnome-system-tools (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Triaged
Revision history for this message
Anzenketh (anzenketh) wrote :

Cleaned up and readded patch.

Changed in hundredpapercuts:
assignee: Anzenketh (anzenketh) → nobody
assignee: nobody → Anzenketh (anzenketh)
assignee: Anzenketh (anzenketh) → nobody
assignee: nobody → Anzenketh (anzenketh)
Revision history for this message
Anzenketh (anzenketh) wrote :

Subscribed Ubuntu review team to look over my patch.

Revision history for this message
Anzenketh (anzenketh) wrote :

Fixed a error in changelog.

Revision history for this message
Vish (vish) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream. Thanks in advance!

Changed in gnome-system-tools (Ubuntu):
status: Triaged → Confirmed
Revision history for this message
Vish (vish) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
https://bugzilla.gnome.org/show_bug.cgi?id=611453

Changed in gst:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-system-tools (Ubuntu):
status: Confirmed → Triaged
Nigel Babu (nigelbabu)
Changed in hundredpapercuts:
assignee: Anzenketh (anzenketh) → Nigel Babu (nigelbabu)
Changed in gnome-system-tools (Ubuntu):
assignee: Anzenketh (anzenketh) → Nigel Babu (nigelbabu)
Revision history for this message
Nigel Babu (nigelbabu) wrote :
Revision history for this message
Milan Bouchet-Valat (nalimilan) wrote :

Hmm, thanks for working on this, but if we change this now, we need to update translations too, else non-English versions won't be consistent with the English one. And since GNOME is in string freeze currently, I'm really not sure it's worth the work for translators. I'd like to hear from other developers to be sure it's worth applying this patch only for Ubuntu.

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Unsubscribing sponsors for now. This would need a UI freeze exception, and I'm not sure it justifies that. It also breaks the translations

Nigel Babu (nigelbabu)
Changed in hundredpapercuts:
assignee: Nigel Babu (nigelbabu) → nobody
Changed in gnome-system-tools (Ubuntu):
assignee: Nigel Babu (nigelbabu) → nobody
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Noting the ongoing discussion about the "Right name to choose" (bike shed color discussion really) as well as String freeze in Gnome & Lucid. I'm unsubscribing Ubuntu Reviewers for now.

I'm subscribing myself to keep an eye on it.

Thank you for contributing to Ubuntu. Hopefully we will get this Upstream & Ubuntu M.

tags: added: patch-needswork
removed: patch
Revision history for this message
Vish (vish) wrote :

This is now fixed upstream.

For the accounts dialogue , there is also https://bugzilla.gnome.org/show_bug.cgi?id=623287 with a patch.

Changed in gnome-system-tools (Ubuntu):
status: Triaged → Fix Committed
Changed in gst:
status: Unknown → Fix Released
Revision history for this message
Vish (vish) wrote :

This is fixed in gst in commit:
http://git.gnome.org/browse/gnome-system-tools/commit/?id=a9a2f0a15fcc4037b2d4c8c640e25a92dac1072b

And in the accounts dialogue as well.

Changed in hundredpapercuts:
status: Triaged → Fix Committed
tags: added: patch-accepted-upstream
removed: patch-needswork
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-tools - 2.30.2-1ubuntu4

---------------
gnome-system-tools (2.30.2-1ubuntu4) maverick; urgency=low

  * Fix LP: #570828 - gnome-network-admin on UbuntuStudio doesnt allow
    to configure either wired networks or wireless. Expose the
    connections tab and locations combo box on derivatives that don't use
    Network Manager
    - update debian/patches/10_disable_interfaces.patch
  * Fix LP: #529744 - When creating a new user, "Shortname" should
    really be "Username"
    - add debian/patches/12_users_string_change.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Mon, 23 Aug 2010 17:04:08 +0100

Changed in gnome-system-tools (Ubuntu):
status: Fix Committed → Fix Released
Vish (vish)
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Changed in gst:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.