users-admin : Scrolling through list resizes listbox

Bug #514298 reported by James Bellinger on 2010-01-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GST
Fix Released
Undecided
Unassigned
gnome-system-tools (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-system-tools

When I scroll through the user list, the listbox resizes. This looks _extremely_ unprofessional and ought to be fixed.
What's even more interesting is that it does it needlessly. I scroll onto root from my own account and it gets wider (!).

Another thing, the symmetry on the right is nice, but it's really not good for naming. Instead of Edit for all three (not very specific), put 'Rename' for the name and 'Change' for the other two. The first has no label so it's not clear what it is initially, and there's no such thing as 'editing' an Account Type, since it's a list of options not a big, configurable thing. One could argue for editing a password, but nobody uses English that way, they say 'change my password'.

Also, 'Help' and 'Close' are a few pixels squished in from the sides and don't align with anything else. It looks weird. :)

Milan Bouchet-Valat (nalimilan) wrote :

If you want to provide a full UI review, a message to our mailing list would be more appropriate I guess. For now: I think I'll change "Edit" to "Change", I was misled by the French translation into thinking it was the right term (actually this is a stock GTK+ button).

The alignment problem for "Help" and "Close" is known, but I'm not sure how I can fix this, since that box is normally automatically configured by GTK+. I'll see what we can do, but obviously that's not top priority since that can be change at any time without risks - better get the tools working right first.

So I'll keep that report to tackle the resizing issue. I suspect the list isn't getting wider when you select root, but rather the main part of the window is getting wider when you select your own account. I know this can happen when labels get wider than the default, which mainly depends on your locale. Could you provide screenshots of both situations? BTW, this has changed in the latest upstream code, so that may not behave the same now.

Changed in gnome-system-tools (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

Hmm, you are right. The name is longer for me than for root. Though,
what is strange about it is, in both cases there is plenty of space
between the names and the buttons, so it shouldn't need the extra
space anyway..

The reason I recommend "Rename" for the name instead of Change like
the others is that it's not immediately clear what is being changed
otherwise (since it's just a person-head and a name). Also it would
break up the repetition and is more specific.

-James

On Fri, Jan 29, 2010 at 9:05 AM, Milan Bouchet-Valat <email address hidden> wrote:
> If you want to provide a full UI review, a message to our mailing list
> would be more appropriate I guess. For now: I think I'll change "Edit"
> to "Change", I was misled by the French translation into thinking it was
> the right term (actually this is a stock GTK+ button).
>
> The alignment problem for "Help" and "Close" is known, but I'm not sure
> how I can fix this, since that box is normally automatically configured
> by GTK+. I'll see what we can do, but obviously that's not top priority
> since that can be change at any time without risks - better get the
> tools working right first.
>
> So I'll keep that report to tackle the resizing issue. I suspect the
> list isn't getting wider when you select root, but rather the main part
> of the window is getting wider when you select your own account. I know
> this can happen when labels get wider than the default, which mainly
> depends on your locale. Could you provide screenshots of both
> situations? BTW, this has changed in the latest upstream code, so that
> may not behave the same now.
>
> ** Changed in: gnome-system-tools (Ubuntu)
>   Importance: Undecided => Low
>
> ** Changed in: gnome-system-tools (Ubuntu)
>       Status: New => Incomplete
>
> --
> users-admin : Scrolling through list resizes listbox
> https://bugs.launchpad.net/bugs/514298
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “gnome-system-tools” package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: gnome-system-tools
>
> When I scroll through the user list, the listbox resizes. This looks _extremely_ unprofessional and ought to be fixed.
> What's even more interesting is that it does it needlessly. I scroll onto root from my own account and it gets wider (!).
>
> Another thing, the symmetry on the right is nice, but it's really not good for naming. Instead of Edit for all three (not very specific), put 'Rename' for the name and 'Change' for the other two. The first has no label so it's not clear what it is initially, and there's no such thing as 'editing' an Account Type, since it's a list of options not a big, configurable thing. One could argue for editing a password, but nobody uses English that way, they say 'change my password'.
>
> Also, 'Help' and 'Close' are a few pixels squished in from the sides and don't align with anything else. It looks weird. :)
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/gnome-system-tools/+bug/514298/+subscribe
>

Milan Bouchet-Valat (nalimilan) wrote :

OK, if that's the length of the name I see the problem. I'll fix that before the release, that's not as trivial as it may seem but is definitely not hard to fix. ;-)

I don't like the idea of changing the label to "Rename" because since it's more specific, it will break the similarity between all those buttons. In the current design, you immediately see that these buttons all refer to the data that is on the same line. If we were to change the label to "Rename", we would have to find specific descriptions for every field, and the idea is to add more fields - eventually the dialog would get harder to read. Since there's only the name on the first button's line, I think people will understand - if they are not sure, it's just a click away, not a big deal.

James Bellinger (jfb) wrote :

Hmm, I hope you are right. Still, I think Rename, Change, Change would
improve self-description.
But, it's your program :)

On Sun, Jan 31, 2010 at 5:43 AM, Milan Bouchet-Valat <email address hidden> wrote:
> OK, if that's the length of the name I see the problem. I'll fix that
> before the release, that's not as trivial as it may seem but is
> definitely not hard to fix. ;-)
>
> I don't like the idea of changing the label to "Rename" because since
> it's more specific, it will break the similarity between all those
> buttons. In the current design, you immediately see that these buttons
> all refer to the data that is on the same line. If we were to change the
> label to "Rename", we would have to find specific descriptions for every
> field, and the idea is to add more fields - eventually the dialog would
> get harder to read. Since there's only the name on the first button's
> line, I think people will understand - if they are not sure, it's just a
> click away, not a big deal.
>
> --
> users-admin : Scrolling through list resizes listbox
> https://bugs.launchpad.net/bugs/514298
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “gnome-system-tools” package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: gnome-system-tools
>
> When I scroll through the user list, the listbox resizes. This looks _extremely_ unprofessional and ought to be fixed.
> What's even more interesting is that it does it needlessly. I scroll onto root from my own account and it gets wider (!).
>
> Another thing, the symmetry on the right is nice, but it's really not good for naming. Instead of Edit for all three (not very specific), put 'Rename' for the name and 'Change' for the other two. The first has no label so it's not clear what it is initially, and there's no such thing as 'editing' an Account Type, since it's a list of options not a big, configurable thing. One could argue for editing a password, but nobody uses English that way, they say 'change my password'.
>
> Also, 'Help' and 'Close' are a few pixels squished in from the sides and don't align with anything else. It looks weird. :)
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/gnome-system-tools/+bug/514298/+subscribe
>

Milan Bouchet-Valat (nalimilan) wrote :

I've just committed a fix upstream. Long names will be truncated in the list, and wrapped on two lines in the main view. This should solve the problem you've described, and will be released with users-admin 2.29.90. Please continue testing it in Lucid to avoid any regression that may have appeared!

Changed in gst:
status: New → Fix Committed
Changed in gnome-system-tools (Ubuntu):
status: Incomplete → Triaged
Milan Bouchet-Valat (nalimilan) wrote :

Fix released upstream with the gnome-system-tools 2.29.90.

Changed in gst:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-tools - 2.29.90-0ubuntu1

---------------
gnome-system-tools (2.29.90-0ubuntu1) lucid; urgency=low

  * New upstream version
  * Users
    - Fix hangs when changing own password with some PAM setups
    - Update password field to indicate whether password is empty and/or
      asked on login
    - Support disabled accounts, waiting for the backends to report this
    - Sort users and groups list, implement search (LP: #477324)
    - Don't resize window with long user names (LP: #514298)
    - Improve buttons string to be "Change..."
    - Fix "Reload Changes?" dialog shown after creating an user
    - Fix a few leaks of OobsUsers and OobsGroups
  * Services
    - Only commit changes to one service at a time, to avoid many harmful
      issues
    - Remove unlock button, ask for authentication on-the-fly
    - Improve appearance of services list, use some additional icons and
      known services
  * Shares
    - Don't create an OobsIfacesConfig object since it's not used and
      consumes memory
  * Fixes LP: #200105
  * Refreshed patches:
    - 81_gst-packages-shares-admin.patch
    - 90_relibtoolize.patch
  * debian/control:
    - Bump liboobs-dev build-depend to 2.29.90
    - Update Standards-Version to 3.8.4. No other changes required
 -- Chris Coulson <email address hidden> Sun, 14 Feb 2010 18:03:45 +0000

Changed in gnome-system-tools (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers