Users-admin password->password confirm requires 2 Tab keys

Bug #501976 reported by Will Bickerstaff on 2009-12-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GST
Unknown
Low
gnome-system-tools (Ubuntu)
Low
Chris Coulson

Bug Description

Binary package hint: gnome-system-tools

A really minor usability bug. In the change user password dialog (in users-admin), moving from user password to confirmation requires 2 x tab key presses, expected behavior would be 1 x tab key press.

Chris Coulson (chrisccoulson) wrote :

This dialog actually comes from gnome-about-me, reassigning

affects: gnome-system-tools (Ubuntu) → gnome-control-center (Ubuntu)
Changed in gnome-control-center (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Chris Coulson (chrisccoulson) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream. Thanks in advance!

The password dialog in gnome-about-me is different to the one in users-admin and does not suffer from this bug.
gnome-system-tools 2.29.1, I've posted a bug over at bugzilla.gnome.org id=606184

Chris Coulson (chrisccoulson) wrote :

users-admin spawns "gnome-about-me --password" to change the password since Karmic

Thanks chris wasn't aware of that however the dialogs are different and behave differently

Chris Coulson (chrisccoulson) wrote :

Is it your own user password that you are trying to edit, or that of another user? Could you attach a screenshot of the dialog which appears?

Chris, its when changing another users password, screenshot attached

Chris Coulson (chrisccoulson) wrote :

Ah yes, my bad - it's the new g-s-t dialog :)

Confirming the issue there then. I actually need to press TAB twice between the 2 password fields, and twice again to activate the Ok button.

affects: gnome-control-center (Ubuntu) → gnome-system-tools (Ubuntu)
Changed in gnome-system-tools (Ubuntu):
status: New → Triaged
affects: gnome-control-center → gst
Milan Bouchet-Valat (nalimilan) wrote :

Chris, you said you were able to reproduce the problem too? So that wouldn't be specific to the reporter's configuration... I'm absolutely not able to see this, maybe I'll have to get the package form Lucid.

Found it, in the /usr/share/gnome-system-tools/ui/users.ui theres a gtk button behind the confirmation password entry box that can focus its on line 1847 and has id user_settings_chpasswd changing canfocus to false stops the 2xtab keys between password boxes

It looks like this rogue control is added by ubuntu so is probably not a gnome bug http://launchpadlibrarian.net/37396660/gnome-system-tools_2.29.1-0ubuntu2.diff.gz, it doesn't appear in the original source

Good catch indeed! That's the button used to change password when the selected user is the current one. Does the bug appear only with that user? In other cases, it should be hidden.

Anyway, this hack should go away in the next release, with a more generic dialog from upstream.

With the control focus set true, changing the current user password behaves correctly, all other users incorrectly. Set to false changing any users password behaves correctly

Chris Coulson (chrisccoulson) wrote :

Good catch. I'm not sure how that ended up in there though, as that is leftover from the Karmic version and I thought I'd removed all the ui file changes

Changed in gnome-system-tools (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Chris Coulson (chrisccoulson)
Chris Coulson (chrisccoulson) wrote :

Even stranger, is the UI element there is added by an unrelated patch. It got added in this revision here:

http://bazaar.launchpad.net/~ubuntu-desktop/gnome-system-tools/ubuntu/revision/19#debian/patches/82_gst-packages-time-admin.patch

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-tools - 2.29.3-0ubuntu1

---------------
gnome-system-tools (2.29.3-0ubuntu1) lucid; urgency=low

  * New upstream release (LP: #506365)
    - Move to new System Tools Backends protocol (new liboobs API).
      We now only commit changes to one user at a time, reducing the
      risk for dangerous bugs.
    - Include default profiles configuration file (user-profiles.conf).
      Distributors should modify it to suit their needs and send them
      back for inclusion.
    - When creating an user, don't force UID, main group, home directory
      and shell: these parameters are now handled (better) by the platform
      tools (LP: #488158, LP: #313990)
    - Allow removing home directory when deleting an user (LP: #426125).
    - Don't allow deleting the last administrator account, and warn when
      the user is losing its own admin rights. Same for active users
      (LP: #25947, LP: #349453)
    - Don't allow creating a group with an existing GID (LP: #491434)
    - Use UID and GID ranges defined by liboobs, depending on the platform's
      abilities.
    - Clear suggested login entry when Real name is emptied in the new user
      dialog.
    - Change GConf "showall" option to apply only on users. System groups are
      always shown, since they are the most interesting ones.
    - Various UI and string improvements.
    - Change password for current user by running 'passwd', to avoid
      breaking keyrings and encrypted dirs
    - Ask for PolicyKit authentication when it most makes sense, i.e.
      when showing dialogs
    - Option to set encrypted home directories when creating users (on
      platforms that support it) (LP: #302870)
    - When editing one group, only commit changes to that group
    - When changing Real name, update it in the users list (LP: #498970)
    - Select current user on start, and the first one after selected user
      has been deleted
    - Don't force updating configuration twice on start
  * Also fixes LP: #344182, LP: #208057, LP: #188757, LP: #372695,
    LP: #99276, LP: #160862
  * debian/control:
    - Bump liboobs-dev build-dep to 2.29.3
  * debian/gnome-system-tools.install:
    - Don't install debian/profile
    - Install upstream user-profiles.conf instead
  * Delete debian/profiles
  * Refreshed patches:
    - 25_sambashare_group_definition.patch
    - 90_relibtoolize.patch
  * Dropped debian/patches/85_user_gnome_about_me_for_password.patch:
    - The change is obsolete in the new version
  * debian/patches/82_gst-packages-time-admin.patch:
    - Updated to remove superfluous UI file changes, causing focus issues
      in the users-admin password change dialog. Thanks to Will for
      spotting this (LP: #501976)
 -- Chris Coulson <email address hidden> Fri, 05 Feb 2010 15:30:10 +0000

Changed in gnome-system-tools (Ubuntu):
status: Triaged → Fix Released
Changed in gst:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.