users-admin: shortname field does not update when name field is cleared.

Bug #498970 reported by lavinog on 2009-12-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GST
Fix Released
Undecided
Unassigned
gnome-system-tools (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-system-tools
users-admin in Lucid Lynx

Steps to recreate:
Open the create user dialog by clicking Add.
Enter a name like 'Test User' in the name field.
The short name field will update as it is entered.
Then press backspace to erase each character in the name field.
Once the name field is blank, the short name field will show 't' instead of being blank.

Expected behavior:
Clearing name field should cause short name field to be cleared.

This is a very minor issue that shouldn't cause any usability issues, but might be an easy fix.

ProblemType: Bug
Architecture: amd64
Date: Mon Dec 21 01:39:35 2009
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20091215.1)
Package: gnome-system-tools 2.29.1-0ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-9.13-generic
SourcePackage: gnome-system-tools
Tags: lucid
Uname: Linux 2.6.32-9-generic x86_64

lavinog (lavinog) wrote :
description: updated
Milan Bouchet-Valat (nalimilan) wrote :

Thanks for your report. This was indeed a silly detail that I've just fixed. It will be available in the next minor release.

Please continue to report bugs about the gnome-system-tools, especially the next version that should land in Lucid in a month or so. Not many people do this, which makes your testing highly valuable to us.

Changed in gnome-system-tools (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in gst:
status: New → Fix Committed
Milan Bouchet-Valat (nalimilan) wrote :

Fixed in 2.29.2.

Changed in gst:
status: Fix Committed → Fix Released
Changed in gnome-system-tools (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-tools - 2.29.3-0ubuntu1

---------------
gnome-system-tools (2.29.3-0ubuntu1) lucid; urgency=low

  * New upstream release (LP: #506365)
    - Move to new System Tools Backends protocol (new liboobs API).
      We now only commit changes to one user at a time, reducing the
      risk for dangerous bugs.
    - Include default profiles configuration file (user-profiles.conf).
      Distributors should modify it to suit their needs and send them
      back for inclusion.
    - When creating an user, don't force UID, main group, home directory
      and shell: these parameters are now handled (better) by the platform
      tools (LP: #488158, LP: #313990)
    - Allow removing home directory when deleting an user (LP: #426125).
    - Don't allow deleting the last administrator account, and warn when
      the user is losing its own admin rights. Same for active users
      (LP: #25947, LP: #349453)
    - Don't allow creating a group with an existing GID (LP: #491434)
    - Use UID and GID ranges defined by liboobs, depending on the platform's
      abilities.
    - Clear suggested login entry when Real name is emptied in the new user
      dialog.
    - Change GConf "showall" option to apply only on users. System groups are
      always shown, since they are the most interesting ones.
    - Various UI and string improvements.
    - Change password for current user by running 'passwd', to avoid
      breaking keyrings and encrypted dirs
    - Ask for PolicyKit authentication when it most makes sense, i.e.
      when showing dialogs
    - Option to set encrypted home directories when creating users (on
      platforms that support it) (LP: #302870)
    - When editing one group, only commit changes to that group
    - When changing Real name, update it in the users list (LP: #498970)
    - Select current user on start, and the first one after selected user
      has been deleted
    - Don't force updating configuration twice on start
  * Also fixes LP: #344182, LP: #208057, LP: #188757, LP: #372695,
    LP: #99276, LP: #160862
  * debian/control:
    - Bump liboobs-dev build-dep to 2.29.3
  * debian/gnome-system-tools.install:
    - Don't install debian/profile
    - Install upstream user-profiles.conf instead
  * Delete debian/profiles
  * Refreshed patches:
    - 25_sambashare_group_definition.patch
    - 90_relibtoolize.patch
  * Dropped debian/patches/85_user_gnome_about_me_for_password.patch:
    - The change is obsolete in the new version
  * debian/patches/82_gst-packages-time-admin.patch:
    - Updated to remove superfluous UI file changes, causing focus issues
      in the users-admin password change dialog. Thanks to Will for
      spotting this (LP: #501976)
 -- Chris Coulson <email address hidden> Fri, 05 Feb 2010 15:30:10 +0000

Changed in gnome-system-tools (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers