users-admin fakes adding groups with existing gid

Bug #491434 reported by wierdlmate@gmail.com on 2009-12-02
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GST
Fix Released
Undecided
Unassigned
gnome-system-tools (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-system-tools

I start users-admin, and I try to add a new group. The first error (IMO) is that I am presented with gid 0. I leave that, and try to add, say, group oki. The tool shows on the bottom of the list of groups that oki is added. I close tool, but /etc/group shows no group oki. When I reopen users-admin, and I open "manage groups" of course there is no group oki.

You can repeat the same thing with any existing gid: try to add a group with an existing gid, and users-admin will fake adding it.

Both bugs (initial gid 0 and faking the addition of a group with existing gid) are reproducible in Ubuntu 9.10 fully updated.

ProblemType: Bug
Architecture: amd64
Date: Wed Dec 2 09:06:42 2009
DistroRelease: Ubuntu 9.10
Package: gnome-system-tools 2.28.1-0ubuntu2
ProcEnviron:
 PATH=(custom, no user)
 LANG=hu_HU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic
SourcePackage: gnome-system-tools
Uname: Linux 2.6.31-15-generic x86_64
XsessionErrors:
 (gnome-settings-daemon:6494): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:6494): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:6597): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:6586): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (gnome-panel:6585): Gdk-CRITICAL **: gdk_x11_colormap_foreign_new: assertion `GDK_IS_VISUAL (visual)' failed

I noticed that the same happens when you try to add a user with an existing uid. The tool even claims that the new user's home directory is added. On the other hand, at least the initially proposed uid is not 0.

Why not give a *warning* (not error) message when a duplicate uid is given in the tool, and if user confirms, run useradd and groupadd with the -o option.

Milan Bouchet-Valat (nalimilan) wrote :

Yeah, that's already been spotted several times. See bug 475974 for the GID = 0 issue.

I'll fix that for the next release.

Changed in gnome-system-tools (Ubuntu):
importance: Undecided → Medium
status: New → Triaged

To make matters even more confusing, when I add a new user with an existing uid, it doesn't get added, but its usergroup does get added, so the next time I'd try to add the user, the tool will report an error.

Milan Bouchet-Valat (nalimilan) wrote :

This is now fixed upstream, will be included in 2.29.2.

Changed in gst:
status: New → Fix Committed
Milan Bouchet-Valat (nalimilan) wrote :

Fixed in 2.29.2.

Changed in gst:
status: Fix Committed → Fix Released
Changed in gnome-system-tools (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-tools - 2.29.3-0ubuntu1

---------------
gnome-system-tools (2.29.3-0ubuntu1) lucid; urgency=low

  * New upstream release (LP: #506365)
    - Move to new System Tools Backends protocol (new liboobs API).
      We now only commit changes to one user at a time, reducing the
      risk for dangerous bugs.
    - Include default profiles configuration file (user-profiles.conf).
      Distributors should modify it to suit their needs and send them
      back for inclusion.
    - When creating an user, don't force UID, main group, home directory
      and shell: these parameters are now handled (better) by the platform
      tools (LP: #488158, LP: #313990)
    - Allow removing home directory when deleting an user (LP: #426125).
    - Don't allow deleting the last administrator account, and warn when
      the user is losing its own admin rights. Same for active users
      (LP: #25947, LP: #349453)
    - Don't allow creating a group with an existing GID (LP: #491434)
    - Use UID and GID ranges defined by liboobs, depending on the platform's
      abilities.
    - Clear suggested login entry when Real name is emptied in the new user
      dialog.
    - Change GConf "showall" option to apply only on users. System groups are
      always shown, since they are the most interesting ones.
    - Various UI and string improvements.
    - Change password for current user by running 'passwd', to avoid
      breaking keyrings and encrypted dirs
    - Ask for PolicyKit authentication when it most makes sense, i.e.
      when showing dialogs
    - Option to set encrypted home directories when creating users (on
      platforms that support it) (LP: #302870)
    - When editing one group, only commit changes to that group
    - When changing Real name, update it in the users list (LP: #498970)
    - Select current user on start, and the first one after selected user
      has been deleted
    - Don't force updating configuration twice on start
  * Also fixes LP: #344182, LP: #208057, LP: #188757, LP: #372695,
    LP: #99276, LP: #160862
  * debian/control:
    - Bump liboobs-dev build-dep to 2.29.3
  * debian/gnome-system-tools.install:
    - Don't install debian/profile
    - Install upstream user-profiles.conf instead
  * Delete debian/profiles
  * Refreshed patches:
    - 25_sambashare_group_definition.patch
    - 90_relibtoolize.patch
  * Dropped debian/patches/85_user_gnome_about_me_for_password.patch:
    - The change is obsolete in the new version
  * debian/patches/82_gst-packages-time-admin.patch:
    - Updated to remove superfluous UI file changes, causing focus issues
      in the users-admin password change dialog. Thanks to Will for
      spotting this (LP: #501976)
 -- Chris Coulson <email address hidden> Fri, 05 Feb 2010 15:30:10 +0000

Changed in gnome-system-tools (Ubuntu):
status: Fix Committed → Fix Released
atom88 (adam-hiatt) wrote :

How can I upgrade my Ubuntu 9.10 gnome-system-tools from 2.28.1-ubuntu2 to 2.29 ? There are some bugs, such as when adding users that are fixed in 2.29 but in Synaptic Package manager it is only showing the 2.28.1 version as being available?

Milan Bouchet-Valat (nalimilan) wrote :

Karmic is a stable release, which means only bugfix versions are uploaded to it now, i.e. (for GNOME) version with an even minor number. So users-admin 2.29.x is only available in Lucid - you'll have to wait until April to get the fix. BTW, you could see this information by this line in the previous comment:
> gnome-system-tools (2.29.3-0ubuntu1) lucid; urgency=low

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers