[users-admin] users & groups: should have some mention than a session restart is required to apply a group change

Bug #48262 reported by Brad Allen on 2006-06-03
30
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GST
Won't Fix
Wishlist
gnome-system-tools (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: gksu

I'm running Ubuntu Dapper Drake, and created a user called "svn" using the GUI tool found under System->Administration->Users and Groups. I noted that along with this user called "svn" a group of the same name was consequently auto-created. I pressed ok to close.

Next, I decided to add my own account, "ballen", to the group "svn".

Once again, I opened the Users and Groups GUI, then found the group "svn" under the Groups tab. I doubleclicked the "svn" group, then added the "ballen" user to the "svn" group. I then pressed ok to close and closed the Users and Groups GUI.

I quickly discovered that my "ballen" account did not have the priveleges of being a member of the "svn" group. When I typed the "id" command while logged in as "ballen", the "svn" group was nowhere among the list.

After a reboot, the change took effect, and the id command showed "ballen" to be a member of "svn".

Hopefully, you will consider this a bug. It caused me considerable consternation as I suspect it will others.

Thanks!

Sebastian Heinlein (glatzor) wrote :

Generally group changes are only applied on relogin.

Perhaps this should be mentioned on a more central place.

Changed in gksu:
status: Unconfirmed → Rejected

>Generally group changes are only applied on relogin.
>
>Perhaps this should be mentioned on a more central place.

How about in a dialog box informing the user? After all, GUIs are
supposed to help users who may not be so advanced or have read
documentation.

You should file a bug report in GNOME's bugzilla.

Changed in gksu:
status: Rejected → Confirmed

I've forwarded the issue upstream: http://bugzilla.gnome.org/show_bug.cgi?id=343809

Changed in gnome-system-tools:
assignee: nobody → desktop-bugs
Changed in gst:
status: New → Confirmed
Changed in gnome-system-tools (Ubuntu):
status: Confirmed → Triaged
Daniel Hahler (blueyed) wrote :

Xiegai, thanks for your patch.

Please consider forwarding it upstream (https://bugzilla.gnome.org/show_bug.cgi?id=343809), where it belongs.

Additionally, I suggest fixing the message:
"It is strongly recommended that you restart system for the changes to take effect."
to
"It is strongly recommended that you restart the system for the changes to take effect."

Thanks.

tags: added: patch
Daniel Hahler (blueyed) wrote :

Also, it should suggest logging out and in first, because that's easier/faster than rebooting.

Changed in gst:
importance: Unknown → Wishlist
Daniel Hahler (blueyed) wrote :

I've unsubscribed sponsors: this is getting discussed at the gnome bugtracker, and should come into Ubuntu via Gnome.

Changed in gst:
status: Confirmed → Won't Fix
Changed in gnome-system-tools (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.