Misleading message about deleting user directory

Bug #426125 reported by Barry Klein on 2009-09-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GST
Fix Released
Undecided
Unassigned
gnome-system-tools (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-system-tools

Release: Jaunty
Package: gnome-system-tools 2.22.2-0ubuntu4
File: users-admin

Deleting a user gives the following message:

"Are you sure you want to delete the account “<username>”?
This will disable this user’s access to the system without deleting the user’s home directory."

If you delete the user, then try to add a user of that name, you get the message:

"User name “<username>” already exists. Please select a different user name." This is related to bug 129443.

In fact, the “Delete” has deleted the user and the user's home directory but not the user's group.

The message states that the user's home directory will not be deleted, but it is deleted.

Alex Lourie (alourie) on 2009-09-08
Changed in gnome-system-tools (Ubuntu):
status: New → Confirmed
tags: added: bitesize
Milan Bouchet-Valat (nalimilan) wrote :

Hm, you're raising an issue here, but I'd really like you to try the last version in Karmic.

First, I don't think any version of users-admin ever removed the user home directory (which is something I'd like to solve). Could you check that you can reproduce it?

Then, I guess we now have improved the error message recently (i.e. in Karmic). Now we say that the group already exists, which is more correct. I'd like to actually fix this by:
- removing the group when deleting the user, if the user is the only member of it
- if a group already exists with the name of the user, ask to use that group, or change it
But I can't do that now because we're far too close from the GNOME release - only bug fixes should go in. String changes are forbidden, I may still check whether removing the group together with the user would be easy enough to go in now...

As a workaround, if the main group already exists, you can force it to be used by selecting it in the list on the Advanced tab. That's in the Karmic version.

Milan Bouchet-Valat (nalimilan) wrote :

And: bug 129443 you are referring to is not likely to be the number you intended to post here. Would you give me the right report you had in mind?

Oops, sorry.

Correct bug is 192443

Barry

On Tue, 08 Sep 2009 15:26 +0000, "Milan Bouchet-Valat"
<email address hidden> wrote:
> And: bug 129443 you are referring to is not likely to be the number you
> intended to post here. Would you give me the right report you had in
> mind?
>
> --
> Misleading message when deleting user using "Users and Groups"
> https://bugs.launchpad.net/bugs/426125
> You received this bug notification because you are a direct subscriber
> of the bug.

OK, I understand the link with the present bug. I'd like to mark this one as fixed in Karmic, considering the title of the report. The other part of it is bug 192443, which I'll try to fix soon. Could you confirm the problem that the home directory is removed without warning? Seems strange to me. Thanks!

Changed in gnome-system-tools (Ubuntu):
status: Confirmed → Incomplete

I forgot one vital piece of information.

The /etc/deluser.conf file had been edited: REMOVE_HOME=1

I checked the operation of user-admin 'Delete' with both values of
REMOVE_HOME. If it's 0 (the default) the home directory is not removed.
If it's 1, the home directory is removed. The same message is displayed
in both cases.

The console command 'deluser <username>' operates similarly, but deletes
the group (with a relevant message) if the user was the only member of
the group.

Barry Klein

On Wed, 09 Sep 2009 10:09 +0000, "Milan Bouchet-Valat"
<email address hidden> wrote:
> OK, I understand the link with the present bug. I'd like to mark this
> one as fixed in Karmic, considering the title of the report. The other
> part of it is bug 192443, which I'll try to fix soon. Could you confirm
> the problem that the home directory is removed without warning? Seems
> strange to me. Thanks!
>
> ** Changed in: gnome-system-tools (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> Misleading message when deleting user using "Users and Groups"
> https://bugs.launchpad.net/bugs/426125
> You received this bug notification because you are a direct subscriber
> of the bug.

Ah, thanks the precisions. Indeed, in the future I guess I'll add a checkbox that will reflect the state of REMOVE_HOME, and will change it if needed. At least, in the default case, REMOVE_HOME is 0, so the message is right.

summary: - Misleading message when deleting user using "Users and Groups"
+ Misleading message about deleting user directory
Changed in gnome-system-tools (Ubuntu):
status: Incomplete → Confirmed
Milan Bouchet-Valat (nalimilan) wrote :

OK, this is now in 2.29.2, should be in Lucid soon.

Changed in gst:
status: New → Fix Released
Changed in gnome-system-tools (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Changed in gnome-system-tools (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-tools - 2.29.3-0ubuntu1

---------------
gnome-system-tools (2.29.3-0ubuntu1) lucid; urgency=low

  * New upstream release (LP: #506365)
    - Move to new System Tools Backends protocol (new liboobs API).
      We now only commit changes to one user at a time, reducing the
      risk for dangerous bugs.
    - Include default profiles configuration file (user-profiles.conf).
      Distributors should modify it to suit their needs and send them
      back for inclusion.
    - When creating an user, don't force UID, main group, home directory
      and shell: these parameters are now handled (better) by the platform
      tools (LP: #488158, LP: #313990)
    - Allow removing home directory when deleting an user (LP: #426125).
    - Don't allow deleting the last administrator account, and warn when
      the user is losing its own admin rights. Same for active users
      (LP: #25947, LP: #349453)
    - Don't allow creating a group with an existing GID (LP: #491434)
    - Use UID and GID ranges defined by liboobs, depending on the platform's
      abilities.
    - Clear suggested login entry when Real name is emptied in the new user
      dialog.
    - Change GConf "showall" option to apply only on users. System groups are
      always shown, since they are the most interesting ones.
    - Various UI and string improvements.
    - Change password for current user by running 'passwd', to avoid
      breaking keyrings and encrypted dirs
    - Ask for PolicyKit authentication when it most makes sense, i.e.
      when showing dialogs
    - Option to set encrypted home directories when creating users (on
      platforms that support it) (LP: #302870)
    - When editing one group, only commit changes to that group
    - When changing Real name, update it in the users list (LP: #498970)
    - Select current user on start, and the first one after selected user
      has been deleted
    - Don't force updating configuration twice on start
  * Also fixes LP: #344182, LP: #208057, LP: #188757, LP: #372695,
    LP: #99276, LP: #160862
  * debian/control:
    - Bump liboobs-dev build-dep to 2.29.3
  * debian/gnome-system-tools.install:
    - Don't install debian/profile
    - Install upstream user-profiles.conf instead
  * Delete debian/profiles
  * Refreshed patches:
    - 25_sambashare_group_definition.patch
    - 90_relibtoolize.patch
  * Dropped debian/patches/85_user_gnome_about_me_for_password.patch:
    - The change is obsolete in the new version
  * debian/patches/82_gst-packages-time-admin.patch:
    - Updated to remove superfluous UI file changes, causing focus issues
      in the users-admin password change dialog. Thanks to Will for
      spotting this (LP: #501976)
 -- Chris Coulson <email address hidden> Fri, 05 Feb 2010 15:30:10 +0000

Changed in gnome-system-tools (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers