[network-admin] freezes when autodetecting internal winmodem

Bug #23997 reported by Dean Michael Berris on 2005-10-15
12
Affects Status Importance Assigned to Milestone
gnome-system-tools (Ubuntu)
Low
Michael Vogt

Bug Description

In the network-manager (network settings) dialog, I was surprised to see that
there is an entry for a modem (which my ECS Desknote A530 has) -- but it's a
winmodem. I then tried to configure the modem, and tried to autodetect it using
the Properties dialog for the modem entry. After canceling the dialog after a
while of waiting, the network settings dialog remains busy and I cannot do
anything with it (everything is greyed out, seems to be waiting for something).

To reproduce, on a laptop with an internal winmodem, check to see if the network
settings dialog shows an entry for a modem connection. If so, select it and then
click on Properties. Click on the option to autodetect the device. Application
becomes unresponsive and busy.

For laptop details: http://wiki.ubuntu.com/HardwareMachinesSupportECS

Kai F. Lahmann (kfl) wrote :

..wrong tool.

Changed in gnome-system-tools:
assignee: j-bootlab → mvo
Sebastien Bacher (seb128) wrote :

Thanks for your bug. What version of Ubuntu do you use? What do you call "autodetect it"? Do you still have the issue? Could you get a backtrace of the hang using gdb? When the tools hang, run "sudo gdb -p $(pidof network-admin)" for a command line and "thread apply all bt" and copy that to a comment

Changed in gnome-system-tools:
status: Unconfirmed → Needs Info
importance: Medium → Low
Basilio Kublik (sourcercito) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New".

Thanks again!

Changed in gnome-system-tools:
status: Incomplete → Invalid
Andres Herrera (andresh) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Hardy Heron. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at [WWW] http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.