[network-admin] Dial out does not work

Bug #22119 reported by Martin Willemoes Hansen on 2005-09-20
28
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GST
Unknown
Medium
gnome-system-tools (Ubuntu)
High
Unassigned

Bug Description

On Breezy preview 1 on a HP NC4200.

1. Setup panel applet to dial to a number (my mobile).
2. Activate the connection

Nothing happens, my mobile is not getting a call.
Works in Hoary.

http://bugs.gnome.org/show_bug.cgi?id=316989: http://bugs.gnome.org/show_bug.cgi?id=316989

Daniel Holbach (dholbach) wrote :

Thanks for the bug report, I took the issue upstream:
http://bugs.gnome.org/show_bug.cgi?id=316989

Daniel Holbach (dholbach) wrote :

Comment #1 from Carlos Garnacho Parro 2006-01-02 11:48 UTC

can you attach all the configuration files? (/etc/ppp/*) and the logs that pppd
outputs?

Martin Willemoes Hansen (mwh) wrote :

Created an attachment (id=5594)
syslog

Martin Willemoes Hansen (mwh) wrote :

Created an attachment (id=5595)
/etc/ppp/*

Martin Willemoes Hansen (mwh) wrote :

modem, doesnt work on dapper either. The logs and /etc/ppp/* is from dapper.

Daniel Holbach (dholbach) wrote :

I forwarded your comments upstream.

Changed in gnome-system-tools:
status: Unconfirmed → Confirmed
Changed in gnome-system-tools:
status: Confirmed → Unconfirmed
Changed in gnome-system-tools:
assignee: dholbach → desktop-bugs
Martin Willemoes Hansen (mwh) wrote :

Same issue Edgy 2

Changed in gnome-system-tools:
status: Unconfirmed → Confirmed
Gert Kulyk (gkulyk) wrote :

According to syslog and settings in /etc/ppp/peers/* a device /dev/modem is assumed which does not exist. Instead, the real device name should be added (e.g. /dev/ttySL0 for smartlink-alsa-driver, /dev/slamr0 for non-free driver, /dev/ttyS0 for serial modem etc.) . Udev no-longer creates a /dev/modem link as far as I know. Only for "ttyLTM[0-9]*" (whatever kind of device that is, maybe lucent?) in /etc/udev/rules.d/60-symlinks.rules a symlink is set up. You may modify this setting according to your needs, too, if you want to have a /dev/modem symlink (which is still hardcoded for some programs).

Daniel Holbach (dholbach) wrote :

I forwarded your comment upstream.

Daniel Holbach (dholbach) wrote :

Upstream comment: "As far as I can see, this happens because either /dev/modem doesn't exist or
isn't a valid serial device, if I point the configuration file to a non-existing link pppd spews the same error, but as soon as I make it point to /dev/ttyS0 it tries to communicate. I'll close it as NOTGNOME at the moment, please reopen if this is not the case for him."

Changed in gst:
status: Unconfirmed → Rejected
Martin Willemoes Hansen (mwh) wrote :

/dev/modem does not exist.

Although when I use /dev/ttyS0 to ring to my mobile, nothing happens.

Same issue in Edgy final release (with an external U.S. Robotics 56k modem), while there were no problems in Dapper.

Nothing happens using neither /dev/modem nor /dev/ttyS0.

Konstantinos Tampouris (ktamp) wrote :

In Edgy this is caused by incorrectly setting the dial-out command to "ATDTW" or "ATDPW" instead of "ATDT" or "ATDP" in /etc/chatscripts/ppp0.

Konstantinos Tampouris (ktamp) wrote :

The quick and dirty way to fix things for Edgy: Go to file /usr/share/system-tools-backends-2.0/scripts/Network/Ifaces.pm, line 3137 (subroutine get_interface_replace_table, section "debian-3.0") and remove 'W' from between %external_line% and %phone_number%.

Carlos Garnacho (carlosg) wrote :

The "W" issue is already fixed in system-tools-backends HEAD

Bill Barmettler (bpbar) wrote :

Hey, guys, I'm sorry if I'm in the wrong place for this...never tried to file a bug.

The Networking setup isn't working for me and my USR Sportster either, but some of the problem is not mentioned here. I set it up as "Tones" in the modem properties. Close and go back it's reverted to "Pulse". I'm not very good with Linux, sorry, but I can't figure out how to delete the entries and start over. Edgy refuses to let go of the "Pulse" setting. Tones is what i used in Dapper and that worked.

Another forum member checked it out and confirmed.
http://ubuntuforums.org/showthread.php?t=330467

Modem Monitor never gives me "Activate" - it's always grayed out. Have no idea if that's related to the Tone/Pulse idiosyncracy.

Also, I guess this isn't a bug, but I sure miss the little "Activate" button in Networking.

FLPCGuy (strapane) wrote :

re: "The quick and dirty way to fix things for Edgy: Go to file /usr/share/system-tools-backends-2.0/scripts/Network/Ifaces.pm, line 3137 (subroutine get_interface_replace_table, section "debian-3.0") and remove 'W' from between %external_line% and %phone_number%."

This helps, but still doesn't resolve all the issues probably related to having no /dev/modem. If I configure my modem connection to /dev/ttyS0 and other ISP info, it will dial and connect fine, but I still have a grayed out sync to timeserver button, can't install firestarter, or do other things that require awareness of a network connection.

Networking for dial-up needs fixing in Feisty and testing by someone who can get the test Herds and try them via external dial-up. I wish I could help but don't have access to a broadband connection at all anymore. I can't save all the modem settings...modem config keeps defaulting to pulse after I have set tone dialing, for example.

I'm just manually connecting via PPP either from terminal or KPPP. Fortunately, Firefox has no problems with that. If this isn't enough to identify something to work on, how about adding a Connect/Disconnect button in networking for modem users? I don't always need to be online and don't like not being able to disconnect without shutting down.

Michael Losonsky (michl) wrote :

>Networking for dial-up needs fixing in Feisty

Yes this still is an issue in Feisty and it was an
issue in Edgy. System->Administration->
Network still does not allow you to enable a
dial-up modem. Also, the problem with it
reverting to pulse after you set it to tone is
still an issue.

It is not a problem with the modem. Wvdial
recognizes the modem and you can dial out
with it. But the dial-up in Network should really
work!

Michael Losonsky (michl) wrote :

In the final Feisty release, the modem in Admin -> Networking now works enough
to let you configure the modem and dial out and connect. However the modem
now keeps disconnecting. This also happens with wvdial in Feisty (which was
not the case in 6.10 and 6.06). The disconnecting seems to be related to the
ppp daemon.

jkohler2 (jkohler2) wrote :

My laptop is a Dell 4150 and my pcmcia modem is an old IBM datafax 56k unit with an x-jack connector (model fru 02k4248).

The last versino of Linux that would detect the modem and dial out was Fedora 3 which had a program KUDZU that found the modem during installation and called it a "generic" modem.
The GNOME network configuration program identified the modem as ttyS3 and local dial up was perfect.

From Fedora 4 on up, the pcmcia driver in the kernel changed from PCMCIA-cs to PCMCIA -utils
and no version of Fedora will drive the modem now.

I tried Ubuntu 6 and 7 and used the GNOME network configuration to run ppp0 and the dial up modem.

All the values stay in place except the tone/pulse selection which keeps going back to pulse on my system.

Are PCMCIA modems out of date for all current Linux Kernels, including Ubuntu?

John

Guy S (guyshipard) wrote :

I have had this problem with Ubuntu 8.04, and later 8.04.1, even with all the latest updates. I use a dial up modem and phone line to access the internet. After installing Ubuntu, I can go to System - Administration - Network, put in the correct information, and access the internet. If the computer is left on after disconnecting from the internet, I can connect again, as many times as I like. However, if the computer is turned off, then restarted, and an attempt is made to connect to the internet, the modem beeps as if it is beginning to dial the number then stops, and does not connect to the internet. I have found, if I untick the box, enable this connection, which deletes all of the information, reboot the computer, enter all of the information in again, it works.
I have overcome this by installing KPPP, which I use to successfully access the internet.
I am using a 667 mHz computer with 512 mb of RAM, with a Banksia Wave sp 336 external modem. There is a possibility it may work OK on faster computers.
However, most people now use broadband. People using dial up modems may have given up if they had this problem and changed to other operating systems.

security vulnerability: yes → no

Thank you for posting this bug.

Does this occur in Lucid?

Changed in gnome-system-tools (Ubuntu):
status: Confirmed → Incomplete

rusivi1: I don't think it really makes sense to ask people to test network-admin in Lucid, since (as I said) the Interfaces tab is not present. Better leave these bugs open until 1) we get that tab back, or 2) we decide to keep it removed, and close all bugs without asking.

Thanks for going over that painful process of closing old bugs, but in this precise case people will feel fooled since they have no way to check...

Changed in gst:
importance: Unknown → Medium
status: Invalid → Unknown
jkohler2 (jkohler2) wrote :

I stopped using the PCMCIA modem as soon as I got a laptop with USB ports.
The 2 USB modems I have now, Zoom and US Robotics, work perfectly with
Gnome-PPP under Ubuntu 10.04, both at the user and the superuser level.
Thanks to all you developers in Linux, Ubuntu, and GNOME!

lowdowngt (yaax.gt) wrote :

I have a Asus mobo P5G41C-M, Pentium D 3.0Ghz., 2Gb ram, I install Ubuntu 10.04 and 10.10 but the network don't work. In Win 7 it's works.

Marking as confirmed.

Changed in gnome-system-tools (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody

I'm sorry that nobody has looked at this bug earlier and could have made a fixed.

My question is: Who is still effected by this bug? Please use only an Ubuntu version starting with 12.04 LTS.

Thank you very much for you feedback!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.