users-admin crashed with SIGSEGV in strcmp(), and then on next run failed to add groups or users

Bug #207804 reported by Craig Taverner on 2008-03-27
30
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GST
Expired
Critical
gnome-system-tools (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-system-tools

AMD64 Hardy Beta
Description: Ubuntu hardy (development branch)
Release: 8.04
gnome-system-tools:
  Installed: 2.22.0-0ubuntu3

Used 'System -> Administration -> Users and groups' to try add a new user and a new group. The tool crashed on first use. It did not crash on later uses, but silently failed to add users or groups.

First use sequence:
start users-admin
manage-groups
close #manage groups
unlock, and authenticate
manage-groups
# added new group
add user # crashed

Second use sequence:
start users-admin
unlock, and authenticate
add user, and added user with all required info, but did not find previous group
closed users-admin
sudo -s # and went to /etc to check passwd, group etc, but found no trace of new user or group

ProblemType: Crash
Architecture: amd64
Date: Thu Mar 27 16:43:47 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/users-admin
NonfreeKernelModules: nvidia
Package: gnome-system-tools 2.22.0-0ubuntu3
PackageArchitecture: amd64
ProcCmdline: users-admin
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: gnome-system-tools
StacktraceTop:
 strcmp () from /lib/libc.so.6
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: users-admin crashed with SIGSEGV in strcmp()
Uname: Linux 2.6.24-12-generic x86_64
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev video
SegvAnalysis:
 Segfault happened at: 0x7f50af1ceb32 <strcmp+2>: cmp (%rsi),%al
 PC (0x7f50af1ceb32) ok
 source "(%rsi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%al" ok
SegvReason: reading NULL VMA

Craig Taverner (craig-amanzi) wrote :

StacktraceTop:strcmp () from /lib/libc.so.6
privileges_table_set_from_profile (profile=0x6f6520) at privileges-table.c:238
table_set_default_profile (tool=0x656810) at table.c:163
user_settings_dialog_new (user=0x0) at user-settings.c:395
on_user_new_clicked (button=<value optimized out>, user_data=0x0) at callbacks.c:274

Changed in gnome-system-tools:
importance: Undecided → Medium
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=524680

Changed in gnome-system-tools:
assignee: nobody → desktop-bugs
status: New → Triaged
royden (ryts) wrote :

I got a segfault from users-admin with "users-admin crashed with SIGSEGV in strcmp()" whilst logged in as root (yes, I know :) but it worked in making the user. Noticed crash report via apport when logged back in as normal user.

Worth adding to the Gnome number or a forgetter as it seems not to effect matters?

ryts

royden (ryts) wrote :

Sorry - this is on Hardy latest.....

ryts

Saivann Carignan (oxmosys) wrote :

How to reproduce the crash :

1. open it
2. unlock
3. "manage groups"
4. add a group (which will be an noname-one)
5. quit "manage groups"
6. "add user"

Saivann Carignan (oxmosys) wrote :

bug 205144 fixed problems with users-admin. Can someone test if this bug can be reproduced in Hardy?

Changed in gnome-system-tools:
status: Triaged → Fix Released
status: Fix Released → Triaged
Chris Coulson (chrisccoulson) wrote :

I don't get the crash anymore with the latest version (using the steps above). However, the original reporter mentioned it silently failing to add users and groups afterwards. I can add and delete groups now the fix for bug 205144 is in, but I still can't add or delete users, and I seem to be in a minority. I've opened a new bug report for this though, as I don't think it's related (bug 220697)

Saivann Carignan (oxmosys) wrote :

Ok then we should keep this bug open until the upstream bug is fixed.

Changed in gst:
status: Unknown → New
Kees Cook (kees) on 2009-09-16
description: updated

Any trace of this bug in Karmic (or at least Jaunty)? I really can't afford going through our code in Hardy to check where this was coming from, we have already enough bugs to tackle in recent versions. The trace upstream is too old, I'll have to close the report there without more information.

OK, I'm closing the report since the trace is largely outdated, and nobody reported it occurring in recent releases. Moreover, that code has much changed again in the development version, so it's likely to be fixed. If the bug comes back, please feel free to open a new report, I'll look at it. Thanks!

Changed in gnome-system-tools (Ubuntu):
status: Triaged → Invalid

Sorry for not replying to your previous email, I was on vacation and rushed
through my emails on return.

I have not seen this bug in any later releases since then. In fact I think
later updates to hardy fixed it also. So if it was not explicitly fixed, it
was fixed as a side effect of related bug fix(es).

On Sun, Jan 31, 2010 at 11:40 AM, Milan Bouchet-Valat <email address hidden>wrote:

> OK, I'm closing the report since the trace is largely outdated, and
> nobody reported it occurring in recent releases. Moreover, that code has
> much changed again in the development version, so it's likely to be
> fixed. If the bug comes back, please feel free to open a new report,
> I'll look at it. Thanks!
>
> ** Changed in: gnome-system-tools (Ubuntu)
> Status: Triaged => Invalid
>
> --
> users-admin crashed with SIGSEGV in strcmp(), and then on next run failed
> to add groups or users
> https://bugs.launchpad.net/bugs/207804
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Cool. Thanks for the feedback!

Changed in gst:
importance: Unknown → Critical
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.