shows root user in users-admin

Bug #188757 reported by Tormod Volden on 2008-02-03
6
Affects Status Importance Assigned to Milestone
GST
Fix Released
Undecided
Unassigned
gnome-system-tools (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: gnome-system-tools

After a default, clean install of Ubuntu Hardy Alpha 4, when I start users-admin it shows the root user in addition to the user I defined during installation. Not very consistent with the policy and explanation in for instance man sudo_root.

Changed in gnome-system-tools:
importance: Undecided → Wishlist
Tormod Volden (tormodvolden) wrote :

This was brought up a year ago (https://lists.ubuntu.com/archives/ubuntu-users/2006-November/098963.html) but the discussion didn't go anywhere.

Miguel Ruiz (mruiz) wrote :

Hi,

Thank you for taking the time to report this bug and helping to make Ubuntu better. I'm using Hardy Heron up to date and I confirm this issue.

Thanks again and we appreciate your help.

Cheers!

Changed in gnome-system-tools:
status: New → Confirmed
Milan Bouchet-Valat (nalimilan) wrote :

Development version upstream has a GConf option to show root, which means its hidden by default.

Changed in gst:
status: New → Fix Committed
Changed in gnome-system-tools (Ubuntu):
status: Confirmed → Triaged
C de-Avillez (hggdh2) wrote :

I was looking at upstream GIT, and this has been fixed there, so we should have it on next update for Lucid.

Milan Bouchet-Valat (nalimilan) wrote :

Fixed in 2.29.2.

Changed in gst:
status: Fix Committed → Fix Released
Changed in gnome-system-tools (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-tools - 2.29.3-0ubuntu1

---------------
gnome-system-tools (2.29.3-0ubuntu1) lucid; urgency=low

  * New upstream release (LP: #506365)
    - Move to new System Tools Backends protocol (new liboobs API).
      We now only commit changes to one user at a time, reducing the
      risk for dangerous bugs.
    - Include default profiles configuration file (user-profiles.conf).
      Distributors should modify it to suit their needs and send them
      back for inclusion.
    - When creating an user, don't force UID, main group, home directory
      and shell: these parameters are now handled (better) by the platform
      tools (LP: #488158, LP: #313990)
    - Allow removing home directory when deleting an user (LP: #426125).
    - Don't allow deleting the last administrator account, and warn when
      the user is losing its own admin rights. Same for active users
      (LP: #25947, LP: #349453)
    - Don't allow creating a group with an existing GID (LP: #491434)
    - Use UID and GID ranges defined by liboobs, depending on the platform's
      abilities.
    - Clear suggested login entry when Real name is emptied in the new user
      dialog.
    - Change GConf "showall" option to apply only on users. System groups are
      always shown, since they are the most interesting ones.
    - Various UI and string improvements.
    - Change password for current user by running 'passwd', to avoid
      breaking keyrings and encrypted dirs
    - Ask for PolicyKit authentication when it most makes sense, i.e.
      when showing dialogs
    - Option to set encrypted home directories when creating users (on
      platforms that support it) (LP: #302870)
    - When editing one group, only commit changes to that group
    - When changing Real name, update it in the users list (LP: #498970)
    - Select current user on start, and the first one after selected user
      has been deleted
    - Don't force updating configuration twice on start
  * Also fixes LP: #344182, LP: #208057, LP: #188757, LP: #372695,
    LP: #99276, LP: #160862
  * debian/control:
    - Bump liboobs-dev build-dep to 2.29.3
  * debian/gnome-system-tools.install:
    - Don't install debian/profile
    - Install upstream user-profiles.conf instead
  * Delete debian/profiles
  * Refreshed patches:
    - 25_sambashare_group_definition.patch
    - 90_relibtoolize.patch
  * Dropped debian/patches/85_user_gnome_about_me_for_password.patch:
    - The change is obsolete in the new version
  * debian/patches/82_gst-packages-time-admin.patch:
    - Updated to remove superfluous UI file changes, causing focus issues
      in the users-admin password change dialog. Thanks to Will for
      spotting this (LP: #501976)
 -- Chris Coulson <email address hidden> Fri, 05 Feb 2010 15:30:10 +0000

Changed in gnome-system-tools (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers