Unlock button throws an error, doesn't authenticate

Bug #187335 reported by kstanoev on 2008-01-30
30
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-system-tools (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-system-tools

In Users and Groups, Date and Time, and Network Manager, there is an Unlock button, which I guess replaces prompting for a sudo password upon clicking on them. When I click on it, the message "Could not authenticate" and "an unknown error has ocured" is displayed. When I run users-admin from the console, when I click on it "** (users-admin:11615): CRITICAL **: The name org.gnome.PolicyKit was not provided by any .service files" is displayed in the console.
When I run "sudo users-admin" immediately "** (users-admin:11618): CRITICAL **: Unable to lookup session information for process '11618'" is displayed in the terminal window. When run with sudo, the Unlock button is not clickable but I do not have administrative priviledges.

kstanoev (civ-mail) wrote :

I'm sorry, this is the first time I've tried to report a bug... I thought this would automactically be assigned to Hardy. Also I forgot important details.
This occurs in Hardy Alpha 3 with the latest update. The version of gnome-system-utils is 2.21.5.1-0ubuntu1 and also I'm using Xubuntu.

Pedro Villavicencio (pedro) wrote :

Thanks for your report, It sounds like a broken dbus session, can you look if dbus is running?

Changed in gnome-system-tools:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
kstanoev (civ-mail) wrote :

dbus is running, I ran dbus-monitor and "ps x | grep dbus". dbus-monitor outputs nothing when I click on Unlock, though it does upon launch and close of the apps. I'm attaching the output of these.

Basilio Kublik (sourcercito) wrote :

Hi there
do you still experience this issue?

Thanks

kstanoev (civ-mail) wrote :

Well, it does not occur in a fresh install of Hardy Alpha 5, if there's anything else I need to do, just tell me.

I can confirm that bug with Hardy Alpha 6 from alternate install. I was unable to use 'Unlock' button with fresh install and it still doesn't work for me with all available updates installed.

When I click 'Unlock' button it hangs for some time and then displays "Could not authenticate" error message.

Here's the output from terminal:

$ users-admin

** (users-admin:7549): CRITICAL **: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Looks like I found the solution. I added my regular user to 'admin' group and restarted the system. After that I'm able to use the 'Unlock' button and other features like proprietary driver management are working now too.

It means that regular user wasn't included in 'admin' group by default in Hardy Alpha 6 alternate install.

One-Man-Bucket (erik-lindblad) wrote :

I had the same problem. I run 8.04 upgraded from 7.10 on a laptop with an attached screen. Two instances of gnome (no xinerama).

After checking that I had my account added to /etc/group to admin and polkitusers groups and reconfiguring the package i discovered that the button actually did work, however only on the laptop-screen.

If I start an administrative tool on my laptop screen everything works fine, but if i try to do the same on the external screen i get an "unexpected error".

This really seems like a bug in whatever voodoo that handles policykit. Like it can't bind to the correct window manager or something.

Josh Hill (ingenium) wrote :

I'm having the same problem. Sometimes when I click unlock, nothing happens, and sometimes it gives me the error message about an unknown error occurring. I was already in the admin group, but I added myself to the polkitusers group and I'm still having the problem.

I'm not sure if it matters, but when I upgraded I had a lot of errors in dbus but it said it was OK because there was an upgrade in progress. Then the first boot had a lot of program crashes, but after that everything seemed fine. So perhaps this could be a dbus issue?

Sam_ (and-sam) wrote :

Hi,
I'd like to note it's related to bug #227383, thanks.

bsh (bsh) wrote :

I have the same problem here. When I log in to the pc, everything seems to be working fine. However, when i log in from elsewhere, using vnc, there are many things not working. Like the "unlock" button.

Gilbert Mendoza (gmendoza) wrote :

Just ran into this bug. Clean installation of Ubuntu Desktop 8.04.

Running "users-admin" from console works as expected.
Running "users-admin" or "sudo users-admin" from remote connection (e.g. ssh X11 forwarding, NXClient, etc) does not allow administrative access to unlock the tool.

The error given is:
** (users-admin:9673): CRITICAL **: Unable to lookup session information for process '9673'

aquasync (aquasync) wrote :

Yeah I think I'm hitting this too. Also a vanilla Ubuntu Desktop 8.04 install.

If I ssh -X in, users-admin fails with the "Unable to lookup session information" error. This worked fine from Dapper through to Feisty (ie pre-policy kit mess).

If it helps:

% polkit-auth --show-obtainable
% ck-list-sessions
%

^ Both of them return nothing at all! (in the ssh session)

Gilbert Mendoza (gmendoza) wrote :

Folks... for those of you trying to remotely run applications and are not presented with the unlock option, Martin Pitt came up with the solution in another bug report. [1]

System -> Administration -> Authorizations -> org, freedesktop, systemtoolsbackends, Manage system configuration.

Modify the "Implicit Authorizations" with the Edit button, and change the "Anyone" value to "Admin Authentication". (Screenshot attached)

I am now able to unlock tools managed by policy kit remotely (e.g. SSH forwarding, NX, etc).

[1] https://bugs.launchpad.net/bugs/183673

Gilbert Mendoza (gmendoza) wrote :

Sorry folks... I misspoke. NoMachine does not work for me either. I'm still investigating.

A cheesy workround until then is to "ssh -XC localhost" from the NoMachine session.

Fresh install of 8.04.1, and I randomly see this error without any remote anything. Sometimes the error appears, and other times it works, with no rhyme or reason, except that it fails more consistently when I click and type more slowly.

hakinchen (hakinchen) wrote :

Hi all,

i have the same problem under 8.10 Alpha 6.
with "users-admin" under root-rights, i can't unlock.

best wishes

Feanor (angelo-pantano) wrote :

same here with intrepid, i reinstalled policykit and gnome-system-tools, but no luck, with a normal user i cannot unlock the panel

I just installed Ubuntu 8.10 desktop as a guest on a vmware server 2.0 running on CentOS. Seems that this problem still exists, unfortunately I won't be able to connect locally to verify that remote connection is in fact the culprit. Any solutions for this problem?

sektor (sektor-dsli) wrote :

In response to Gilbert Mendoza's post regarding to Martin Pitt's solution about editing the policy, if you are having issues modifying the policy open a terminal window and type the following sudo polkit-gnome-authorization, then edit the policy listed above and the unlock buttons will work from a remote location. I just did it on my machine and I have a windows session running via Xnest.

Using Ubuntu 8.10 32 bits fully updated/upgraded i have this issue if i try to set date and time option using the menu System → Administration → Date and time

Thank you

Josh Hill (ingenium) wrote :

I believe this is a dbus issue, and it went away when I increased the number of connections allowed by dbus. To do this, create the file /etc/dbus-1/system-local.conf and add to it:

<!DOCTYPE busconfig PUBLIC
 "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
 <limit name="max_connections_per_user">256</limit>
</busconfig>

Save and restart.

Fabien Chéreau (xalioth) wrote :

Josh, I tried this on my ubuntu and it didn't change a thing.
Fabien

Daniel Martin Yerga (yerga) wrote :

I was hitting the same problem in Debian.

So it's how I have fixed it:
Go to synaptic or apt-get and then install policykit-gnome and libpolkit-gnome0

Please, comment if this fixed your problems.

Stefano Prenna (stefanoprenna) wrote :

What solved the issue for me has been:

1. Purge policykit (please note that this will remove ubuntu-desktop as well) from Synaptics
2. As Ubuntu-desktop has been removed I had to manually reconnect to the LAN (the network manager applet has been removed as well)
3. Reinstall ubuntu-desktop
4. Reboot the machine

blaz (bdl) wrote :

"Go to synaptic or apt-get and then install policykit-gnome and libpolkit-gnome0"

Fixed my problem. But then I too am running Debian ...

nadrimajstor (majstor) wrote :

I've had same problem.
Running Ubuntu 9.04, policykit 0.9-2ubuntu1, dbus 1.2.12-0ubuntu2.1

Ubuntu was installed as guest system in VirtualBox, then transfered to a real-world machine, leaving VirtualBox add-on kernel modules installed. Because of missing VirtualBox host system, addon kernel modules didn't start on boot, resulting in no creation of home folder for vboxadd user. This triger error 'Unable to lookup session information for process' on system tools authentication.

Solution: Delete vboxadd user if you don't need it anymore or add /nonexistent for homedir as suggested in https://bugs.launchpad.net/bugs/232278

Note that users with missing homedir, will also triger dbus error when Nautilus try to automount NTFS partition.

nadrimajstor: the problem with empty home dir field has nothing to do with the present report. To me, that's bug 316667, which will be fix very soon in Karmic. The present bug is not very clear to me, and it may be fixed by the move to PolicyKit1 in Karmic.

Could somebody confirm it can be seen in Karmic BTW?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions