time-admin window doesn't install ntp when prompted

Bug #1666951 reported by Paul White on 2017-02-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-system-tools (Ubuntu)
Undecided
Unassigned

Bug Description

I'm using Xubuntu 17.04 but I don't think this problem is specific to Xubuntu.

By default, "Configuration" in "Time and Date Settings" is set to "Manual". If I change the option to "Keep synchronized with Internet servers" I am prompted to "Install NTP support" or to cancel the change. Obviously this is only when the ntp package isn't already installed.

Clicking on "Install NTP support" displays a notification window to say that an application is requesting additional packages and that is can be found in "Software". Clicking on that window brings up gnome-software which says that the requested package cannot be found.

I'm sure that in the past I was prompted for my administrator password as would be expected when installing software.

Recent updates have changed what is seen after asking for ntp to be installed.

*UPDATE*

For Xubuntu, the expected dialogs appear and ntp is installed.

For Lubuntu, an error message is now displayed:

*Could not install package*

GDBus.Error:org.freedekstop.org.DBus.Error.ServiceUnknown: the name org.freedesktop.PackageKit was not provided by an service files

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: gnome-system-tools 3.0.0-4ubuntu3
ProcVersionSignature: Ubuntu 4.10.0-8.10-generic 4.10.0-rc8
Uname: Linux 4.10.0-8-generic x86_64
ApportVersion: 2.20.4-0ubuntu2
Architecture: amd64
CasperVersion: 1.380
CurrentDesktop: XFCE
Date: Wed Feb 22 15:16:50 2017
ExecutablePath: /usr/bin/time-admin
LiveMediaBuild: Xubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20170222)
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-system-tools
UpgradeStatus: No upgrade log present (probably fresh install)

Paul White (paulw2u) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1666951

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-system-tools (Ubuntu):
status: New → Confirmed
Paul White (paulw2u) wrote :

For 17.04 I've found this problem affecting Lubuntu and Xubuntu but not Ubuntu or Ubuntu MATE. Other flavours not (yet) tested.

tags: added: lubuntu xubuntu
Paul White (paulw2u) wrote :

No longer seeing this issue with Xubuntu 64 and 32-bit ISOs as of 20170326

Paul White (paulw2u) wrote :

Re Xubuntu, with ISO of 20170328 I'm still not seeing this bug - good!

With Lubuntu ISO 20170327 (64 bit, 32 bit not tested) I'm now seeing an error message of:

Could not install package

GDBus.Error:org.freedekstop.org.DBus.Error.ServiceUnknown: the name org.freedesktop.PackageKit was not provided by an service files

Paul White (paulw2u) on 2017-03-28
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers