time-admin can not install ntp

Bug #1270090 reported by Sergio Benjamim on 2014-01-17
84
This bug affects 15 people
Affects Status Importance Assigned to Milestone
gnome-system-tools (Ubuntu)
Medium
Alistair Buxton

Bug Description

xfce4-panel clock can not install ntp, take a look at the image.

"Could not install package
The necessary applications to install the package could not be found"

I can install ntp by apt-get, and it works at the clock.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xfce4-panel 4.10.1-1ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-3.18-generic 3.13.0-rc8
Uname: Linux 3.13.0-3-generic x86_64
ApportVersion: 2.13.1-0ubuntu1
Architecture: amd64
Date: Fri Jan 17 11:51:15 2014
InstallationDate: Installed on 2014-01-09 (7 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140109)
ProcEnviron:
 LANGUAGE=fr_FR
 TERM=xterm
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: xfce4-panel
UpgradeStatus: No upgrade log present (probably fresh install)

Sergio Benjamim (sergio-br2) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1270090

tags: added: package-qa-testing
affects: xfce4-panel (Ubuntu) → gnome-system-tools (Ubuntu)
summary: - xfce4-panel clock can not install ntp
+ time-admin can not install ntp
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-system-tools (Ubuntu):
status: New → Confirmed

time-admin requires synaptic and gksudo to install the ntp package, but Xubuntu does not ship these programs by default anymore.

Rolf Leggewie (r0lf) on 2014-03-06
Changed in gnome-system-tools (Ubuntu):
importance: Undecided → Medium
Changed in gnome-system-tools (Ubuntu):
assignee: nobody → Alistair Buxton (a-j-buxton)
Doug Barton (dougb) wrote :

Affecting me after a clean install of the 14.04 b1. Per discussion on #xubuntu-devel, running the following from the command line works, but may not be the ideal solution: pkexec --user root apt-get install ntp -y

Simon Lock (aergan) wrote :

Still present in Xubuntu 14.04 LTS x64

joe invader (mrinvader) wrote :

confirmed

Xubuntu 14.04 LTS x64 ...
clean install.

sudo apt-get install ntp

_did_ work for me.

ntp is overkill. ntpdate is all that *should* be required.

Schlomo Schapiro (sschapiro) wrote :

Really nice that the LTS Ubuntu does not support NTP any more ...

manually installing ntp helped, but it should be simpler than that.

How is the debugging going, Alistair? You assigned the bug to yourself, but it's been 9 months since the assignment without any information.

The bug is still present in 14.04.1. I did a fresh install yesterday, and I still can't install ntp support.

Alistair Buxton (a-j-buxton) wrote :

Sorry I forgot about this. Here's a debdiff which should fix it. It will need cleaning up and testing.

Alistair Buxton (a-j-buxton) wrote :

What this does is replace all the synaptic and gksudo code with a dbus call to packagekit. The old code was added in an Ubuntu patch, so I just regenerated that patch with the new code instead. I don't know if that is the correct way to do it. Only one file needs to be modified, gst-package.c. The new version of 80_gst-packages-common.patch is generated with different diff options so the diff is kind of confusing, sorry about that.

The packagekit source is taken almost verbatim from the C example here: http://www.freedesktop.org/software/PackageKit/pk-faq.html#session-methods

Alistair Buxton (a-j-buxton) wrote :

The attachment "Fix typo on my email address" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
tags: added: utopic

It seems like this would possibly be a good candidate for SRU; but this requires that the bug be also fixed in the development release. Given that there's already a tag for utopic and reports that it doesn't work there, I suspect it also doesn't work yet in Vivid.

Alistair, maybe you'd be interested in also preparing the patch for vivid?

Finally; please see https://wiki.ubuntu.com/StableReleaseUpdates#Procedure; there are some more tasks needed before we can SRU this (updating the description according to the SRU bug template in the link). I'll unsubscribe sponsors for now, but feel free to re-subscribe the team once you have patches ready for the development release as well.

Thanks!

Alistair Buxton (a-j-buxton) wrote :

This broke in the first place because gksudo was removed from the default distribution. So it is broken in all recent releases.

I would do the patch for Vivid if I knew how.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-tools - 3.0.0-4ubuntu2

---------------
gnome-system-tools (3.0.0-4ubuntu2) vivid; urgency=medium

  * debian/patches/80_gst-packages-common.patch: rework to use PackageKit
    to download any required packages; since there is neither gksudo nor
    synaptic available anymore on default installs. Thanks to Alistair Buxton
    for the patch. (LP: #1270090)
  * debian/control: Recommends python3-aptdaemon.pkcompat | packagekit, so that
    we make sure some form of packagekit API is available to get the package
    installation requests if possible.
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 27 Feb 2015 21:41:22 -0500

Changed in gnome-system-tools (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers