Setting user as administrator doesn't give him sudoing rights

Bug #1016932 reported by Ken Causey on 2012-06-23
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-system-tools (Ubuntu)
Undecided
Unassigned

Bug Description

I setup xubuntu on a laptop for a friend to borrow and initially created an account for myself (ken). I then created an account for my friend (joey).

I logged in as my friend (joey) and tried to use the Ubuntu Software Center as I want him to be able to install any software he likes. When I tried to install anything it asked for my (ken) password. Not unexpected, so I went into the users config and set joey up as an administrator. I logged out and back in and it still asked for my (ken) password when I was logged in as 'joey'.

After some advice on the #xubuntu channel I checked sudoers and compared the groups the two of us were in. We were both 'adm' but neither one of us was 'admin' which is what appears in sudoers. But sudoers also is configured with 'sudo' as a group and I (ken) was in that group but not my friend (joey). I added joey to the sudo group manually and now he can install software.

Why didn't setting him as administrator achieve the desired result?

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-system-tools 3.0.0-2ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-25.40-generic 3.2.18
Uname: Linux 3.2.0-25-generic i686
ApportVersion: 2.0.1-0ubuntu8
Architecture: i386
Date: Sat Jun 23 12:05:03 2012
InstallationMedia: Xubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-system-tools
UpgradeStatus: No upgrade log present (probably fresh install)

Ken Causey (bx0-ozn-zwn) wrote :
Changed in gnome-system-tools (Ubuntu):
status: New → Confirmed
Thomas Ward (teward) on 2012-06-23
summary: - Setting user to Adminstrator does not allow software installation
+ Setting user as administrator doesn't give him sudoing rights
Pasi Lallinaho (knome) on 2012-06-23
security vulnerability: no → yes
security vulnerability: yes → no
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1016932

tags: added: iso-testing

The administrator group change is explained in bug 893842.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-tools - 3.0.0-3ubuntu3

---------------
gnome-system-tools (3.0.0-3ubuntu3) trusty; urgency=medium

  * debian/patches/the_admin_group_is_sudo.patch: Change no longer used
    "admin" group to "sudo", thanks Thaddäus Tintenfisch (LP: #1016932)
 -- Sebastien Bacher <email address hidden> Wed, 26 Feb 2014 11:16:13 +0100

Changed in gnome-system-tools (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers