System Monitor does not remember CPU colour settings

Bug #874997 reported by Burton Tsang
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gnome System Monitor
Fix Released
Medium
gnome-system-monitor (Ubuntu)
Low
Robert Roth

Bug Description

I have a PC running an Intel Core i7 with Ubuntu 11.10. When I initially go into System Monitor, it will show 8 CPUs all with the same colour setting. I go to change the colour settings so each CPU has a different colour (so each CPU is easily identifiable in the graph) but whenever I exit the System Monitor and go back in, the colour settings for all 8 CPUs are not remembered, only for 4 of them (see screenshot).

This problem does not exist in Ubuntu 11.04.

Revision history for this message
Burton Tsang (burtontsang) wrote :
Robert Roth (evfool)
affects: ubuntu → gnome-system-monitor (Ubuntu)
Changed in gnome-system-monitor (Ubuntu):
status: New → Confirmed
Robert Roth (evfool)
Changed in gnome-system-monitor (Ubuntu):
status: Confirmed → Triaged
Robert Roth (evfool)
Changed in gnome-system-monitor (Ubuntu):
importance: Undecided → Low
Changed in gnome-system-monitor:
importance: Unknown → Wishlist
status: Unknown → New
Revision history for this message
killmess (killmess) wrote :

Maybe it does that because it detects your cpu is a 4 physical core cpu with 4 virtual cpu.

                  4 physical cpus + 4 virtual cpus = 8 cpus.

But only 4 are real.
                                    Bye, KM.

Changed in gnome-system-monitor:
status: New → Confirmed
Robert Roth (evfool)
Changed in gnome-system-monitor (Ubuntu):
assignee: nobody → Robert Roth (evfool)
status: Triaged → In Progress
Changed in gnome-system-monitor:
importance: Wishlist → Unknown
status: Confirmed → Unknown
Changed in gnome-system-monitor:
importance: Unknown → Medium
status: Unknown → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-monitor - 3.3.4-0ubuntu1

---------------
gnome-system-monitor (3.3.4-0ubuntu1) precise; urgency=low

  * New upstream unstable release.
    - New process properties dialog (LP: #249237)
    - Case insensitive quick search (LP: #915973)
    - Fixed cannot change priority dialogs for root processes (LP: #910845)
    - Sorting numeric columns fixed (LP: #206239)
    - Fixed crashes caused when application icon is not found (LP: #700900)
    - CPU chart colors saved for all CPUs (LP: #705505, LP: #874997)
  * debian/patches/02_lpi.patch: Refreshed.
  * debian/control.in: Require librsvg2-dev >= 2.35.0 to match configure.in.
 -- Robert Roth <email address hidden> Wed, 19 Jan 2012 19:10:15 +0200

Changed in gnome-system-monitor (Ubuntu):
status: In Progress → Fix Released
Changed in gnome-system-monitor:
status: Fix Released → Confirmed
Changed in gnome-system-monitor:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.