System Monitor won't close through normal methods, I have to kill the process.

Bug #482680 reported by DarrenShare on 2009-11-14
138
This bug affects 23 people
Affects Status Importance Assigned to Milestone
gnome-system-monitor (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-system-monitor

Ubuntu 9.10 (I can't remember if this problem is unique to 9.10, I think I might have experienced it in 9.04 as well).
System Monitor 2.28.0

Trying to close System Monitor either by clicking on the close window X, using the menu Monitor | Quit, pressing CTRL-Q or ALT-F4 produces no result. Apart from that the application is 100% functional. To close it I have to resort to killing its own process in the Processes pane.

This doesn't occur all the time and isn't reliably reproducible as far as I can tell.

ProblemType: Bug
Architecture: i386
Date: Sat Nov 14 15:20:34 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/gnome-system-monitor
NonfreeKernelModules: nvidia
Package: gnome-system-monitor 2.28.0-0ubuntu1
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: gnome-system-monitor
Uname: Linux 2.6.31-14-generic i686

DarrenShare (darren-moorstreet) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in gnome-system-monitor (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
DarrenShare (darren-moorstreet) wrote :

Hi Sebastien,

Presumably you'd only be interested in a backtrace when I'm experiencing this problem. Can you confirm?

Thanks.

I, too, am experiencing this problem. The process is also using a consistently high amount of CPU (36-42%), as is dbus-daemon; I suspect that the two things are related.

DarrenShare (darren-moorstreet) wrote :

I just tried installing the debug symbols for gnome-system-monitor as per the linked instructions. However, the instructions aren't fully clear.

Although the installation went OK, running gnome-system-monitor-dbgsym results in this:

darren@ubuntu-desktop:~$ gnome-system-monitor-dbgsym
gnome-system-monitor-dbgsym: command not found

If I try to run the backtrace with gnome-system-monitor I get this message:

Reading symbols from /usr/bin/gnome-system-monitor...Reading symbols from /usr/lib/debug/usr/bin/gnome-system-monitor...done.
(no debugging symbols found)...done.

So I assume the backtrace isn't going to work.

Any help?

jnewm (jessenewmark) wrote :

Hi, this just started happening to me as well.

Captain Chaos (launchpad-chaos) wrote :

Happening to me too. It seems to be happening since the latest update round, although gnome-system-monitor wasn't updated then. The version of gnome-system-monitor I have installed is 2.28.0-0ubuntu1.

On my system too it does not happen all the time. The first time I tried running it with strace it did work, for instance. But it happens more often than not.

Since the application is not crashing I don't think backtraces are applicable. I have attached an strace log. I captured it with the following command line:

strace -Ff -tt gnome-system-monitor 2> strace-gnome-system-monitor.log

I then clicked once on the close button in the title bar (which did nothing), and then ended the program by pressing Ctrl+C on the console.

Changed in gnome-system-monitor (Ubuntu):
status: Incomplete → New
slazil (slazil) wrote :

Hi everybody.

I had experienced the same issue with system monitor until today. But now GSM closes quite well again. The only change that I can remember is that I've deleted "System monitor applet" from the bottom panel. I tried add the applet back to panel but GSM keeps quiting OK by any mean - clicking [X], or choosing "Close" from menu or pressing Ctrl-Q - all close GSM.
So this issue is not reproducible any more.

Regards.
Ilya.

MrPok (wiebenik) wrote :

I also have this problem on 10.10 maverick meerkat.
I was ripping an audio cd with rubyripper and wanted to see if rubyripper actually used multiple threads (I'd set it to 3, and I have a quadcore cpu) but then I couldn't close the System Monitor window anymore.
When rubyripper was finished, I still couldn't close the window, BUT
after opening the cd tray the window vanished without me touching it... :S

(Mind you, this is not a duplicate of bug #692420, since selecting Quit from menu item Monitor also doesn't close the window)

Jay S (topdownjimmy) wrote :

Just started happening to me as well, adding this comment because it only began after I installed Rubyripper.

I can confirm this on Ubuntu 10.10 amd64.
Gnome system monitor won't close with the menu quit or window icon quit button.

Theatre-X (theatrex) wrote :

I can confirm this in Natty too. On x86. I have to open a bash shell and kill the process.

chocoboman (chocoboman) wrote :

Same for me (Natty 64bit).

This is also cropping up on ubuntu 11.10 beta 1 - 64 bit, though not all the time. I first noticed this a few weeks ago, when all the other windows closed as soon as i hit X, except for the system monitor which behaves erratically - this problem has never happened to me in Natty, Maverick or Lucid.

Hitting the X button:
Sometimes it lags a few seconds before closing; sometimes it refuses to close even after hitting close several times - also doesn't respond to right-clicking --> quit (in unity) or close (on a gnome panel).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-system-monitor (Ubuntu):
status: New → Confirmed
Lukáš Chmela (lukaschmela) wrote :

I can confirm this issue on Ubuntu 11.10 (upgraded from 10.04). I am not able to close gnome-system-monitor the usual way by clicking on the red cross in the top left corner, I have to kill it from the processes list.

tags: added: amd64 oneiric
Robert Roth (evfool) wrote :

This could be related to an upstream issue [1], seemingly fixed in the 3.3.2 development release.
[1] https://bugzilla.gnome.org/show_bug.cgi?id=655964

Robert Roth (evfool) wrote :

Could anyone affected try if this is still the case with GNOME system monitor from the current development version of Ubuntu Precise Pangolin? This might have been fixed upstream.

Changed in gnome-system-monitor (Ubuntu):
status: Confirmed → Incomplete
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Robert Roth (evfool)
Robert Roth (evfool) on 2012-01-19
Changed in gnome-system-monitor (Ubuntu):
assignee: Robert Roth (evfool) → nobody
status: Incomplete → New
status: New → Incomplete
Robert Roth (evfool) wrote :

As there has been no response in the last two months to the question from comment 18, I am closing this bug as Invalid. Feel free to reopen by setting the status to Confirmed if you still experience the behavior.

Changed in gnome-system-monitor (Ubuntu):
status: Incomplete → Invalid
DarkMind (ipsissimus) wrote :

What kind of response are you looking for, bug still exists.
System Monitor closes if you dont look at the tabs, if you change the tabs from System to Processes tab then it is not closing, and you have to force close it

Robert Roth (evfool) wrote :

DarkMind (ipsissimus): See the previous question in comment 18. I just wanted to know whether anyone still has this using System Monitor 3.4.0 from Precise, as there have been lots of changes and improvements in System Monitor in this cycle, and some were to address long closing time. Which version of System Monitor do you experience this with?

Changed in gnome-system-monitor (Ubuntu):
status: Invalid → Incomplete
DarkMind (ipsissimus) wrote :

I cant test it on Ubuntu Precise Pangolin, but it doesn't matter, it would be a lot of people who would like to continue using 11.10, moreover what if bug is not fixed? We have to wait more? I can confirm I'm using 3.2.1 and bug still presents

Robert Roth (evfool) wrote :

@DarkMind (ipsissimus): If it's Fixed in Precise Pangolin, then the bug is fixed in the latest version of the package. In that case it is possible to backport the fix to an earlier release, like Oneiric (11.10) (if it is regarded as important enough). However if it's not fixed in the latest release, we have to investigate what else can be the problem. So if you can test on Precise Pangolin, please try to reproduce and report back, as I can't reproduce it on my computer. On Oneiric I have a few seconds lag before closing with high IO usage, but afterwards System Monitor closes. On Precise I don't have this, so there have been some improvements for sure. That's why it would be important to find out whether it's fixed on Precise Pangolin for you. You can even test it using a LiveCD/LiveUSB with the latest daily image or Beta 2. Thanks.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Robert Roth (evfool) on 2012-09-13
Changed in gnome-system-monitor (Ubuntu):
status: Incomplete → Confirmed
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.