Ubuntu

Parent process should show child process totals

Reported by Neovos on 2008-09-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gnome System Monitor
Confirmed
Medium
gnome-system-monitor (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-system-monitor

Ubuntu 8.04 Hardy
2.6.24-18-generic
Gnome 2.22.3

When using the System monitor, I feel that all parent processes, when collapsed, should give the totals of itself and it's child processes for all fields (cpu, memory etc.). This could help clean up the window a little bit for people who like to have all dependencies and all processes for all users on there at once. Once that parent is opened, then it can revert back to displaying it's own totals and the child processes can do the same (unless of course, it is a parent for other children).

This should be default behavior in my opinion, but at least the addition of an option somewhere would be great. I think it would make much more sense to be able to get totals for "gdm" and "xorg" and other conglomerate processes as giant entities instead of having to open up all the little sub processes to get an idea of whats eating up my cpu.

Pedro Villavicencio (pedro) wrote :

thanks for the report, feel free to send it upstream to bugzilla.gnome.org since you're the interest on the feature, for forwarding instructions please have a look to https://wiki.ubuntu.com/Bugs/Upstream/GNOME ; thanks in advance.

Changed in gnome-system-monitor:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
status: New → Confirmed

________________________________
De: Brian Clements <email address hidden>
Para: <email address hidden>
Enviado: miércoles, 17 de septiembre, 2008 13:16:24
Asunto: [Bug 271421] [NEW] Parent process should show child process totals

Public bug reported:

Binary package hint: gnome-system-monitor

Ubuntu 8.04 Hardy
2.6.24-18-generic
Gnome 2.22.3

When using the System monitor, I feel that all parent processes, when
collapsed, should give the totals of itself and it's child processes for
all fields (cpu, memory etc.). This could help clean up the window a
little bit for people who like to have all dependencies and all
processes for all users on there at once. Once that parent is opened,
then it can revert back to displaying it's own totals and the child
processes can do the same (unless of course, it is a parent for other
children).

This should be default behavior in my opinion, but at least the addition
of an option somewhere would be great. I think it would make much more
sense to be able to get totals for "gdm" and "xorg" and other
conglomerate processes as giant entities instead of having to open up
all the little sub processes to get an idea of whats eating up my cpu.

** Affects: gnome-system-monitor (Ubuntu)
    Importance: Undecided
        Status: New

--
Parent process should show child process totals
https://bugs.launchpad.net/bugs/271421
You received this bug notification because you are subscribed to gnome-
system-monitor in ubuntu.

Status in “gnome-system-monitor” source package in Ubuntu: New

Bug description:
Binary package hint: gnome-system-monitor

Ubuntu 8.04 Hardy
2.6.24-18-generic
Gnome 2.22.3

When using the System monitor, I feel that all parent processes, when collapsed, should give the totals of itself and it's child processes for all fields (cpu, memory etc.). This could help clean up the window a little bit for people who like to have all dependencies and all processes for all users on there at once. Once that parent is opened, then it can revert back to displaying it's own totals and the child processes can do the same (unless of course, it is a parent for other children).

This should be default behavior in my opinion, but at least the addition of an option somewhere would be great. I think it would make much more sense to be able to get totals for "gdm" and "xorg" and other conglomerate processes as giant entities instead of having to open up all the little sub processes to get an idea of whats eating up my cpu.

      ____________________________________________________________________________________
Premios MTV 2008¡En exclusiva! Fotos, nominados, videos, y mucho más! Mira aquí http://mtvla.yahoo.com/

eugenia (draeugeniasu) wrote :
Download full text (4.3 KiB)

ABANDONO ESTE CORREO , NO QUIERO MAS INFORMACION  HAN SIDO MUY AMABLES .
GRACIAS

________________________________
De: eugenia <email address hidden>
Para: <email address hidden>
Enviado: miércoles, 3 de diciembre, 2008 21:43:19
Asunto: Re: [Bug 271421] [NEW] Parent process should show child process totals

________________________________
De: Brian Clements <email address hidden>
Para: <email address hidden>
Enviado: miércoles, 17 de septiembre, 2008 13:16:24
Asunto: [Bug 271421] [NEW] Parent process should show child process totals

Public bug reported:

Binary package hint: gnome-system-monitor

Ubuntu 8.04 Hardy
2.6.24-18-generic
Gnome 2.22.3

When using the System monitor, I feel that all parent processes, when
collapsed, should give the totals of itself and it's child processes for
all fields (cpu, memory etc.). This could help clean up the window a
little bit for people who like to have all dependencies and all
processes for all users on there at once. Once that parent is opened,
then it can revert back to displaying it's own totals and the child
processes can do the same (unless of course, it is a parent for other
children).

This should be default behavior in my opinion, but at least the addition
of an option somewhere would be great. I think it would make much more
sense to be able to get totals for "gdm" and "xorg" and other
conglomerate processes as giant entities instead of having to open up
all the little sub processes to get an idea of whats eating up my cpu.

** Affects: gnome-system-monitor (Ubuntu)
    Importance: Undecided
        Status: New

--
Parent process should show child process totals
https://bugs.launchpad.net/bugs/271421
You received this bug notification because you are subscribed to gnome-
system-monitor in ubuntu.

Status in “gnome-system-monitor” source package in Ubuntu: New

Bug description:
Binary package hint: gnome-system-monitor

Ubuntu 8.04 Hardy
2.6.24-18-generic
Gnome 2.22.3

When using the System monitor, I feel that all parent processes, when
collapsed, should give the totals of itself and it's child processes for
all fields (cpu, memory etc.). This could help clean up the window a
little bit for people who like to have all dependencies and all
processes for all users on there at once. Once that parent is opened,
then it can revert back to displaying it's own totals and the child
processes can do the same (unless of course, it is a parent for other
children).

This should be default behavior in my opinion, but at least the addition
of an option somewhere would be great. I think it would make much more
sense to be able to get totals for "gdm" and "xorg" and other
conglomerate processes as giant entities instead of having to open up
all the little sub processes to get an idea of whats eating up my cpu.

      ____________________________________________________________________________________
Premios MTV 2008¡En exclusiva! Fotos, nominados, videos, y mucho más! Mira aquí http://mtvla.yahoo.com/

--
Parent process should show child process totals
https://bugs.launchpad.net/bugs/271421
You received this bug notification because you are subscribed to gnome-
system-monitor in ubuntu.

Status...

Read more...

Forwarding this upstream.

Changed in gnome-system-monitor:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-system-monitor:
status: Unknown → New
Changed in gnome-system-monitor (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-system-monitor:
importance: Unknown → Wishlist
Changed in gnome-system-monitor:
status: New → Invalid
Robert Roth (evfool) on 2012-01-04
Changed in gnome-system-monitor:
importance: Wishlist → Unknown
status: Invalid → Unknown
Changed in gnome-system-monitor:
importance: Unknown → Medium
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.