2.22.3 stable update

Bug #245197 reported by Sebastien Bacher on 2008-07-03
8
Affects Status Importance Assigned to Milestone
gnome-system-monitor (Ubuntu)
Wishlist
Ubuntu Desktop Bugs
Hardy
Wishlist
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-system-monitor

there is a new 2.22.3 stable version

TESTCASE: nothing specific to try there, just run the software and see if it still works correctly

Sebastien Bacher (seb128) wrote :

there is a newer version in intrepid

Changed in gnome-system-monitor:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
status: New → Fix Released
Changed in gnome-system-monitor:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
status: New → Confirmed
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gnome-system-monitor:
status: Confirmed → Fix Committed
Pjotr12345 (computertip) wrote :

Version 2.22.3 is still plagued by the bug. In a completely up-to-date Ubuntu 8.04.1.

CPU usage is mostly at 11 % (sometimes it drops for a second to 0 % or 1 %), with peaks as high as 22 %. On my Intel Core 2 Duo machine with 2 GB RAM.... This is crazy.

Memory usage is acceptable though: constant at 8,7 MB. I can live with that. :-)

Sebastien Bacher (seb128) wrote :

a new rebuild revision has been uploaded now to some libglib issues

Pjotr12345 (computertip) wrote :

Today I tested the newest version in proposed. The problem seems largely fixed, but not quite.

When I check the system load caused by gnome-system-monitor using the command "top" in the terminal, the CPU load is almost imperceptible. That's good.

But when I check the system load by double-clicking gnome-system-monitor, so that it opens it's own full-size window, I see the crazy values again (confirmed by top). 15 % CPU, with peaks as high as 21 %.

So it appears that as long as you use gnome-system-monitor only as a little meter in the panel, there's no problem with this new version. But do not double-click it, for then the trouble starts.

For most practical puposes the meter is therefore allright now. Upstream should deal with the remaining problem, though.

Pedro Villavicencio (pedro) wrote :

the package works as expected however there's still issues with the CPU usage which is a known bug. marking this as verification done, thanks.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in gnome-system-monitor:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers