can t run snap gnome-system-monitor

Bug #1821012 reported by HankB on 2019-03-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-system-monitor (Ubuntu)
High
Unassigned

Bug Description

Can't run from 'gnome find' - nothing happens.
Try to run from terminal - get this:

hbarta@karakum:~$ gnome-system-monitor
You need to connect this snap to the gnome platform snap.

You can do this with those commands:
snap install gnome-3-26-1604
snap connect gnome-system-monitor:gnome-3-26-1604 gnome-3-26-1604

(the '3-26-1604' number defines the platform version and might change)
hbarta@karakum:~$
hbarta@karakum:~$ snap install gnome-3-26-1604
snap "gnome-3-26-1604" is already installed, see 'snap help refresh'
hbarta@karakum:~$ snap connect gnome-system-monitor:gnome-3-26-1604 gnome-3-26-1604
error: snap "gnome-system-monitor" has no plug named "gnome-3-26-1604"
hbarta@karakum:~$

Remove snap, install deb - runs OK.

Remove deb, install snap (with intent to see if this fixes the issue or to file a bug report) and now get

hbarta@karakum:~$ gnome-system-monitor
Failed to register: GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: An AppArmor policy prevents this sender from sending this message to this recipient; type="method_call", sender=":1.112" (uid=1000 pid=10105 comm="gnome-system-monitor " label="snap.gnome-system-monitor.gnome-system-monitor (enforce)") interface="org.gtk.Actions" member="DescribeAll" error name="(unset)" requested_reply="0" destination="org.gnome.SystemMonitor" (uid=1000 pid=3975 comm="gnome-system-monitor " label="unconfined")
hbarta@karakum:~$

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: gnome-system-monitor (not installed)
ProcVersionSignature: Ubuntu 4.15.0-46.49-generic 4.15.18
Uname: Linux 4.15.0-46-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.6
Architecture: amd64
CurrentDesktop: GNOME
Date: Wed Mar 20 09:05:16 2019
InstallationDate: Installed on 2019-01-30 (48 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-system-monitor
UpgradeStatus: No upgrade log present (probably fresh install)

HankB (hbarta) wrote :
Sebastien Bacher (seb128) wrote :
Changed in gnome-system-monitor (Ubuntu):
importance: Undecided → High
HankB (hbarta) wrote :

The snap is now working. (In other words, not able to reproduce.)
I'm not sure what made the change but I did reboot several times.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers