snap doesn't filter out squashfs entries

Bug #1819919 reported by Tero Gusto on 2019-03-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gnome System Monitor
Fix Released
Unknown
gnome-system-monitor (Ubuntu)
Low
Unassigned

Bug Description

Previous versions of File Systems only showed my two harddrives, and was pretty useful.

In Ubuntu 18.04 gnome-system-monitor > File Systems now shows 35 lines of uninteresting lines, like /var/lib/snapd ...

I tried switching from Snap- to classic apt-based version, with these commands:

sudo snap remove gnome-system-monitor
sudo apt-get install gnome-system-monitor

I got the good old System Files back, showing just the two hard drives of interest to me, but "snap remove gnome-system-monitor" removed a lot of extra packages, so my shortcuts stopped working, and possibly other stuff as well. I had to revert to snap-based gnome-system-monitor to get them working again.

How can I get the previous and useful File Systems back, only showing my two hard drives?

Tero Gusto (tero-gusto) on 2019-03-14
summary: - Lots of useless info in File Systems
+ Too much useless information in File Systems
summary: - Too much useless information in File Systems
+ Too much information in File Systems
Paul White (paulw2u) on 2019-03-30
affects: libgtop → gnome-system-monitor
Changed in gnome-system-monitor:
status: Unknown → Fix Released
Wileam Yonatan Phan (wileamyp) wrote :

Sorry for bumping an old issue, but the "fix" released on upstream seems to be the "nuclear" option of completely removing `snap`... which might not work for everyone. :(

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-system-monitor (Ubuntu):
status: New → Confirmed
Changed in gnome-system-monitor (Ubuntu):
importance: Undecided → Low
tags: added: snap
summary: - Too much information in File Systems
+ snap doesn't filter out squashfs entries
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.