system-monitor produces many apparmor permission denied warnings

Bug #1791454 reported by LinuxUser on 2018-09-08
116
This bug affects 25 people
Affects Status Importance Assigned to Milestone
gnome-system-monitor (Ubuntu)
High
Unassigned

Bug Description

gnome-system-monitor (installed as snap, latest stable version) on Ubuntu 18.04.1 causes while running many warnings in the system log of the following type:

 audit[2095]: AVC apparmor="DENIED" operation="open" profile="snap.gnome-system-monitor.gnome-system-monitor" name="/proc/2932/wchan" pid=2095 comm="gnome-system-mo" requested_mask="r" denied_mask="r" fsuid=1000 ouid=1000

 audit[2095]: AVC apparmor="DENIED" operation="open" profile="snap.gnome-system-monitor.gnome-system-monitor" name="/proc/1/cgroup" pid=2095 comm="gnome-system-mo" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

The output of
  journalctl | grep "operation=\"open\" profile=\"snap.gnome-system-monitor.gnome" | wc -l
amounts on my system to 4 924 215 .
For comparison journalctl | wc -l amounts to 5 143 715 .
Thus it is really spamming my system log.

output of snap info gnome-system-monitor is attached.

output of lsb_release -rd:
  Description: Ubuntu 18.04.1 LTS
  Release: 18.04

LinuxUser (linux-user-42) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-system-monitor (Ubuntu):
status: New → Confirmed
Seth Arnold (seth-arnold) wrote :

If this bug is about a snap package you should probably open a report with the snap author.

Thanks

laluz (laluz) wrote :

I have it on 18.04 as well with System-Monitor installed as an app.

Mario Charest (stayprivate) wrote :

iotop is showing systemd-journal writing to disk at around 1MBs while system-monitor is running. 420 entries per seconds.

Cheers

Sebastien Bacher (seb128) wrote :

That's not an issue on a new/stock installation, maybe having to do with the context but unsure in which cases it's an issue

Changed in gnome-system-monitor (Ubuntu):
importance: Undecided → High
Kevin Winters (kjwinters) wrote :

My new machine (one week old) is receiving these as well:

$ lsb_release -rd
Description: Ubuntu 18.04.3 LTS
Release: 18.04

$ journalctl | grep "operation=\"open\" profile=\"snap.gnome-system-monitor.gnome" | wc -l
77549

which half the log!

$ journalctl | wc -l
144263

Sebastien Bacher (seb128) wrote :

Could you describe your system? Is there anything non standard in the type of disks, user accounts, ...?

Jamie Strandboge (jdstrand) wrote :

Note, these accesses were added in 22d37f834b6f4605faa3887bae3cf4d0e1673278

Changed in gnome-system-monitor (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers