System monitor under-reports maximum CPU usage by xorg and compiz

Bug #1740247 reported by Dan Dascalescu on 2017-12-27
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-system-monitor (Ubuntu)
Undecided
Unassigned

Bug Description

My CPU was being roasted on all 4 cores, htop showed 25% utilization for both xorg and compiz, but `sudo gnome-system-monitor` showed much smaller numbers for xorg (~7%) and compiz (5%).

Killing compiz didn't help - after a dip in the CPU usage and a flash of the screen, it's back to 100% of the CPU core.

The machine is an ASUS ZenBook UX430UQ Intel Core i7-7500 with a 2GB NVIDIA 940MX card (but System details shows Intel® HD Graphics 620 (Kabylake GT2) and 16GB RAM.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gnome-system-monitor 3.18.2-1ubuntu1
ProcVersionSignature: Ubuntu 4.10.0-42.46~16.04.1-generic 4.10.17
Uname: Linux 4.10.0-42-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.14
Architecture: amd64
Date: Wed Dec 27 02:14:15 2017
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/gnome-system-monitor
InstallationDate: Installed on 2017-10-06 (82 days ago)
InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 (20170801)
SourcePackage: gnome-system-monitor
UpgradeStatus: No upgrade log present (probably fresh install)

description: updated
summary: - System monitor under-report maximum CPU usage by xorg and compiz
+ System monitor under-reports maximum CPU usage by xorg and compiz
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers