Double-click to expand a super wide column (process name) ruins your day

Bug #1725803 reported by Sirap on 2017-10-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-system-monitor (Ubuntu)
Low
Unassigned

Bug Description

Google Chrome has long process names. By long I mean hundreds and hundreds of characters wide (see picture). Without knowing this I unsuspectingly double-clicked the process name column edge in the processes tab, and ended up with a column that stretched far, far to the right. The only way to get back to normal was to scroll to the far right and tediously grab the column and shrink it manually over and over until it got back to normal.

Before doing that I tried double-clicking again to try and make it shrink to its smallest size -- that didn't work. I generally tend to expect the reverse operation to work when working with UI. Open-Close, Expand-Collapse, Show-Hide, etc.

After doing that I -- unfortunately -- tried to disable the process name column in the column context menu (right click). That made everything worse. Another column took over the super wide column that previously held process names, and pretty much every other existing column seemingly disappeared from the table. After some head-scratching I figured out that all other columns had collapsed into zero width.

I tried restarting the application -- didn't work; it had saved my column setup.

Adjusting some column widths went from a simple task to becoming a real chore.

Expectations:
I expected to be able to collapse the column the same way I expanded it. I also expected all other columns to keep their own sizes when disabling/hiding a column. In hindsight I now also expect column expansion to have some kind of sanity check.

Note:
I was positive that I had included the scroll bars in the screenshots, but apparently they timed out and disappeared, so the pictures kind of fail to illustrate the extent of the column width.

----
Description: Ubuntu 17.10
Release: 17.10

gnome-system-monitor:
  Installed: 3.26.0-1
  Candidate: 3.26.0-1
  Version table:
 *** 3.26.0-1 500
        500 http://se.archive.ubuntu.com/ubuntu artful/main amd64 Packages
        100 /var/lib/dpkg/status

Sirap (sirap) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in gnome-system-monitor (Ubuntu):
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers