gnome-system-monitor crash on 17.04

Bug #1665209 reported by siucdude on 2017-02-16
52
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Gnome System Monitor
Fix Released
Critical
gnome-system-monitor (Ubuntu)
Medium
Unassigned

Bug Description

crash after update

ProblemType: Crash
DistroRelease: Ubuntu 17.04
Package: gnome-system-monitor 3.23.90-0ubuntu1
ProcVersionSignature: Ubuntu 4.10.0-8.10-generic 4.10.0-rc8
Uname: Linux 4.10.0-8-generic x86_64
ApportVersion: 2.20.4-0ubuntu2
Architecture: amd64
CurrentDesktop: LXDE
Date: Wed Feb 15 21:53:47 2017
ExecutablePath: /usr/bin/gnome-system-monitor
InstallationDate: Installed on 2017-01-26 (20 days ago)
InstallationMedia: Lubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.1)
ProcCmdline: gnome-system-monitor
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
SegvAnalysis: Skipped: missing required field "Disassembly"
Signal: 11
SourcePackage: gnome-system-monitor
UpgradeStatus: Upgraded to zesty on 2017-01-27 (19 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

siucdude (siucdude) wrote :
information type: Private → Public

StacktraceTop:
 __GI___libc_free (mem=0x55f100000000) at malloc.c:2963
 get_process_cgroup_info (info=...) at cgroups.cpp:114
 update_info (info=0x55f1105f34e0, app=0x55f10ff775a0) at proctable.cpp:913
 refresh_list (n=37, pid_list=0x55f1106464b0, app=0x55f10ff775a0) at proctable.cpp:990
 proctable_update (app=app@entry=0x55f10ff775a0) at proctable.cpp:1123

Changed in gnome-system-monitor (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-system-monitor (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2017-02-16
Changed in gnome-system-monitor (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-system-monitor:
importance: Unknown → Critical
status: Unknown → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-monitor - 3.23.90-0ubuntu2

---------------
gnome-system-monitor (3.23.90-0ubuntu2) zesty; urgency=medium

  * debian/rules:
    - Drop --enable-wnck since it's unsupported and causes the app to
      crash (LP: #1665209)

 -- Jeremy Bicha <email address hidden> Sun, 19 Feb 2017 07:40:43 -0500

Changed in gnome-system-monitor (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-system-monitor:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.