System Monitor CPU graph shows random colors only for 4 CPU cores

Bug #1600142 reported by BismarX
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libgtop
Fix Released
Unknown
gnome-system-monitor (Ubuntu)
Low
Unassigned

Bug Description

On Linux Mint 18 Cinnamon 64-bit (and on Mint 17 series as well) System Monitor CPU graph has random colours for 4 cores only. My AMD FX-series CPU has 8 cores and core 5 to 8 graph is shown in red for each mentioned core separately. There is no option to choose a different colour for each CPU core (it would be nice to have).
The problem is that I can not distinguish which core does what if half of them is shown in the same colour. It kind of defeats the purpose of having a separate graph for each core. Yes, one might argue it is not that important but still - if it is there, I would like to use that option. Multi-core CPUs with more than just 4 cores are widespread.
Having more contrast in those graphs for all cores would solve my problem.

Revision history for this message
BismarX (karlis-martinsons) wrote :

Screenshot attached.

Changed in linuxmint:
status: New → Confirmed
no longer affects: linuxmint
Revision history for this message
BismarX (karlis-martinsons) wrote :

Same problem on Linux Mint 19 Cinnamon 64-bit. See screenshot attached.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-system-monitor (Ubuntu):
status: New → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :
Changed in gnome-system-monitor (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Revision history for this message
BismarX (karlis-martinsons) wrote :

Bug fixed on Linux Mint Cinnamon 19.2 64-bit.

Changed in gnome-system-monitor (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-system-monitor (Ubuntu):
status: Fix Released → Triaged
Changed in libgtop:
status: Unknown → New
Changed in libgtop:
status: New → Fix Released
Changed in gnome-system-monitor (Ubuntu):
status: Triaged → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.