"Started" column not displayed for processes when column is enabled in settings

Bug #1581229 reported by Wise Melon on 2016-05-12
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Gnome System Monitor
Fix Released
Medium
Ubuntu GNOME
Undecided
Unassigned
gnome-system-monitor (Ubuntu)
Low
Unassigned
Xenial
Low
Unassigned

Bug Description

* Impact
some columns have a default width of 0 pixels which is buggy

* Test case
- go to preference and enable one of the memory/started column
you should have list with a decent width

* Regression potential
the change is only one in the default value of a schema, if the UI looks fine there it's working

----------------------------------

I have recently noticed that in the gnome-system-monitor if I go into the settings and tick the box for "Started" in the "Information fields" section of that the "Processes" tab that the "Started" column is not added and in fact this information is not seemingly displayed anywhere except for in the "Properties" window for a process. But it would be really useful if it did actually appear as a column so that you could easily view the start times for multiple processes at the same time and to also sort them in terms of that. I am running Ubuntu GNOME 15.10 with GNOME 3.18 but I have also experienced the behaviour on Ubuntu GNOME 16.04 with GNOME 3.20, in fact when running it on that system through Terminal this was the output (the exact moment I checked the "Started" box in the settings to add that column I got the first bit of output and then very quickly the other output followed):

    (gnome-system-monitor:2252): GLib-CRITICAL **: Source ID 73 was not found when attempting to remove it

    (gnome-system-monitor:2252): Gtk-WARNING **: Negative content width -12 (allocation 1, extents 6x7) while allocating gadget (node button, owner GtkButton)

    (gnome-system-monitor:2252): Gtk-WARNING **: Negative content width -12 (allocation 1, extents 6x7) while allocating gadget (node button, owner GtkButton)

    (gnome-system-monitor:2252): Gtk-WARNING **: Negative content width -12 (allocation 1, extents 6x7) while allocating gadget (node button, owner GtkButton)

    (gnome-system-monitor:2252): Gtk-WARNING **: Negative content width -12 (allocation 1, extents 6x7) while allocating gadget (node button, owner GtkButton)

    (gnome-system-monitor:2252): Gtk-WARNING **: Negative content width -12 (allocation 1, extents 6x7) while allocating gadget (node button, owner GtkButton)

    (gnome-system-monitor:2252): Gtk-WARNING **: Negative content width -12 (allocation 1, extents 6x7) while allocating gadget (node button, owner GtkButton)

    (gnome-system-monitor:2252): Gtk-WARNING **: Negative content width -12 (allocation 1, extents 6x7) while allocating gadget (node button, owner GtkButton)

    (gnome-system-monitor:2252): Gtk-WARNING **: Negative content width -12 (allocation 1, extents 6x7) while allocating gadget (node button, owner GtkButton)

    (gnome-system-monitor:2252): Gtk-WARNING **: Negative content width -12 (allocation 1, extents 6x7) while allocating gadget (node button, owner GtkButton)

    (gnome-system-monitor:2252): Gtk-WARNING **: Negative content width -12 (allocation 1, extents 6x7) while allocating gadget (node button, owner GtkButton)

    (gnome-system-monitor:2252): Gtk-WARNING **: Negative content width -12 (allocation 1, extents 6x7) while allocating gadget (node button, owner GtkButton)

    (gnome-system-monitor:2252): Gtk-WARNING **: Negative content width -12 (allocation 1, extents 6x7) while allocating gadget (node button, owner GtkButton)

    (gnome-system-monitor:2252): Gtk-WARNING **: Negative content width -12 (allocation 1, extents 6x7) while allocating gadget (node button, owner GtkButton)

    (gnome-system-monitor:2252): Gtk-WARNING **: Negative content width -12 (allocation 1, extents 6x7) while allocating gadget (node button, owner GtkButton)

    (gnome-system-monitor:2252): Gtk-WARNING **: Negative content width -12 (allocation 1, extents 6x7) while allocating gadget (node button, owner GtkButton)

    (gnome-system-monitor:2252): Gtk-WARNING **: Negative content width -12 (allocation 1, extents 6x7) while allocating gadget (node button, owner GtkButton)

    (gnome-system-monitor:2252): Gtk-WARNING **: Negative content width -12 (allocation 1, extents 6x7) while allocating gadget (node button, owner GtkButton)

    (gnome-system-monitor:2252): Gtk-WARNING **: Negative content width -12 (allocation 1, extents 6x7) while allocating gadget (node button, owner GtkButton)

    (gnome-system-monitor:2252): Gtk-WARNING **: Negative content width -12 (allocation 1, extents 6x7) while allocating gadget (node button, owner GtkButton)

    (gnome-system-monitor:2252): Gtk-WARNING **: Negative content width -12 (allocation 1, extents 6x7) while allocating gadget (node button, owner GtkButton)

summary: - Start time for processes not displayed when column is enabled in
+ "Started" column not displayed for processes when column is enabled in
settings
Changed in gnome-system-monitor:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in gnome-system-monitor (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in gnome-system-monitor:
importance: Medium → Unknown
status: Confirmed → Unknown
Changed in gnome-system-monitor:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in ubuntu-gnome:
status: New → Confirmed
Changed in gnome-system-monitor:
status: Confirmed → Fix Released

A patched version has been released upstream so we should backport it in.

Sebastien Bacher (seb128) wrote :

right it's on our list but feel free to provide a debdiff if you want to help with that update

Changed in gnome-system-monitor (Ubuntu):
status: Triaged → Fix Committed

I will see what I can do.

Am I creating a debdiff for 3.20 and 3.18 or which versions do you want?

That is a version for the gnome3-staging PPA and the normal repository version?

Changed in gnome-system-monitor (Ubuntu):
assignee: nobody → Nikita Yerenkov-Scott (yerenkov-scott)
Changed in ubuntu-gnome:
assignee: nobody → Nikita Yerenkov-Scott (yerenkov-scott)
Sebastien Bacher (seb128) wrote :

depends of what serie you want to get fixed, ideally just using the patch on top of what is currently in the archive so 3.20 for yakkety and 3.18 for xenial

Here is the debdiff for the 3.20 version. I assume that I also need to make on for 3.18. Is that correct and does my 3.20 debdiff look ok or does anything need improving/changing (I haven't really done this before, at least not for a long time, and back then I had help, this time I had none)?

Strange, I didn't get the message you sent before I sent mine... We must have sent them at the same time.

Anyway, so you need me to do what I have done for the 3.20 in Yakkety and the 3.18 in Xenial? I hope that at least the Ubuntu GNOME gnome3-staging PPA can make use of my current debdiff. I will do the work for the next debdiffs in VMs so I may take a little while to submit them, I hope to get another submitted by the end of today, but my Yakkety VM is a bit on the slow side so there might be a delay in one of them, but should all be there by some time tomorrow.

Sebastien Bacher (seb128) wrote :

the debdiff looks great, thanks! (just the changelog targets needs to be changed to yakkety for upload). I've subscribed ubuntu-sponsors to the bug

Sebastien Bacher (seb128) wrote :

the debdiff can easily be adapted but if you want to do the xenial SRU that would be welcome, the team working on the GNOME3 ppa should be able to use the yakkety debdiff or adapt don't worry, also you probably don't need to bother much using VMs and build/testing on each serie, just get the source for xenial, do the change and generate a debdiff using whatever version of ubuntu you are on, for those sort of changes it should be safe enough and the sponsor can test before uploading

Oh, ok, so I don't actually need to do any more debdiffs? Would it be preferable if I did or can I just correct the unstable to yakkety and not need to do any more? If it's needed of me or would be preferable for you I will do it, but as my system is rather slow and overheating due to its fan being broken I would prefer not to be doing anything on it that isn't actually needed of me.

So you just need me to change unstable to yakkety in the changelog, resign and reupload and that is it or do I need to do anything else?

Do you need me to just change "unstable" to "yakkety" in the debdiff and reupload? Or do you need me to rerun the entire process of making the debdiff after I've made the appropriate changes in the changelog?

I hope that I have done it correctly and as you wanted. Please let me know if there is anything else I need to fix or if I have done this in the wrong way. I will be unavailable for a few hours starting from now but should be able to have a look later tonight (if not, then tomorrow).

tags: added: patch
tags: added: yakkety
Changed in ubuntu-gnome:
status: Confirmed → Fix Committed

I am now available again to do any necessary work. Is all well or is there anything else you need me to do?

Sebastien Bacher (seb128) wrote :

nothing else needed, it just needs a reviewer to pick it up which I'm going to try to do today (but if somebody else wants to beat me to it feel free to upload), thanks for the work!

Sebastien Bacher (seb128) wrote :

Ok, I've uploaded to yakkety with those changes
- rename the patch to be prefixed with git which is sort of a convention for desktop packages, makes it easier to see what is coming from upstream
- changed the "closes: #" Debian syntax to "lp: #" in the changelog
- line wraps in the changelog to 78 columns

I've also backported 2 extra commits fixed similar issue for other columns

Thanks again for the work!

description: updated
Sebastien Bacher (seb128) wrote :

the new default looks a bit tight, I've commented upstream about that but I uploaded to xenial as well with the current values, we can do another upload to tweak later if they decide to change the values

Right, so if they do update the values will that just require a few changes in the debdiff or will the whole thing need to be rerun?

Sebastien Bacher (seb128) wrote :

the patch just needs to be refreshed with the new value, we can handle if it's the case don't worry

Jeremy Bicha (jbicha) wrote :

Congratulations on getting your first package update into Ubuntu!

https://launchpad.net/ubuntu/+source/gnome-system-monitor/3.20.1-1ubuntu1

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-monitor - 3.20.1-1ubuntu1

---------------
gnome-system-monitor (3.20.1-1ubuntu1) yakkety; urgency=medium

  * debian/patches/gitFixDefaultColumnWidth.patch:
    - Fixes the default column width for the memory and started columns as
      they otherwise do not show even when enabled (lp: #1581229)

 -- Nikita Yerenkov-Scott <email address hidden> Tue, 16 Aug 2016 16:05:36 +0100

Changed in gnome-system-monitor (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2016-08-17
Changed in gnome-system-monitor (Ubuntu Xenial):
status: New → In Progress
importance: Undecided → Low

Hello Nikita, or anyone else affected,

Accepted gnome-system-monitor into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-system-monitor/3.18.2-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-system-monitor (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed

I have tested the version in -proposed on an Ubuntu GNOME 16.04.1 VM with the default GNOME 3.18 and it fixes the issue.

tags: added: verification-done
removed: verification-needed

The package version I tested being 3.18.2-1ubuntu1.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-monitor - 3.18.2-1ubuntu1

---------------
gnome-system-monitor (3.18.2-1ubuntu1) xenial; urgency=medium

  * debian/patches/gitFixDefaultColumnWidth.patch:
    - Fixes the default column width for the memory and started columns as
      they otherwise do not show even when enabled (lp: #1581229)

 -- Nikita Yerenkov-Scott <email address hidden> Wed, 17 Aug 2016 16:30:31 +0200

Changed in gnome-system-monitor (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-system-monitor has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Paul White (paulw2u) wrote :

Marking "Fix Released" to fully close

Changed in ubuntu-gnome:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.