System Monitor numbers change but not graphs when viewing it through the Activities Overview (this happens often but not all the time)

Bug #1558156 reported by Wise Melon on 2016-03-16
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
Low
Ubuntu GNOME
Undecided
Unassigned
gnome-shell (Ubuntu)
Undecided
Unassigned
gnome-system-monitor (Ubuntu)
Undecided
Unassigned

Bug Description

Although I have noticed this issue only with the System Monitor I do not know if it is isolated to it, but for some reason sometimes (about half the time) when viewing the System Monitor through the Activities Overview I get this strange effect where the numbers are clearly changing but the graphs are not:

    System_Monitor_Activities_Overview_Only_Numbers_Changing.mp4

And when I click on the application the graphs often then show something very different and carry as they were, so I'm going to say that I don't think that this is just an accurate display of the System Monitor going wrong, but rather something meaning that it is not displayed properly.

I can also close and reopen the Activities Overview and the System Monitor will only snap out of it when I actually go to it (though I will have to test if it only corrects the problem when I go to it through the Activities Overview, but I think that that is the case).

I am running Ubuntu GNOME 15.10 with GNOME 3.18, but I am sure that this issue was also present under Ubuntu GNOME 15.04 with GNOME 3.16. I only really do fresh installs so it's not going to just be faulty installation thing as I do them a lot.

description: updated
summary: - System Monitor graphs do not change often when viewing it through the
- Activities Overview
+ System Monitor numbers changes but not graphs when viewing it through
+ the Activities Overview (this happens often but not all the time)
summary: - System Monitor numbers changes but not graphs when viewing it through
- the Activities Overview (this happens often but not all the time)
+ System Monitor numbers change but not graphs when viewing it through the
+ Activities Overview (this happens often but not all the time)
Changed in gnome-shell:
importance: Unknown → Low
status: Unknown → Confirmed

This was under Xorg, now that I am running Wayland however the issue is much worse. Now not even the numbers, nothing does, even though it's running, it looks like just a still image of it in one state from the AO.

So is this still likely to be a GNOME issue or could it perhaps be with Xorg and Wayland or something else?

Changed in gnome-shell:
status: Confirmed → Incomplete
Changed in gnome-shell:
status: Incomplete → Fix Released
Paul White (paulw2u) wrote :

Upstream report is showing "RESOLVED FIXED" on 2018-07-21

Reporter no longer uses Launchpad but did say on the upstream
report that the bug was longer being seen with gnome-shell 3.28
Works ok here using Ubuntu 18.04 (gnome-shell 3.28.3) so closing as fixed.

Changed in gnome-system-monitor (Ubuntu):
status: New → Fix Released
Changed in gnome-shell (Ubuntu):
status: New → Fix Released
Changed in ubuntu-gnome:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.