New version uses CSD and doesn't work well under Unity

Bug #1261608 reported by Robert Ancell on 2013-12-17
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-system-monitor (Ubuntu)
Wishlist
Jackson Doak

Bug Description

Please update GNOME System Monitor to 3.10.2 - this release contains important bugfixes, for example LP bug #93847 (Excessive CPU usage by Gnome System Monitor) or sync latest 3.12.0-1 release from Debian testing - see debian/changelog:

gnome-system-monitor (3.12.0-1) unstable; urgency=medium

  * New upstream release.
  * Drop debian/patches/01-fix_ftbfs_hurd.patch, merged upstream.

 -- Andreas Henriksson <email address hidden> Mon, 24 Mar 2014 22:33:35 +0100

gnome-system-monitor (3.11.90-1) experimental; urgency=medium

  * New upstream release.

 -- Andreas Henriksson <email address hidden> Mon, 17 Feb 2014 22:12:59 +0100

gnome-system-monitor (3.10.2-2) unstable; urgency=medium

  * Upload to unstable
  * debian/patches/01-fix_ftbfs_hurd.patch: Fix FTBFS on hurd-i386
    (Closes: #738280)
  * Only enable systemd-logind support on linux architectures

 -- Laurent Bigonville <email address hidden> Sun, 16 Feb 2014 13:05:55 +0100

gnome-system-monitor (3.10.2-1) experimental; urgency=low

  * New upstream release.
    - Drop debian/patches/01-kfreebsd-define.patch: Applied upstream
    - debian/control.in: Bump build-dependencies
  * debian/control.in:
    - Bump Standards-Version to 3.9.5 (no further changes)
    - Add dependency against libsystemd-login-dev (>= 44)
  * debian/rules: Explicitly pass --enable-wnck and --enable-systemd to the
    configure

 -- Laurent Bigonville <email address hidden> Sat, 14 Dec 2013 16:17:43 +0100

Related branches

Robert Ancell (robert-ancell) wrote :

Can't be currently upgraded as has rendering issues. See lp:~robert-ancell/gnome-system-monitor/update-3.10.2 for updated packaging.

Changed in gnome-system-monitor (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
Robert Ancell (robert-ancell) wrote :

Also uses GtkHeaderBar which needs to be patched to work in 14.04.

description: updated
description: updated
summary: - Update GNOME System Monitor to 3.10.2
+ Update GNOME System Monitor to 3.10.2-2 or sync latest 3.12.0-1 release
+ from Debian testing
summary: - Update GNOME System Monitor to 3.10.2-2 or sync latest 3.12.0-1 release
- from Debian testing
+ [FFe] Update GNOME System Monitor to 3.10.2-2 or sync latest 3.12.0-1
+ release from Debian testing
tags: added: trusty

I've installed gnome-system-monitor version 3.10.2-0ubuntu1~trusty1 from ppa:gnome3-team/gnome3 (https://launchpad.net/~gnome3-team/+archive/gnome3/) and didn't noticed any problems in few weeks.

Why Ubuntu Unicorn and Trusty still has old and buggy gnome-system-monitor 3.8 ?

Sebastien Bacher (seb128) wrote :

@Mantas: how is 3.8 buggy?

The reason why 3.10 is not used has been stated in previous comment, it uses widgets that correctly only under gnome-shell and would be buggy/a regressions for users from other desktop environments

Mantas Kriaučiūnas (mantas) wrote :

gnome-system-monitor 3.8 has several bugs, some are already reported in Launchpad, see for example
LP bug #1174197 (gnome-system-monitor freezes when reordering columns in procs view), also
LP bug #93847 (Excessive CPU usage by Gnome System Monitor)

Btw, are you 100% sure, that 3.10 and 3.12 releases doesn't work correctly in other desktop environments than GNOME-Shell?

Sebastien Bacher (seb128) wrote 45 minutes ago:
> @Mantas: how is 3.8 buggy?
> The reason why 3.10 is not used has been stated in previous comment, it uses widgets that correctly only under gnome-shell and would be buggy/a regressions for users from other desktop environments

summary: - [FFe] Update GNOME System Monitor to 3.10.2-2 or sync latest 3.12.0-1
- release from Debian testing
+ Update to 3.12

The new version got uploaded by mistake to vivid, tagging the bug "block-proposed" to avoid migration

Jackson, do you think you can fix it to not use GtkHeaderBar decoration under Unity since your sync created the issue?

tags: added: block-proposed
Changed in gnome-system-monitor (Ubuntu):
assignee: nobody → Jackson Doak (noskcaj)
summary: - Update to 3.12
+ New version uses CSD and doesn't work well under Unity
Jackson Doak (noskcaj) wrote :

I've contacted upstream and it should be fixed for 3.16, so hopefully it will make it to vivid

Changed in gnome-system-monitor (Ubuntu):
status: Triaged → Fix Committed
status: Fix Committed → In Progress
Sebastien Bacher (seb128) wrote :

Thanks, testing that version I found other issues, the bg is transparent which makes the application quite unusable under Unity... that should be fixed before accepting in it vivid as well

Tim Lunn (darkxst) wrote :

the transparent background is caused by overlay scrollbars. I think larsu is going to look at this at some point, since I couldn't work out how to set the bg on the GtkStack.

Iain Lane (laney) wrote :

We gave up and blacklisted in g-s-m, uploading the new version with tim's patches nwo. Thanks!

Iain Lane (laney) on 2015-02-02
Changed in gnome-system-monitor (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers