gnome-system-monitor display without grid

Bug #1093582 reported by monochromec on 2012-12-25
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Gnome System Monitor
Fix Released
Medium
gnome-system-monitor (Ubuntu)
Low
Unassigned

Bug Description

gnome-system-monitor display without grid lines after refreshing or starting the application (cf. attached screenshot)

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gnome-system-monitor 3.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-21.32-generic 3.5.7.1
Uname: Linux 3.5.0-21-generic x86_64
ApportVersion: 2.6.1-0ubuntu9
Architecture: amd64
Date: Tue Dec 25 09:26:55 2012
InstallationDate: Installed on 2012-05-16 (222 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MarkForUpload: True
SourcePackage: gnome-system-monitor
UpgradeStatus: Upgraded to quantal on 2012-10-20 (65 days ago)

monochromec (monochromec) wrote :
Robert Roth (evfool) wrote :

What kind of graphic card are you using (intel/nvidia/ATI)? You can find this by running the command "lspci | grep VGA" in a terminal and pasting the result here.
Which driver are you using (open-source driver or binary driver)? You can find this info by running the command "jockey-text -l" in a terminal and pasting the result here.

Changed in gnome-system-monitor (Ubuntu):
status: New → Incomplete
monochromec (monochromec) wrote :

VGA info:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
        Subsystem: Apple Inc. Device 00db
        Flags: bus master, fast devsel, latency 0, IRQ 49
        Memory at a0000000 (64-bit, non-prefetchable) [size=4M]
        Memory at 90000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 2000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: i915

Driver info:

kmod:mac_hid - mac_hid (Free, Enabled, In use)
kmod:firewire_ohci - Driver for PCI OHCI IEEE1394 controllers (Free, Enabled, In use)
kmod:ghash_clmulni_intel - GHASH Message Digest Algorithm, acclerated by PCLMULQDQ-NI (Free, Enabled, In use)
kmod:usbmouse - USB HID Boot Protocol mouse driver (Free, Disabled, Not in use)
kmod:usbkbd - USB HID Boot Protocol keyboard driver (Free, Disabled, Not in use)
kmod:tg3 - Broadcom Tigon3 ethernet driver (Free, Enabled, In use)
kmod:evbug - Input driver event debug module (Free, Disabled, Not in use)
kmod:lpc_ich - LPC interface for Intel ICH (Free, Enabled, In use)
kmod:sdhci_pci - Secure Digital Host Controller Interface PCI driver (Free, Enabled, In use)
kmod:pcspkr - PC Speaker beeper driver (Free, Disabled, Not in use)
kmod:bcm5974 - Apple USB BCM5974 multitouch driver (Free, Enabled, In use)
kmod:bcma - Broadcom's specific AMBA driver (Free, Enabled, In use)
kmod:i915 - Intel Graphics (Free, Enabled, In use)
kmod:i2c_i801 - I801 SMBus driver (Free, Disabled, Not in use)
kmod:aesni_intel - Rijndael (AES) Cipher Algorithm, Intel AES-NI instructions optimized (Free, Enabled, In use)
kmod:hid_apple - hid_apple (Free, Enabled, In use)
kmod:microcode - Microcode Update Driver
Microcode Update Driver
AMD Microcode Update Driver (Free, Enabled, In use)
kmod:mei - Intel(R) Management Engine Interface (Free, Enabled, In use)
kmod:iTCO_wdt - Intel TCO WatchDog Timer Driver (Free, Disabled, Not in use)
kmod:btusb - Generic Bluetooth USB driver ver 0.6 (Free, Enabled, In use)
kmod:usbhid - USB HID core driver (Free, Enabled, In use)
kmod:coretemp - Intel Core temperature monitor (Free, Enabled, In use)
kmod:snd_hda_intel - Intel HDA driver (Free, Enabled, In use)
kmod:joydev - Joystick device interfaces (Free, Enabled, In use)
kmod:kvm_intel - kvm_intel (Free, Enabled, In use)
kmod:snd_pcsp - PC-Speaker driver (Free, Disabled, Not in use)

Robert Roth (evfool) on 2013-02-13
Changed in gnome-system-monitor (Ubuntu):
status: Incomplete → Triaged
Changed in gnome-system-monitor:
importance: Unknown → Medium
status: Unknown → Incomplete
Changed in gnome-system-monitor:
status: Incomplete → Confirmed
Robert Roth (evfool) wrote :

How often do you see this?
What value are you using as the Update interval in the preferences /Resources for the graphs?

Changed in gnome-system-monitor (Ubuntu):
status: Triaged → Incomplete
monochromec (monochromec) wrote :

Software defect seems to be gone after update to raring. Update interval is one second.

Robert Roth (evfool) wrote :

Marking as Invalid based on comment #5.

Changed in gnome-system-monitor (Ubuntu):
status: Incomplete → Invalid
Changed in gnome-system-monitor:
status: Confirmed → Fix Released
Jimmy Merrild Krag (beruic) wrote :

I'm having this issue after updating 13.04 to 13.10.

Jimmy Merrild Krag (beruic) wrote :

Also, every time I open the settings, all update intervals display as 0 until I edit them.

The grids disappear whenever changing to another program, and they reappear if I resize he window.

Robert Roth (evfool) wrote :

Yes, that's an issue fixed upstream, however Ubuntu still uses an older version, and probably won't get upgraded to the current stable release in the next cycle either, so unless someone's willing to backport the patch, this won't change.

Thanks for taking the time to comment to help Ubuntu improve.

Sebastien Bacher (seb128) wrote :

@Robert: is the new version depending on a GTK newer than 3.8? If not we might want to update this cycle...

Changed in gnome-system-monitor (Ubuntu):
importance: Undecided → Low
status: Invalid → Fix Committed
Robert Roth (evfool) wrote :

@Sebastian: Yes, System Monitor has been updated along with the other applications to fit in the GNOME ecosystem with headerbars, which is a 3.10 feature, and requires gtk 3.10. I have been looking at what could be easily backported, but system monitor has undergone some refactorings this cycle too, so changes are not too easily backported.
I will take some more time and to pick the best bugfixes and the ones which also appear in launchpad and can be ported easily, and come up with a system monitor ubuntu package update featuring those ones.

Robert Roth (evfool) wrote :

@Sebastian: I have checked from the system monitor git repo log what would be worth porting, and there's not much worth porting, basically the fix for this bug and another one for a wording change in bug #1156238. The other ones, some performance improvements and memory leak fixes are also interesting, but as these happened after serious refactorings, they can not be easily ported.
With the ones I have mentioned I have created a branch with new patches for it in /debian/patches, unfortunately bzr builddeb fails with some strange error, looks like it wants to revert the fix for the graph grid rendering issue based on the upstream 3.8.2.1.
I would appreciate if you could take a look into that branch, based on ubuntu:gnome-system-monitor, see it at lp:~evfool/gnome-system-monitor/stableupdates.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-monitor - 3.8.2.1-2ubuntu1

---------------
gnome-system-monitor (3.8.2.1-2ubuntu1) trusty; urgency=low

  * Backport some upstream changes
  * debian/patches/git_segfault_fix.patch
    - "Fix segfault on view mode change with process properties open."
      (lp: #1246813)
  * debian/patches/git_grid_rendering.patch:
    - "display without grid" (lp: #1093582)
  * debian/patches/git_chart_value.patch:
    - starts charts with the correct value instead of 0 (lp: #432184)
 -- Sebastien Bacher <email address hidden> Tue, 05 Nov 2013 16:03:26 +0100

Changed in gnome-system-monitor (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.