sushi-start crashed with SIGABRT in mb_release_filter_title()

Bug #983252 reported by vassilis karamitros on 2012-04-16
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Sushi
Fix Released
Medium
gnome-sushi (Ubuntu)
Medium
Unassigned

Bug Description

ubuntu 12.04 beta 2. tried to start sushi but it failed

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gnome-sushi 0.4.0-1ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
ApportVersion: 2.0.1-0ubuntu3
Architecture: i386
CrashCounter: 1
Date: Mon Apr 16 20:16:46 2012
ExecutablePath: /usr/lib/gnome-sushi/sushi-start
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120328)
ProcCmdline: /usr/lib/gnome-sushi/sushi-start
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
Signal: 6
SourcePackage: gnome-sushi
StacktraceTop:
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/i386-linux-gnu/libstdc++.so.6
 ?? () from /usr/lib/i386-linux-gnu/libstdc++.so.6
 std::terminate() () from /usr/lib/i386-linux-gnu/libstdc++.so.6
Title: sushi-start crashed with SIGABRT in raise()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

StacktraceTop:
 __gnu_cxx::__verbose_terminate_handler() () from /tmp/tmpuftrWy/usr/lib/i386-linux-gnu/libstdc++.so.6
 ?? () from /tmp/tmpuftrWy/usr/lib/i386-linux-gnu/libstdc++.so.6
 std::terminate() () from /tmp/tmpuftrWy/usr/lib/i386-linux-gnu/libstdc++.so.6
 __cxa_throw () from /tmp/tmpuftrWy/usr/lib/i386-linux-gnu/libstdc++.so.6
 std::__throw_logic_error(char const*) () from /tmp/tmpuftrWy/usr/lib/i386-linux-gnu/libstdc++.so.6

Changed in gnome-sushi (Ubuntu):
importance: Undecided → Medium
summary: - sushi-start crashed with SIGABRT in raise()
+ sushi-start crashed with SIGABRT in
+ __gnu_cxx::__verbose_terminate_handler()
tags: removed: need-i386-retrace
visibility: private → public
summary: - sushi-start crashed with SIGABRT in
- __gnu_cxx::__verbose_terminate_handler()
+ sushi-start crashed with SIGABRT in mb_release_filter_title()
Changed in gnome-sushi (Ubuntu):
status: New → Confirmed
Changed in gnome-sushi (Ubuntu):
status: Confirmed → Fix Committed
Changed in gnome-sushi:
importance: Unknown → Medium
status: Unknown → Fix Released
Vadim Rutkovsky (roignac) wrote :

This bug has been fixed upstream, but not yet released in Ubuntu's repos.
Could somebody affected try to test latest Sushi from git (use ppa:roignac/gnome-sushi) and report back here?
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Jeremy Bicha (jbicha) wrote :

How common is this crash? What is the risk of regression if we take the patch from Git?

Jeremy,
I've seen this about on every 3rd MP3 I had on my HDD. Sushi with
libmusicbrainz4 didn't crash at all.
The biggest problem that libmusicbrainz3 uses old way to access the
MuiscBrainz DB and is now not supported, so transition is imminent.

Lets wait for reports on the PPA package with a fix this - does it
crash, does it detect tags better etc.

Matt Fischer (mfisch) wrote :

Fixed in 0.5.1-0ubuntu1 in quantal. Also this appears to be a dupe of 870342, but there was a lot of comments here so I didn't dupe it.

Changed in gnome-sushi (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.