Sushi does not use Ambiance theme window decorations

Bug #876805 reported by Satchit Bhogle on 2011-10-17
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Sushi
Fix Released
Wishlist
gnome-sushi (Ubuntu)
Wishlist
Unassigned

Bug Description

OS: Ubuntu 11.10 Oneiric stable 32bit
Application: gnome-sushi 0.2.0-0ubuntu2

See attached image.
Sushi does not use Ambiance window decorations; rather, it appears similar to the GNOME3 default theme, Adwaita, with its thick decorations and window buttons on the right.

Satchit Bhogle (satchitb) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-sushi (Ubuntu):
status: New → Confirmed
Tobias Wolf (towolf) wrote :

Probably intentional, since it’s a custom window

Joschi Poschi (joschiposchi) wrote :

When you look at Gloobus (another preview application for Nautilus), there you can set the theme to current gtk-theme. I hope that this would be possible for Suhi as well.

Jeremy Bicha (jbicha) on 2011-11-06
Changed in gnome-sushi (Ubuntu):
importance: Undecided → Wishlist
Changed in gnome-sushi:
importance: Unknown → Wishlist
status: Unknown → New

I agree with Tobias here. I think the transparent black window is intentional; no other GNOME 3 window looks like that, even under Adwaita. Rather, I find that the issue is more that under Ambiance/Radiance the window seems to try picking up some of its theming from there and it does so poorly (see bugs 937141 and 937148 that I just filed).

Maybe the close button should be modified to look more like the close button from the current theme and sit on the correct (left) side of the window, but IMO the transparent black background should be kept for consistency across themes.

Changed in gnome-sushi:
status: New → Fix Released
Changed in gnome-sushi (Ubuntu):
status: Confirmed → Fix Committed
Vadim Rutkovsky (roignac) wrote :

This bug has been fixed upstream, but not yet released in Ubuntu's repos.
Could somebody affected try to test latest Sushi from git (use ppa:roignac/gnome-sushi) and report back here?

Client decorations can be set in 'org.gnome.sushi.client-decorations' dconf key
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

I just updated from the provided ppa and tested it out. Seems to be working as intended, and also looks like it'll fix Bug #880262 as well! Check my provided screenshot if you want to confirm everything looks as it's supposed to.

Looks good to me. Lets wait for the fix to settle in official repos -
then I'll change the bug status.

BTW this PPA will contain the latest unmodified code from git, so feel
free to check resolved issues and report bugs to upstream developers.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-sushi - 0.4.1-0ubuntu1

---------------
gnome-sushi (0.4.1-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Fix a crash when fetching album cover art (LP: #927555)
    - Move the window to the current desktop workspace when shown
      (LP: #897559)
    - Avoid maximization and window snapping
    - Plug some memory leaks
  * debian/control.in: Bump minimum clutter to 1.10
  * debian/90-make-fullscreen-button-placement-consistent.patch:
    - Git patch to move evince-viewer's fullscreen button to the right
      like other viewers (LP: #896987)
  * debian/91-add-client-decorations-preference.patch:
    - Git patch to add gsettings option to use native window
      management buttons
  * debian/gnome-sushi.gsettings-override:
    - Use native window management buttons by default (LP: #876805,
      LP: #880262)
 -- Jeremy Bicha <email address hidden> Sat, 21 Apr 2012 23:48:30 -0400

Changed in gnome-sushi (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.