sushi-start crashed with SIGABRT in mb_release_filter_title()

Bug #870342 reported by Pranesh Prakash on 2011-10-07
86
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Sushi
Unknown
Unknown
gnome-sushi (Ubuntu)
Medium
Unassigned

Bug Description

1. Oneiric beta2
2. gnome-sushi 0.2.0-0ubuntu2
3. Tried opening an mp3 file, and it crashed.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: gnome-sushi 0.2.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Sat Oct 8 03:31:09 2011
ExecutablePath: /usr/lib/gnome-sushi/sushi-start
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcCmdline: /usr/lib/gnome-sushi/sushi-start
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_IN
 LC_TIME=en_DK.UTF-8
Signal: 6
SourcePackage: gnome-sushi
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
 std::terminate() () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
Title: sushi-start crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to oneiric on 2011-08-23 (45 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Pranesh Prakash (the-solipsist) wrote :

StacktraceTop:
 __gnu_cxx::__verbose_terminate_handler () at ../../../../src/libstdc++-v3/libsupc++/vterminate.cc:95
 __cxxabiv1::__terminate (handler=<optimized out>) at ../../../../src/libstdc++-v3/libsupc++/eh_terminate.cc:40
 std::terminate () at ../../../../src/libstdc++-v3/libsupc++/eh_terminate.cc:50
 __cxxabiv1::__cxa_throw (obj=0x244efc0, tinfo=<optimized out>, dest=<optimized out>) at ../../../../src/libstdc++-v3/libsupc++/eh_throw.cc:83
 std::__throw_logic_error (__s=0x7fae5f74da98 "basic_string::_S_construct null not valid") at ../../../../src/libstdc++-v3/src/functexcept.cc:66

Changed in gnome-sushi (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Jeremy Bicha (jbicha) on 2011-10-15
visibility: private → public

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-sushi (Ubuntu):
status: New → Confirmed
Vadim Rutkovsky (roignac) wrote :

Could you please attach the file you were playing?

sk (sreekumar-r84-live) wrote :

Got the same issue in precise (12.04) as well

Daniel Dietrich (shaddowy2) wrote :

Sushi crashed for me too, Precise 64 bit, but I can't remember which mp3 was the cause, as 9 out of 10 work fine. I found another file which doesn't crash, but doesn't play.
You can find the stubborn file here: http://ubuntuone.com/1sSCAT4jje91oqZ716YbX2
It seems to be related to the tags. If I remove some tags of it, I can hear the first second playing, then sushi closes.
If I remove every tag, it plays fine. I can also just add some text to the album tag and it plays fine. I edit my files with kid3-qt (ID3v2.4.0 (TagLib) with ISO-8859-1 text coding).

You can download the original file from: http://ccmixter.org/files/Blackberry/17059 which plays fine for me...

Vadim Rutkovsky (roignac) wrote :

This might be solved by transition to libmusicbrainz4, see https://bugzilla.gnome.org/show_bug.cgi?id=669931

summary: - sushi-start crashed with SIGABRT in raise()
+ sushi-start crashed with SIGABRT in mb_release_filter_title()

beta 2, ubuntu 12.04
tried to open a mp3 file

Phil Corbett (chubble-10) wrote :

Beta 2, Ubuntu 12.04
Tried to open the example .ogg file in the Ubuntu Free Culture Showcase thing.

Changed in gnome-sushi (Ubuntu):
status: Confirmed → Triaged
status: Triaged → Fix Committed
Vadim Rutkovsky (roignac) wrote :

This bug has been fixed upstream, but not yet released in Ubuntu's repos.
Could somebody affected try to test latest Sushi from git (use ppa:roignac/gnome-sushi) and report back here?
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

tags: added: precise
Matt Fischer (mfisch) wrote :

Fixed in 0.5.1-0ubuntu1 in quantal.

Changed in gnome-sushi (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.