Sushi-start fails with 16.10 upgrade, both Unity and Mate

Bug #1644781 reported by TuxVinyards on 2016-11-25
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Undecided
Unassigned
gnome-sushi (Ubuntu)
High
FanJun Kong - ( BH1SCW )

Bug Description

Dmesg:[ 573.856456] traps: sushi-start[4619] trap int3 ip:7f7ea46c3241 sp:7ffe3ae23350 error:0 in libglib-2.0.so.0.5000.0[7f7ea4673000+110000]

Since upgrade to 16.10 from 16.04 Sushi fails when pressing space-bar. In Mate, space-bar causes pluma text editor to open ...

Sorry, I am not the greatest fan of the Gnome 3 interface, so it's probably down to me on this one. LOL However, if there is a quick fix, maybe an alt-space-bar option ??

summary: - Sushi-start fails with 16.10, both Unity and Mate
+ Sushi-start fails with 16.10 upgrade, both Unity and Mate
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-sushi (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2016-12-23
Changed in gnome-sushi (Ubuntu):
importance: Undecided → High
tags: added: yakkety zesty
Changed in ubuntu-gnome:
status: New → Confirmed

hi, could you try this:

apt-get install gir1.2-evince-3.0

Changed in gnome-sushi (Ubuntu):
assignee: nobody → FanJun Kong - ( BH1SCW ) (fjkong)
status: Confirmed → Incomplete

fixed in Debian #842319

Changed in ubuntu-gnome:
status: Confirmed → In Progress

Looks like a good move in the right direction! Not a full fix for me but a definite improvement.

Installing gir1.2-evince-3.0 gets Sushi starting when using the Unity interface. It works on different types of files; .txt .png ..

There's a wierd extra section to the menu bar though. I guess it's liveable with but it has a bit of a lash-up feel to it. It's semi-transparent so any background text shows through and catches the eye when you look for the start of the read.

Different story with the Mate desktop. Doesn't work at all. But I am not seeing any errors thrown in dmesg, so maybe not all bad.

I tried installing a whole bunch of the other gir libraries as well > lightdm, matekbd, hud, mate-desktop etc but no improvement with either desktop. :(

Unity is the manager on my main computer, so pleased to read these updates this morning.

Thanks.

hi
it works for me on 16.10, I am not very clear what you mean:"There's a wierd extra section to the menu bar though. I guess it's liveable with but it has a bit of a lash-up feel to it. It's semi-transparent so any background text shows through and catches the eye when you look for the start of the read."

could you explain more detail?
thanks

Changed in ubuntu-gnome:
status: In Progress → Invalid

Let me know if more needed.

I see what you mean now, I think it is normal, you can try to maximize window and you can see all other area is tranparent.

Yep. I think this is it.

If I manually adjust the window it all goes away. But if I close the default window it doesn't remember the size I set it to. It goes back to being off size.

Do you know where the configs are for the default window sizes? Reducing the vertical height seems to fix it for me ....

Try this. I think this might be the fix?

Edit /usr/share/sushi/js/util/constants.js

Change 'let VIEW_PADDING_Y = 28;' to 'let VIEW_PADDING_Y = 2;'

Tell me what you think. ;)

Thanks for this, I tried and it look perfect comparing to old one, I just not sure if this change will affect other things, we need to test more.

1. The no-run problem still exists with Ubuntu Mate.

I, personally, use Mate on older laptop. I prefer it to Lubuntu. I can live without Sushi running there. Others, however may not. Mate may be their main OS.

Taking another look at my the Mate problem, I wonder if it is 64bit versus 32bit issue? I haven't tried sushi with 64bit Mate. How far does Canonical support run to the Mate project?

2. On the matter of the 'Y padding'; I am finding this fix to be consistently good. To me, it looks like a dev error that's slipped through.

This is probably something to take up with Cosimo Cecchi. I have checked the source code over at https://git.gnome.org/browse/sushi. The 'error' seems persistent. But I see no rhyme and reason for it.

To me, it looks like something that I would do to test the padding feature, ie stick the extra 8 in there but leave the 2 there to remind me of the original setting. Then like me, someone walks in the room and distracts me. I go off to do something else and when I go back to the code, I am tired, forgotten what I was doing, it looks okay at a glance, so it gets wrapped up and left ....

davstar (davstar) wrote :

Sorry for interupt your discussion...

I'm on Ubuntu 16.10 with Unity and was also effected with this bug.

apt-get install gir1.2-evince-3.0
solved my problem.

Thanks.

Danial Behzadi (dani.behzi) wrote :

The bug marled as Invalid, since 16.10 is out of support.

Changed in gnome-sushi (Ubuntu):
status: Incomplete → Invalid

I think I would like to mark this as 'closed'. It was a valid bug, at the time, and @fjkong managed a good fix for Unity.

Looking back, I don't think it could ever have been fixed for Ubuntu Mate. The architecture is too different. It would need a load of code, not just a tweak or two.

Changed in gnome-sushi (Ubuntu):
status: Invalid → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers