package gnome-split 1.2-1 failed to install/upgrade: trying to overwrite directory '/usr/share/pixmaps' in package gnome-search-tool 3.6.0-2 with nondirectory

Bug #1758120 reported by nabin on 2018-03-22
180
This bug affects 25 people
Affects Status Importance Assigned to Milestone
gnome-split (Ubuntu)
Status tracked in Cosmic
Bionic
High
fossfreedom
Cosmic
High
fossfreedom

Bug Description

[Impact]

 * The package cannot be installed on bionic since the package that has been produced has the /usr/share/pixmaps as a file not as a folder.

[Test Case]

 * Install the package on any Ubuntu flavour

[Regression Potential]

 * None - the patch is a no change rebuild so fixes something that is fundamentally broken.

[Other Info]

 * None

[Original Description]

I'm using Pantheon on ubuntu 18.04. Just testing out

ProblemType: Package
DistroRelease: Ubuntu 18.04
Package: gnome-split 1.2-1
Uname: Linux 4.15.12-041512-generic x86_64
ApportVersion: 2.20.8-0ubuntu10
AptOrdering:
 gnome-split:amd64: Install
 NULL: ConfigurePending
Architecture: amd64
Date: Thu Mar 22 23:38:08 2018
DpkgTerminalLog:
 Preparing to unpack .../gnome-split_1.2-2_all.deb ...
 Unpacking gnome-split (1.2-2) over (1.2-1) ...
 dpkg: error processing archive /var/cache/apt/archives/gnome-split_1.2-2_all.deb (--unpack):
  trying to overwrite directory '/usr/share/pixmaps' in package gnome-search-tool 3.6.0-2 with nondirectory
ErrorMessage: trying to overwrite directory '/usr/share/pixmaps' in package gnome-search-tool 3.6.0-2 with nondirectory
PackageArchitecture: all
Python3Details: /usr/bin/python3.6, Python 3.6.4+, python3-minimal, 3.6.4-1
PythonDetails: /usr/bin/python2.7, Python 2.7.14+, python-minimal, 2.7.14-4
RelatedPackageVersions:
 dpkg 1.19.0.5ubuntu1
 apt 1.6~beta1
SourcePackage: gnome-split
Title: package gnome-split 1.2-1 failed to install/upgrade: trying to overwrite directory '/usr/share/pixmaps' in package gnome-search-tool 3.6.0-2 with nondirectory
UpgradeStatus: No upgrade log present (probably fresh install)

nabin (nabin6707-7) wrote :
tags: added: package-conflict
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-search-tool (Ubuntu):
status: New → Confirmed
Changed in gnome-split (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

gnome-split ships /usr/share/pixmaps as a file, that's going to work since that's a base directory

Changed in gnome-split (Ubuntu):
importance: Undecided → High
Changed in gnome-search-tool (Ubuntu):
status: Confirmed → Invalid
fossfreedom (fossfreedom) wrote :

This appears to only need a rebuild. I've tested this via pbuilder-dist on bionic as well as my PPA (https://launchpad.net/~ubuntubudgie-dev/+archive/ubuntu/unstable-test/+packages) that has proposed enabled.

pixmaps is now a folder in the rebuilt binary not a file as before.

Why the sync from debian produced a pixmaps file I don't know because on debian sid gnome-split has a pixmaps folder

Changed in gnome-split (Ubuntu):
assignee: nobody → fossfreedom (fossfreedom)
description: updated
tags: added: patch
no longer affects: gnome-search-tool (Ubuntu)
Simon Quigley (tsimonq2) on 2018-05-28
Changed in gnome-split (Ubuntu Bionic):
importance: Undecided → High
assignee: nobody → fossfreedom (fossfreedom)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-split - 1.2-2build1

---------------
gnome-split (1.2-2build1) cosmic; urgency=medium

  * No change rebuild to fix package installation (LP: #1758120).

 -- David Mohammed <email address hidden> Thu, 17 May 2018 20:30:18 +0100

Changed in gnome-split (Ubuntu Cosmic):
status: Confirmed → Fix Released

Hello nabin, or anyone else affected,

Accepted gnome-split into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-split/1.2-2build0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-split (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Sebastien Bacher (seb128) wrote :

The new 1.2-2build0.1 version indeed correctly ships /usr/share/pixmaps as a directory

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-split - 1.2-2build0.1

---------------
gnome-split (1.2-2build0.1) bionic; urgency=medium

  * No change rebuild to fix package installation (LP: #1758120).

 -- David Mohammed <email address hidden> Thu, 17 May 2018 20:30:18 +0100

Changed in gnome-split (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-split has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers