Use new media API

Bug #1799614 reported by Robert Ancell on 2018-10-24
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
High
Unassigned
Xenial
High
Robert Ancell
Bionic
High
Robert Ancell
Cosmic
High
Robert Ancell
snapd-glib (Ubuntu)
High
Unassigned
Bionic
High
Robert Ancell
Cosmic
High
Robert Ancell

Bug Description

[Impact]
snapd now provides 'media' which replaces the old 'screenshots' data. We need to migrate to this as the old screenshot data will be removed in the future.

[Test Case]
Run gnome-software with updated snapd-glib and confirm that screenshots and promoted snap banners continue to work.

[Regression Potential]
Possibility of new errors being introduced in updated code paths.

Changed in gnome-software (Ubuntu Trusty):
importance: Undecided → High
Changed in gnome-software (Ubuntu Xenial):
importance: Undecided → High
Changed in gnome-software (Ubuntu Bionic):
importance: Undecided → High
Changed in gnome-software (Ubuntu Cosmic):
importance: Undecided → High
Changed in gnome-software (Ubuntu Trusty):
assignee: nobody → Robert Ancell (robert-ancell)
status: New → Fix Committed
Changed in gnome-software (Ubuntu Xenial):
status: New → Fix Committed
no longer affects: gnome-software (Ubuntu Trusty)
Changed in gnome-software (Ubuntu Xenial):
assignee: nobody → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

Bionic patch is in https://gitlab.gnome.org/robert.ancell/gnome-software/tree/media-api-3-30, will forward port that to 3.32 and master when we're happy with it.

Changed in gnome-software (Ubuntu Bionic):
status: New → In Progress
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu Cosmic):
assignee: nobody → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

Support in snapd in version 2.36 [1] which is not currently in any Ubuntu release.

[1] https://github.com/snapcore/snapd/commit/08bbeb7289fb943ab6c78432579eaceae555ac71

Changed in gnome-software (Ubuntu):
status: New → Fix Committed
Changed in gnome-software (Ubuntu Bionic):
status: In Progress → Fix Committed
Changed in gnome-software (Ubuntu Cosmic):
status: New → Fix Committed
Changed in snapd-glib (Ubuntu):
status: New → Fix Released
Changed in snapd-glib (Ubuntu Bionic):
importance: Undecided → High
Changed in snapd-glib (Ubuntu Cosmic):
importance: Undecided → High
Changed in snapd-glib (Ubuntu Xenial):
importance: Undecided → Low
Changed in snapd-glib (Ubuntu):
importance: Undecided → High
Changed in snapd-glib (Ubuntu Cosmic):
status: New → In Progress
Changed in snapd-glib (Ubuntu Bionic):
status: New → Triaged
Changed in snapd-glib (Ubuntu Xenial):
status: New → Triaged
description: updated
Changed in snapd-glib (Ubuntu Cosmic):
status: In Progress → Fix Committed
no longer affects: snapd-glib (Ubuntu Xenial)
Changed in snapd-glib (Ubuntu Bionic):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.30.6-2ubuntu2

---------------
gnome-software (3.30.6-2ubuntu2) disco; urgency=medium

  * debian/patches/0025-snap-Use-new-media-API.patch:
    - Use new snapd media API (LP: #1799614)

 -- Robert Ancell <email address hidden> Fri, 18 Jan 2019 15:26:44 +1300

Changed in gnome-software (Ubuntu):
status: Fix Committed → Fix Released

Hello Robert, or anyone else affected,

Accepted gnome-software into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.30.2-0ubuntu9 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-cosmic
Brian Murray (brian-murray) wrote :

The upload of snapd-glib is a new upstream version of the package yet only this bug report is referenced in the changelog for it. Is there a special exception for new versions of snapd-glib that I'm not aware of?

Robert Ancell (robert-ancell) wrote :

@brian-murray - there isn't a special exception, so I have written a proposal:
https://wiki.ubuntu.com/SnapdGlibUpdates

The next step is to submit it to a member of the SRU team - would you be able to review it?

snapd-glib should mostly fit section 2.3 "New upstream microreleases" from https://wiki.ubuntu.com/StableReleaseUpdates. The main difference is new features are regularly added because we play catch-up with snapd. Note that old features are never removed and new features are added in a compatible way to not interfere with older API.

An upload of snapd-glib to cosmic-proposed has been rejected from the upload queue for the following reason: "contains changes unrelated to the bug listed in the changelog; currently no SRU exception is approved. Can be reuploaded as-is after an SRU exception is approved, or can be uploaded with just the changes for the bug you're proposing to fix, but in the meantime rejecting the upload rather than leaving it stalled in the queue.".

Changed in snapd-glib (Ubuntu Bionic):
status: Fix Committed → In Progress
Changed in snapd-glib (Ubuntu Cosmic):
status: Fix Committed → In Progress
Changed in snapd-glib (Ubuntu Bionic):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in snapd-glib (Ubuntu Cosmic):
assignee: nobody → Robert Ancell (robert-ancell)
Steve Langasek (vorlon) wrote :

An upload of gnome-software to cosmic-proposed has been rejected from the upload queue for the following reason: "reuploading with different -v option to avoid listing LP: #1799614 which is *un*fixed in this version".

Robert Ancell (robert-ancell) wrote :

The pending SRU page (http://people.canonical.com/~ubuntu-archive/pending-sru.html) still shows this bug as blocking the SRU.

Temporarily marking as verified in cosmic, though no change has occurred. Will re-use this bug once that SRU is complete and we are ready for the media API update.

tags: added: verification-done-cosmic
removed: verification-needed verification-needed-cosmic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.30.2-0ubuntu10

---------------
gnome-software (3.30.2-0ubuntu10) cosmic; urgency=medium

  * debian/rules:
    - Switch from deprecated Ubuntu reviews to ODRS (LP: #1815708)
  * debian/patches/0025-snap-Use-new-media-API.patch:
  * debian/control:
    - Disable for now, still blocked on snapd-glib update

 -- Robert Ancell <email address hidden> Thu, 14 Feb 2019 11:52:46 +1300

Changed in gnome-software (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Changed in gnome-software (Ubuntu Cosmic):
status: Fix Released → Fix Committed
Changed in snapd-glib (Ubuntu Bionic):
status: In Progress → Fix Released
Changed in snapd-glib (Ubuntu Cosmic):
status: In Progress → Fix Released

Hello Robert, or anyone else affected,

Accepted gnome-software into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.30.2-0ubuntu11 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-cosmic
removed: verification-done-cosmic
Łukasz Zemczak (sil2100) wrote :

Hello Robert, or anyone else affected,

Accepted gnome-software into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.28.1-0ubuntu4.18.04.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed-bionic

An upload of gnome-software to xenial-proposed has been rejected from the upload queue for the following reason: "Since this upload includes the same change for 'new media API' as others, I would feel much safer if we set a minimal version depenency to libsnapd-glib-dev (>= 1.45) - since it seems there was more than one snapd-glib version in xenial.".

Robert Ancell (robert-ancell) wrote :

gnome-software 3.20 actually has it's own implementation of the snapd communication code (snapd-glib evolved from that) so it doesn't need a version bump. It's only using a trivial amount of the snapd-glib code.

Robert Ancell (robert-ancell) wrote :

Tested in 18.04 LTS (gnome-software 3.28.1-0ubuntu4.18.04.10). Screenshots and icons continue to show using new API.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Robert Ancell (robert-ancell) wrote :

Tested in 19.10 (gnome-software 3.30.2-0ubuntu11). Screenshots and icons continue to show using new API.

tags: added: verification-done-cosmic
removed: verification-needed verification-needed-cosmic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.30.2-0ubuntu11

---------------
gnome-software (3.30.2-0ubuntu11) cosmic; urgency=medium

  * debian/patches/0025-snap-Use-new-media-API.patch:
  * debian/control:
    - Use new snapd media API (LP: #1799614)
  * debian/patches/0026-odrs-Only-show-reviews-from-the-same-distribution.patch:
    - Show only Ubuntu reviews (LP: #1825064)

 -- Robert Ancell <email address hidden> Wed, 17 Apr 2019 14:48:48 +1200

Changed in gnome-software (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-software has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.28.1-0ubuntu4.18.04.10

---------------
gnome-software (3.28.1-0ubuntu4.18.04.10) bionic; urgency=medium

  * debian/control:
  * debian/patches/0027-snap-Use-new-media-API.patch:
    - Use new snapd media API (LP: #1799614)
  * debian/patches/0030-odrs-Only-show-reviews-from-the-same-distribution.patch:
    - Show only Ubuntu reviews (LP: #1825064)

 -- Robert Ancell <email address hidden> Wed, 17 Apr 2019 12:48:34 +1200

Changed in gnome-software (Ubuntu Bionic):
status: Fix Committed → Fix Released

Hello Robert, or anyone else affected,

Accepted gnome-software into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.20.5-0ubuntu0.16.04.12 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-xenial
Robert Ancell (robert-ancell) wrote :

Tested gnome-software 3.20.5-0ubuntu0.16.04.12. Screenshots and icons continue to show using new API.

tags: added: verification-done-xenial
removed: verification-needed verification-needed-xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers