gnome-software crashes with assertion failure Gs:ERROR:../lib/gs-plugin-loader.c:1698:gs_plugin_loader_pending_apps_add: assertion failed: (gs_app_list_length (list) > 0)

Bug #1798236 reported by Chris Guiver on 2018-10-17
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
High
Robert Ancell
Cosmic
High
Robert Ancell

Bug Description

* Impact

gnome-software segfaults on i386

* Test case

Try to open a category or install a deb on an i386 cosmic instance, it should work

* Regression potential

Nothing specific to test, make sure gnome-software still works on amd64

----------------

https://errors.ubuntu.com/problem/bbef7c8fd9bdc0335c409ee79addfef391dda0e9

---

using the live earlier today I had this issue, I re-zsync'd cosmic daily & re-wrote to thumb-drive, then re-tested - same issue.

load "software' at main menu; search for leafpad (chosen only because it's small & I know name), then clicking install - it sits awhile then software closes.

after software closes, error/warning-type-windows appear saying

"Invalid problem report - No such file or directory"

I re-loaded [gnome-]software from terminal & the output is as follows (same results on screen, search leafpad, select it then click install - software closes/abends..)

xubuntu@xubuntu:~$ gnome-software
02:33:47:0241 Gs plugin appstream took 2.6 seconds to do setup
02:33:47:0263 Gs enabled plugins: desktop-categories, fwupd, os-release, packagekit, packagekit-local, packagekit-offline, packagekit-proxy, packagekit-refine-repos, packagekit-refresh, packagekit-upgrade, packagekit-url-to-app, ubuntuone, appstream, desktop-menu-path, hardcoded-blacklist, hardcoded-featured, hardcoded-popular, modalias, packagekit-refine, rewrite-resource, steam, ubuntu-reviews, packagekit-history, provenance, snap, systemd-updates, generic-updates, provenance-license, icons, key-colors, key-colors-metadata
02:33:47:0264 Gs disabled plugins: dpkg, dummy, repos, shell-extensions, epiphany, odrs
02:33:51:0925 Gs Only 5 apps for popular list, hiding
02:33:54:0421 Gs hiding category graphics featured applications: found only 8 to show, need at least 9
02:42:31:0827 GLib-GObject g_object_new_is_valid_property: object class 'GsPluginJob' has no property named ''
**
Gs:ERROR:../lib/gs-plugin-loader.c:1698:gs_plugin_loader_pending_apps_add: assertion failed: (gs_app_list_length (list) > 0)
Aborted (core dumped)

(( sorry if this is duplicate; I quickly scanned and didn't see, but will scan some more as I add more info to this report ))

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: gnome-software 3.30.2-0ubuntu3 [modified: usr/share/gnome-shell/search-providers/org.gnome.Software-search-provider.ini]
ProcVersionSignature: Ubuntu 4.18.0-10.11-generic 4.18.12
Uname: Linux 4.18.0-10-generic i686
ApportVersion: 2.20.10-0ubuntu13
Architecture: i386
CasperVersion: 1.399
CurrentDesktop: XFCE
Date: Wed Oct 17 02:43:12 2018
InstalledPlugins:
 gnome-software-plugin-flatpak N/A
 gnome-software-plugin-limba N/A
 gnome-software-plugin-snap 3.30.2-0ubuntu3
LiveMediaBuild: Xubuntu 18.10 "Cosmic Cuttlefish" - Release i386 (20181016)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-software
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.xdg.autostart.gnome-software-service.desktop: [deleted]

note: this has now been tested on three machines, same results (for leafpad & gedit) using same thumb-drive & daily iso. However I got the same result on yesterday's iso on dx6120 (first tested system) but didn't have time then to fully diagnose & submit - now done (on newer iso)
--
I booted on a QA-test installed Xubuntu 18.10 (/dev/sda2) on the dx6120, sudo apt update; sudo apt dist-upgrade; then tried gnome-software to add leafpad, gedit... same result -- see comment #12

Chris Guiver (guiverc) wrote :
Chris Guiver (guiverc) wrote :
Chris Guiver (guiverc) wrote :

I didn't see anything useful in `dmesg` ...

Chris Guiver (guiverc) wrote :

I didn't see anything useful in `dmesg` ...

Chris Guiver (guiverc) wrote :

re-ran test on thinkpad sl510 (c2d-t6\6570, 2gb, i915)

connected wifi, sudo apt update; looked at updates & saw gnome-software, so dist-upgrade
then ran gnome-software from term & tried to install leafpad

same result as dx6120 (first tested system)

xubuntu@xubuntu:~$ gnome-software
03:27:29:0967 Gs plugin appstream took 1.6 seconds to do setup
03:27:29:0981 Gs enabled plugins: desktop-categories, fwupd, os-release, packagekit, packagekit-local, packagekit-offline, packagekit-proxy, packagekit-refine-repos, packagekit-refresh, packagekit-upgrade, packagekit-url-to-app, ubuntuone, appstream, desktop-menu-path, hardcoded-blacklist, hardcoded-featured, hardcoded-popular, modalias, packagekit-refine, rewrite-resource, steam, ubuntu-reviews, packagekit-history, provenance, snap, systemd-updates, generic-updates, provenance-license, icons, key-colors, key-colors-metadata
03:27:29:0981 Gs disabled plugins: dpkg, dummy, repos, shell-extensions, epiphany, odrs
03:27:36:0238 Gs Only 5 apps for popular list, hiding
03:27:40:0540 Gs hiding category graphics featured applications: found only 8 to show, need at least 9
03:27:49:0207 GLib-GObject g_object_new_is_valid_property: object class 'GsPluginJob' has no property named ''
**
Gs:ERROR:../lib/gs-plugin-loader.c:1698:gs_plugin_loader_pending_apps_add: assertion failed: (gs_app_list_length (list) > 0)
Aborted (core dumped)
xubuntu@xubuntu:~$ sudo lshw >lshw_sl510.txt
xubuntu@xubuntu:~$ sudo journalctl -a >journalctl-a_sl510.txt

Chris Guiver (guiverc) wrote :
Chris Guiver (guiverc) wrote :
Download full text (5.5 KiB)

ran test in d610 (latitude d610, pentium m, single core, 1gb ram..)

steps:

today's daily xubuntu x86
sudo apt update;
sudo apt dist-upgrade

// gnome-software is updated in dist-upgrade
// this time I try leafpad but searched wallpapers, then gedit & tried to install gedit
// crash

note: I've not had any pop-ups !!

xubuntu@xubuntu:~$
xubuntu@xubuntu:~$ apt-cache policy gnome-software
gnome-software:
  Installed: 3.30.2-0ubuntu4
  Candidate: 3.30.2-0ubuntu4
  Version table:
 *** 3.30.2-0ubuntu4 500
        500 http://archive.ubuntu.com/ubuntu cosmic/main i386 Packages
        100 /var/lib/dpkg/status
xubuntu@xubuntu:~$ gnome-software
03:49:11:0604 Gs plugin appstream took 2.4 seconds to do setup
03:49:11:0619 Gs enabled plugins: desktop-categories, fwupd, os-release, packagekit, packagekit-local, packagekit-offline, packagekit-proxy, packagekit-refine-repos, packagekit-refresh, packagekit-upgrade, packagekit-url-to-app, ubuntuone, appstream, desktop-menu-path, hardcoded-blacklist, hardcoded-featured, hardcoded-popular, modalias, packagekit-refine, rewrite-resource, steam, ubuntu-reviews, packagekit-history, provenance, systemd-updates, generic-updates, provenance-license, icons, key-colors, key-colors-metadata
03:49:11:0619 Gs disabled plugins: dpkg, dummy, repos, shell-extensions, epiphany, odrs, snap
03:49:17:0045 Gs hiding category games featured applications: found only 0 to show, need at least 9
03:49:24:0948 GsPluginPackageKit Failed to find one package for firefox.desktop, /usr/share/applications/firefox.desktop, [0]
03:49:25:0798 Gs hiding category graphics featured applications: found only 1 to show, need at least 9
03:49:25:0925 Gs Only 8 apps for popular list, hiding
03:49:30:0050 Gs ignoring non-installed app GsApp: [0xafa27540]
kind: desktop
state: available
quirk: provenance
id: org.gnome.Software.desktop
unique-id: system/package/ubuntu-cosmic-main/desktop/org.gnome.Software.desktop/*
scope: system
bundle-kind: package
kudos: my-language|recent-release|has-keywords|has-screenshots|perfect-screenshots|hi-dpi-icon
kudo-percentage: 100
name: GNOME Software
pixbuf: 0x2f7f160
icon-kind: stock
icon-name: org.gnome.Software
icon-prefix: /var/lib/app-info/icons/ubuntu-cosmic-main
icon-kind: cached
icon-name: gnome-software_org.gnome.Software.png
icon-prefix: /var/lib/app-info/icons/ubuntu-cosmic-main
icon-kind: remote
version: 3.30.2-0ubuntu4
summary: Application manager for GNOME
description: Software allows you to find and install new applications and system extensions and remove existing installed applications.

GNOME Software showcases featured and popular applications with useful descriptions and multiple screenshots per application. Applications can be found either through browsing the list of categories or by searching. It also allows you to update your system using an offline update.
screenshot-00: http://appstream.ubuntu.com/media/cosmic/org/gnome/Software.desktop/0ED3F40BBF7E...

Read more...

Chris Guiver (guiverc) wrote :

i won't upload lshw for d610 - i summarize in testing as
"dell latitude d610 (pentium m, 1gb, intel i915)"
& I can upload if useful

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1798236

tags: added: iso-testing
Chris Guiver (guiverc) on 2018-10-17
description: updated
Chris Guiver (guiverc) on 2018-10-17
summary: - xubuntu 18.10 daily (x86 live) - software cannot install leafpad
+ xubuntu 18.10 daily (x86 live & installed) - [gnome-]software cannot
+ install leafpad/gedit/software
description: updated

booted dx6120 using recent QA install (/dev/sda2) of xubuntu 18.10

sudo apt update
sudo apt dist-upgrade
gnome-software // and tried to install gedit

guiverc@dx6120x2:~$ gnome-software
05:29:09:0346 Gs plugin appstream took 4.7 seconds to do setup
05:29:09:0393 Gs enabled plugins: desktop-categories, fwupd, os-release, packagekit, packagekit-local, packagekit-offline, packagekit-proxy, packagekit-refine-repos, packagekit-refresh, packagekit-upgrade, packagekit-url-to-app, ubuntuone, appstream, desktop-menu-path, hardcoded-blacklist, hardcoded-featured, hardcoded-popular, modalias, packagekit-refine, rewrite-resource, steam, ubuntu-reviews, packagekit-history, provenance, snap, systemd-updates, generic-updates, provenance-license, icons, key-colors, key-colors-metadata
05:29:09:0393 Gs disabled plugins: dpkg, dummy, repos, shell-extensions, epiphany, odrs
05:29:21:0064 Gs Only 5 apps for popular list, hiding
05:29:23:0094 Gs hiding category graphics featured applications: found only 8 to show, need at least 9
05:29:45:0999 GLib-GObject g_object_new_is_valid_property: object class 'GsPluginJob' has no property named '�ZZ'
**
Gs:ERROR:../lib/gs-plugin-loader.c:1698:gs_plugin_loader_pending_apps_add: assertion failed: (gs_app_list_length (list) > 0)
Aborted (core dumped)
guiverc@dx6120x2:~$

Note: no pop-ups are occuring on installed [dx6120] system, as they didn't in d610 version, unlike live on dx6120 or sl510. I noted a couple of internal-crash reports that I clicked send on. This is also an installed system, so I can explore if helpful

guiverc@dx6120x2:~$ ls -ltrh /var/crash/
total 18M
-rw-r----- 1 guiverc whoopsie 18M Oct 17 16:30 _usr_bin_gnome-software.1000.crash
-rw-rw-r-- 1 guiverc whoopsie 0 Oct 17 16:30 _usr_bin_gnome-software.1000.upload
-rw------- 1 whoopsie whoopsie 0 Oct 17 16:30 _usr_bin_gnome-software.1000.uploaded

Will Cooke (willcooke) wrote :

I installed xubuntu in to a VM from the latest ISO and could use G-S as expect and could install leafpad ok. I'll do more testing.

Iain Lane (laney) wrote :

I just tried to reproduce this with xubuntu 20181017. I couldn't - see the attached screenshot.

One difference is that I was using amd64 and not i386.

This is the error bucket: https://errors.ubuntu.com/bucket/?id=/usr/bin/gnome-software%3A6%3Ag_assertion_message%3Ag_assertion_message_expr%3Ags_plugin_loader_pending_apps_add%3Ags_plugin_loader_process_thread_cb%3Ags_plugin_loader_process_in_thread_pool_cb

Chris Guiver (guiverc) wrote :

Email popped up & I saw last two comments...

I booted dx6120 & a Lubuntu 18.10 test install;

sudo apt update
sudo apt full-upgrade
sudo apt install gnome-software (pulling in...)
gnome-software

searched & tried to install 'leafpad'

--- (copy from end of 'install gnome-software'..
Setting up software-properties-gtk (0.96.27) ...
Setting up gnome-software (3.30.2-0ubuntu4) ...
Setting up gnome-software-plugin-snap (3.30.2-0ubuntu4) ...
Processing triggers for libc-bin (2.28-0ubuntu1) ...
Processing triggers for dbus (1.12.10-1ubuntu2) ...
guiverc@dx6120lu:~$ gnome-software
11:39:14:0533 Gs plugin appstream took 2.6 seconds to do setup
11:39:14:0576 Gs enabled plugins: desktop-categories, fwupd, os-release, packagekit, packagekit-local, packagekit-offline, packagekit-proxy, packagekit-refine-repos, packagekit-refresh, packagekit-upgrade, packagekit-url-to-app, ubuntuone, appstream, desktop-menu-path, hardcoded-blacklist, hardcoded-featured, hardcoded-popular, modalias, packagekit-refine, rewrite-resource, steam, ubuntu-reviews, packagekit-history, provenance, snap, systemd-updates, generic-updates, provenance-license, icons, key-colors, key-colors-metadata
11:39:14:0577 Gs disabled plugins: dpkg, dummy, repos, shell-extensions, epiphany, odrs
11:39:16:0449 GLib-GIO g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed
11:39:31:0803 Gs Only 6 apps for popular list, hiding
11:39:38:0095 Gs hiding category graphics featured applications: found only 8 to show, need at least 9
11:39:40:0639 GLib-GObject g_object_new_is_valid_property: object class 'GsPluginJob' has no property named ''
**
Gs:ERROR:../lib/gs-plugin-loader.c:1698:gs_plugin_loader_pending_apps_add: assertion failed: (gs_app_list_length (list) > 0)
Aborted (core dumped)
guiverc@dx6120lu:~$ apt-cache policy gnome-software
gnome-software:
  Installed: 3.30.2-0ubuntu4
  Candidate: 3.30.2-0ubuntu4
  Version table:
 *** 3.30.2-0ubuntu4 500
        500 http://ftp.iinet.net.au/pub/ubuntu cosmic/main i386 Packages
        100 /var/lib/dpkg/status
guiverc@dx6120lu:~$

Notes:
I use my ISP's mirror (free of bandwidth quota) post-installation (apt-cache policy..)
This install was made on recent QA-Test, and I've added & played with things a little since then for testing. but its mostly original..
Same dx6120 box used by Xubuntu installs (/dev/sda? for xubuntu) but this install is /dev/sdc1

// screenfetch -n
 guiverc@dx6120lu
 OS: Ubuntu 18.10 cosmic
 Kernel: i686 Linux 4.18.0-10-generic
 Uptime: 21m
 Packages: 2101
 Shell: bash 4.4.19
 Resolution: 1280x1024
 DE: LXDE
 WM: OpenBox
 CPU: Intel Pentium 4 2.80GHz @ 2x 2.791GHz [97.0°C]
 GPU: GeForce 7600 GT
 RAM: 474MiB / 3025MiB
// screenfetch lies; this is LXQT not LXDE :(

Chris Guiver (guiverc) wrote :

I tried on my primary box (ubuntu 18.10 [x86_64] with xfce, lxqt & mate desktops added; xfce my usual).

When `gnome-software` was run from [whisker] menu, I got a "Unable to install ...: you do not have permission to install software" when trying to install a font (leafpad & gedit were already installed)

I `sudo gnome-software` and font installed with no issues.

I booted xubuntu on dx6120 & tried from terminal as before (gnome-software), then `sudo gnome-software) getting same error as prior attempts both tries :(

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
David Pearson (akxwi-dave) wrote :

doesn't matter what software is used to be installed.. crashes on all

Chris Guiver (guiverc) wrote :

// term output for comment #16
// I noted a couple of extra lines when run with `sudo`..

guiverc@dx6120x2:~$ gnome-software
13:11:18:0825 Gs plugin appstream took 3.5 seconds to do setup
13:11:18:0857 Gs enabled plugins: desktop-categories, fwupd, os-release, packagekit, packagekit-local, packagekit-offline, packagekit-proxy, packagekit-refine-repos, packagekit-refresh, packagekit-upgrade, packagekit-url-to-app, ubuntuone, appstream, desktop-menu-path, hardcoded-blacklist, hardcoded-featured, hardcoded-popular, modalias, packagekit-refine, rewrite-resource, steam, ubuntu-reviews, packagekit-history, provenance, snap, systemd-updates, generic-updates, provenance-license, icons, key-colors, key-colors-metadata
13:11:18:0857 Gs disabled plugins: dpkg, dummy, repos, shell-extensions, epiphany, odrs
13:11:27:0433 Gs Only 6 apps for popular list, hiding
13:11:38:0592 Gs hiding category graphics featured applications: found only 8 to show, need at least 9
13:12:49:0548 GLib-GObject g_object_new_is_valid_property: object class 'GsPluginJob' has no property named 'p>P
                                                                                                                '
**
Gs:ERROR:../lib/gs-plugin-loader.c:1698:gs_plugin_loader_pending_apps_add: assertion failed: (gs_app_list_length (list) > 0)
Aborted (core dumped)

guiverc@dx6120x2:~$ sudo gnome-software
[sudo] password for guiverc:
13:13:30:0040 Gs plugin appstream took 5.1 seconds to do setup
13:13:55:0106 Gs enabled plugins: desktop-categories, fwupd, os-release, packagekit, packagekit-local, packagekit-offline, packagekit-proxy, packagekit-refine-repos, packagekit-refresh, packagekit-upgrade, packagekit-url-to-app, appstream, desktop-menu-path, hardcoded-blacklist, hardcoded-featured, hardcoded-popular, modalias, packagekit-refine, rewrite-resource, steam, ubuntu-reviews, packagekit-history, provenance, systemd-updates, generic-updates, provenance-license, icons, key-colors, key-colors-metadata
13:13:55:0106 Gs disabled plugins: dpkg, dummy, repos, shell-extensions, ubuntuone, epiphany, odrs, snap
13:13:57:0528 Gs hiding category games featured applications: found only 0 to show, need at least 9
13:13:59:0990 Gs Only 8 apps for popular list, hiding
13:14:00:0626 Gs hiding category graphics featured applications: found only 1 to show, need at least 9
13:14:05:0682 PK internal error: failed, but no error code: cancelled
13:14:14:0035 GLib-GObject g_object_new_is_valid_property: object class 'GsPluginJob' has no property named ''
**
Gs:ERROR:../lib/gs-plugin-loader.c:1698:gs_plugin_loader_pending_apps_add: assertion failed: (gs_app_list_length (list) > 0)
Aborted

guiverc@dx6120x2:~$ ls /var/crash/ -ltrh
total 39M
-rw-r----- 1 guiverc whoopsie 18M Oct 17 16:30 _usr_bin_gnome-software.1000.crash
-rw-rw-r-- 1 guiverc whoopsie 0 Oct 17 16:30 _usr_bin_gnome-software.1000.upload
-rw------- 1 whoopsie whoopsie 0 Oct 17 16:30 _usr_bin_gnome-software.1000.uploaded
-rw-r----- 1 root whoopsie 21M Oct 18 00:14 _usr_bin_gnome-software.0.crash

Sebastien Bacher (seb128) wrote :

Confirmed the issue on 32 bit arch using xubuntu i386 cosmic iso.

Robert can you have a look?

Changed in gnome-software (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
importance: Undecided → High
summary: - xubuntu 18.10 daily (x86 live & installed) - [gnome-]software cannot
- install leafpad/gedit/software
+ gnome-software segfaults when installing debs on 32 bits/cosmic

valgrind log error

==3185== Process terminating with default action of signal 6 (SIGABRT)
==3185== at 0x5AC2512: raise (raise.c:51)
==3185== by 0x5AAC2B5: abort (abort.c:79)
==3185== by 0x496ADD3: g_assertion_message.cold.16 (gtestutils.c:2596)
==3185== by 0x49C6C3B: g_assertion_message_expr (gtestutils.c:2619)
==3185== by 0x184520: gs_plugin_loader_pending_apps_add (gs-plugin-loader.c:1698)
==3185== by 0x184520: gs_plugin_loader_process_thread_cb (gs-plugin-loader.c:3136)
==3185== by 0x184AC5: gs_plugin_loader_process_in_thread_pool_cb (gs-plugin-loader.c:3447)
==3185== by 0x49C830C: g_thread_pool_thread_proxy (gthreadpool.c:307)
==3185== by 0x49C78B9: g_thread_proxy (gthread.c:784)
==3185== by 0x5A77FEC: start_thread (pthread_create.c:486)
==3185== by 0x5B8EA75: clone (clone.S:108)
==3185==

stdout output
GLib-GObject g_object_new_is_valid_property: object class 'GsPluginJob' has no property named '��c
                                '
**
Gs:ERROR:../lib/gs-plugin-loader.c:1698:gs_plugin_loader_pending_apps_add: assertion failed: (gs_app_list_length (list) > 0)
Abandon (core dumped)

Sebastien Bacher (seb128) wrote :

it segfaults also when trying to enter a category

Sebastien Bacher (seb128) wrote :

backtrace when clicking the audio&video category

(gdb) bt
#0 0xb228a4cf in gs_plugin_add_category_apps (plugin=0x663888, category=0x0,
    list=0xb21796f0, cancellable=0xdef190, error=0xacd61f50)
    at ../plugins/core/gs-plugin-desktop-categories.c:100
#1 0x0047a918 in gs_plugin_loader_call_vfunc (helper=helper@entry=0xb2179780,
    plugin=plugin@entry=0x663888, app=app@entry=0x0, list=0xb21796f0,
    refine_flags=<optimized out>, cancellable=0xdef190, error=0xacd62004)
    at ../lib/gs-plugin-loader.c:643
#2 0x0047ac7b in gs_plugin_loader_run_results (
    helper=helper@entry=0xb2179780, cancellable=cancellable@entry=0xdef190,
    error=error@entry=0xacd62004) at ../lib/gs-plugin-loader.c:1147
#3 0x0047bce3 in gs_plugin_loader_process_thread_cb (task=0x57f2a0,
    object=0x7328a8, task_data=0xb2179780, cancellable=0xdef190)
    at ../lib/gs-plugin-loader.c:3140
#4 0xb7c217bf in g_task_thread_pool_thread (thread_data=0x57f2a0,
    pool_data=0x0) at ../../../../gio/gtask.c:1331
#5 0xb7df930d in g_thread_pool_thread_proxy (data=0x557f70)
    at ../../../../glib/gthreadpool.c:307
#6 0xb7df88ba in g_thread_proxy (data=0xb2b8ac90)
    at ../../../../glib/gthread.c:784
#7 0xb6d86fed in start_thread (arg=0xacd62b40) at pthread_create.c:486
#8 0xb6c9aa76 in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:108

Robert Ancell (robert-ancell) wrote :
Changed in gnome-software (Ubuntu):
status: Confirmed → Triaged
Daniel van Vugt (vanvugt) wrote :
summary: - gnome-software segfaults when installing debs on 32 bits/cosmic
+ gnome-software crashes with assertion failure Gs:ERROR:../lib/gs-plugin-
+ loader.c:1698:gs_plugin_loader_pending_apps_add: assertion failed:
+ (gs_app_list_length (list) > 0)
description: updated
Daniel van Vugt (vanvugt) wrote :

Actually comment #21 (this crash) is better matched by:
https://errors.ubuntu.com/problem/bbef7c8fd9bdc0335c409ee79addfef391dda0e9

description: updated
David Pearson (akxwi-dave) wrote :

still happening afater two new rebuilds

Changed in gnome-software (Ubuntu):
status: Triaged → In Progress
Sebastien Bacher (seb128) wrote :

Looks like Robert uploaded a fix but just didn't update the bug, doing that now to reflect the status

description: updated
Changed in gnome-software (Ubuntu):
status: In Progress → Fix Committed

Hello Chris, or anyone else affected,

Accepted gnome-software into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.30.2-0ubuntu7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-software (Ubuntu Bionic):
status: New → Fix Committed
no longer affects: gnome-software (Ubuntu Bionic)
tags: added: verification-needed verification-needed-cosmic
Chris Guiver (guiverc) wrote :
Download full text (5.3 KiB)

guiverc@dx6120x2:~$ apt-cache policy gnome-software
gnome-software:
  Installed: 3.30.2-0ubuntu7
  Candidate: 3.30.2-0ubuntu7
  Version table:
 *** 3.30.2-0ubuntu7 500
        500 http://ftp.iinet.net.au/pub/ubuntu cosmic-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     3.30.2-0ubuntu5 500
        500 http://ftp.iinet.net.au/pub/ubuntu cosmic/main i386 Packages

tested on dx6120 xubuntu 18.10 using -proposed...

I was able to search & install leafpad, gedit (non-snap version selected) & xscorch

I ran it from CLI - HOWEVER it didn't return as expected to bash ($) prompt - needing me to eventually ^C to get my prompt back. Output follows, but on another term I queried and saw

guiverc@dx6120x2:~$ ps -elf |grep gnome-soft
0 S guiverc 16974 3044 28 80 0 - 64142 poll_s 21:27 pts/0 00:02:13 gnome-software
0 S guiverc 18807 18798 0 80 0 - 2051 pipe_w 21:35 pts/2 00:00:00 grep --color=auto gnome-soft
guiverc@dx6120x2:~$ ps -Flww -p 16974
F S UID PID PPID C PRI NI ADDR SZ WCHAN RSS PSR STIME TTY TIME CMD
0 S guiverc 16974 3044 25 80 0 - 64142 poll_s 133380 1 21:27 pts/0 00:02:13 gnome-software

No idea if this is an issue ... I re-ran it again, searched for leafpad, cancelled and searched for mpv, then exited (no installs). It hung this time too ..

guiverc@dx6120x2:~$ ps -elf |grep gnome-soft
0 S guiverc 18814 3044 6 80 0 - 53162 poll_s 21:39 pts/0 00:00:12 gnome-software
0 S guiverc 18874 18798 0 80 0 - 2051 pipe_w 21:42 pts/2 00:00:00 grep --color=auto gnome-soft
guiverc@dx6120x2:~$ ps -Flww -p 18814
F S UID PID PPID C PRI NI ADDR SZ WCHAN RSS PSR STIME TTY TIME CMD
0 S guiverc 18814 3044 6 80 0 - 53162 poll_s 93580 0 21:39 pts/0 00:00:12 gnome-software
guiverc@dx6120x2:~$

// Output of first test (install of leafpad, gedit, xscorch)

guiverc@dx6120x2:~$ gnome-software
10:27:16:0273 Gs plugin appstream took 2.9 seconds to do setup
10:27:16:0313 Gs enabled plugins: desktop-categories, fwupd, os-release, packagekit, packagekit-local, packagekit-offline, packagekit-proxy, packagekit-refine-repos, packagekit-refresh, packagekit-upgrade, packagekit-url-to-app, ubuntuone, appstream, desktop-menu-path, hardcoded-blacklist, hardcoded-featured, hardcoded-popular, modalias, packagekit-refine, rewrite-resource, steam, ubuntu-reviews, packagekit-history, provenance, snap, systemd-updates, generic-updates, provenance-license, icons, key-colors, key-colors-metadata
10:27:16:0313 Gs disabled plugins: dpkg, dummy, repos, shell-extensions, epiphany, odrs
10:27:22:0427 Gs Only 6 apps for popular list, hiding
10:27:24:0581 Gs hiding category graphics featured applications: found only 8 to show, need at least 9
10:27:47:0222 As failed to rescan: Failed to parse /usr/share/applications/leafpad.desktop file: cannot process file of type application/x-desktop
10:27:47:0247 As failed to rescan: Failed to parse /usr/share/applications/leafpad.desktop file: cannot process file of type application/x-desktop
10:27:55:0853 Gs Only 6 apps for popular list, hiding
10:27:55:0908 Gs hiding category graphics featured applications: found only 8 to show, n...

Read more...

Chris Guiver (guiverc) wrote :

ps: i opened all categories on first run [of gnome-software], it worked like I believe it should (i use aptitude sorry). everything looked correct, except it didn't return me to prompt requiring me to ^C

tags: added: verification-done-cosmic
removed: verification-needed-cosmic
Chris Guiver (guiverc) wrote :

sorry I've decided the not-returning to prompt is normal behavior.

I enabled -proposed on x86_64 box, upgraded and had same behavior using 3.30.2-0ubuntu7

I booted another partition [x86[ install on this dx6120 (different QA test), update & upgraded software and it has "Installed: 3.30.2-0ubuntu5" for gnome-software - got identical behavior.

I ran it on my normal workstation (ver 0ubuntu5) & it returned to $prompt almost immediately; before I had a chance to do anything with gnome-software - very different behavior.

So please ignore my return-to-prompt comments..

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.30.2-0ubuntu7

---------------
gnome-software (3.30.2-0ubuntu7) cosmic; urgency=medium

  * debian/patches/0001-Use-correct-boolean-type-for-GsPluginJob-interactive.patch:
    - Fix crashes in 32 bit architectures (LP: #1798236)

gnome-software (3.30.2-0ubuntu6) cosmic; urgency=medium

  * debian/patches/0001-lib-Allow-opening-CAB-files-that-resolve-more-than-o.patch:
    - Support composite CAB files (LP: #1798470)

 -- Robert Ancell <email address hidden> Thu, 18 Oct 2018 11:14:33 +1300

Changed in gnome-software (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-software has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.