/usr/bin/gnome-software:11:g_type_check_instance:g_signal_emit_valist:g_signal_emit:g_closure_invoke:signal_emit_unlocked_R

Bug #1778160 reported by errors.ubuntu.com bug bridge on 2018-06-22
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
Status tracked in Cosmic
Xenial
Medium
Robert Ancell
Bionic
Medium
Robert Ancell
Cosmic
Medium
Robert Ancell

Bug Description

[Impact]
Configuring the permissions for a snap that has a plug that can connect to multiple slots causes a crash:
https://errors.ubuntu.com/problem/46232e57fbbc469ce3e5f5c0f12bc24f95cd27c6

[Test Case]
1. Open GNOME Software
2. Search for and install TBD snap
3. Open Permissions dialog
4. Toggle TBD permission that uses a combo box

Expected result:
Permission is changed

Observed result:
GNOME Software crashes

[Regression Potential]
Fix is to rename a signal to avoid a name collision, low chance of introducing new bugs.

Robert Ancell (robert-ancell) wrote :

The crash seems to be related to a ComboBox and has only started occurring in Xenial after the Snap interfaces support was added.

Robert Ancell (robert-ancell) wrote :

Cause seems to be a name collision for the GsPermissionComboBox "changed" signal - solution was to rename it to "value-changed". This only occurs when a snap has a plug that can connect to more than one slot.

Changed in gnome-software (Ubuntu Cosmic):
status: New → Fix Committed
importance: Undecided → Medium
Changed in gnome-software (Ubuntu Bionic):
importance: Undecided → Medium
Changed in gnome-software (Ubuntu Xenial):
importance: Undecided → Medium
description: updated
Changed in gnome-software (Ubuntu Xenial):
status: New → Fix Committed
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu Bionic):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu Cosmic):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu Bionic):
status: New → Triaged
description: updated
Robert Ancell (robert-ancell) wrote :

Asked on forum if anyone knows a suitable snap to test this:
https://forum.snapcraft.io/t/searching-for-a-snap-that-has-a-plug-with-multiple-slots

Changed in gnome-software (Ubuntu Bionic):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.29.1-0ubuntu2

---------------
gnome-software (3.29.1-0ubuntu2) cosmic; urgency=medium

  * debian/control:
    - Bump minimum version of snapd-glib
  * debian/patches/0014-Add-a-basic-permissions-system.patch:
    - Fix crash when have plugs with multiple slots available (LP: #1778160)

 -- Robert Ancell <email address hidden> Fri, 22 Jun 2018 15:44:13 +1200

Changed in gnome-software (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Robie Basak (racb) wrote :

>
[Regression Potential]
Fix is to rename a signal to avoid a name collision, low chance of introducing new bugs.

Please update that to inform testers where to look for new bugs if the change does happen to introduce any.

Robie Basak (racb) wrote :

>
Asked on forum if anyone knows a suitable snap to test this:
https://forum.snapcraft.io/t/searching-for-a-snap-that-has-a-plug-with-multiple-slots

Looks like you got an answer there on how to reproduce? Accepting for now, but please verify using that method (or by finding the culprit snap that causes user crashes) for SRU verification.

tags: added: verification-needed verification-needed-bionic

Hello errors.ubuntu.com, or anyone else affected,

Accepted gnome-software into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.28.1-0ubuntu4.18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers