Snap branches shown in random order

Bug #1769556 reported by Robert Ancell on 2018-05-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
Status tracked in Cosmic
Xenial
Medium
Robert Ancell
Bionic
Medium
Robert Ancell
Cosmic
Medium
Robert Ancell

Bug Description

[Impact]
Snap branches are shown in a random order.

[Test Case]
1. Open GNOME Software
2. Search for and select "communitheme" snap
3. Select available channels (requires LP: #1768779 to be fixed).

Expected result:
Branches are shown in some predictable order.

Observed result:
Branches are shown in a random order.

[Regression Potential]
Solution is to sort branches alphabetically, could introduce new bugs in channel code.

Changed in gnome-software (Ubuntu Bionic):
importance: Undecided → Medium
Changed in gnome-software (Ubuntu Cosmic):
status: New → Triaged
Changed in gnome-software (Ubuntu Xenial):
status: New → Triaged
Changed in gnome-software (Ubuntu Bionic):
status: New → Triaged
Changed in gnome-software (Ubuntu Cosmic):
importance: Undecided → Medium
Changed in gnome-software (Ubuntu Xenial):
importance: Undecided → Medium
Changed in gnome-software (Ubuntu Xenial):
status: Triaged → Fix Committed
Changed in gnome-software (Ubuntu Bionic):
status: Triaged → Fix Committed
Changed in gnome-software (Ubuntu Cosmic):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.28.1-0ubuntu6

---------------
gnome-software (3.28.1-0ubuntu6) cosmic; urgency=medium

  * debian/patches/0011-Support-snap-channels.patch:
    - Make snap channel selection list scrollable (LP: #1768779)
    - Fix channel branches all showing the same name (LP: #1768794)
    - Alphabetically sort channel branch names (LP: #1769556)

 -- Robert Ancell <email address hidden> Mon, 07 May 2018 16:31:46 +1200

Changed in gnome-software (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Changed in gnome-software (Ubuntu Cosmic):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu Bionic):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu Xenial):
assignee: nobody → Robert Ancell (robert-ancell)

Hello Robert, or anyone else affected,

Accepted gnome-software into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.28.1-0ubuntu4.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-bionic
Brian Murray (brian-murray) wrote :

Hello Robert, or anyone else affected,

Accepted gnome-software into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.20.5-0ubuntu0.16.04.11 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed-xenial
Changed in gnome-software (Ubuntu Xenial):
assignee: Robert Ancell (robert-ancell) → nobody
assignee: nobody → Robert Ancell (robert-ancell)
Jean-Baptiste Lallement (jibel) wrote :

I am not sure how to verify this SRU because the server no longer advertises branches (comment 4 bug 1768794) and this information is not displayed in gnome-software. Tracks are in a predictable order.

Robert Ancell (robert-ancell) wrote :

I'll mark this verification-done as I did test it at the time (when the server did advertise branches). I think with Jean-Baptiste's confirmation that the tracks are correct then we should keep the change in case the server ever changed behaviour. I think the risk of this patch causing further issues is sufficiently low that it's not worth backing it out.

tags: added: verification-done-bionic verification-done-xenial
removed: verification-needed verification-needed-bionic verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.28.1-0ubuntu4.18.04.1

---------------
gnome-software (3.28.1-0ubuntu4.18.04.1) bionic; urgency=medium

  * debian/patches/0011-Support-snap-channels.patch:
    - Fix incorrect default install version being shown (LP: #1767445)
    - Make snap channel selection list scrollable (LP: #1768779)
    - Fix channel branches all showing the same name (LP: #1768794)
    - Alphabetically sort channel branch names (LP: #1769556)
  * debian/control:
    - Use bionic Vcs link

 -- Robert Ancell <email address hidden> Mon, 07 May 2018 16:32:37 +1200

Changed in gnome-software (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-software has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers