Snap channel selection list not scrollable

Bug #1768779 reported by Michal Predotka on 2018-05-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
Status tracked in Cosmic
Xenial
Low
Robert Ancell
Bionic
Low
Robert Ancell
Cosmic
Low
Robert Ancell

Bug Description

[Impact]
Snaps with many channels/branches (e.g. communitheme) make the channel selector too large - it should use a scrollable window if there are many.

[Test Case]
1. Search for ”communitheme” in the store
2. Open ”communitheme” result
3. Click on the channel selection button
4. You will see a popup with loooooong list of channels
5. Try to scroll to see more entries

Expected result:
You can scroll the list

What happen instead:
You cannot scroll the list

[Regression Potential]
Solution is to use a GtkScrolledWindow for the list. Could cause other UI bugs to occur.

Michal Predotka (mpredotka) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The list not being scrollable is an issue but there is also a bug that its has more entries that it should.

Changed in gnome-software (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
importance: Undecided → High
Didier Roche (didrocks) wrote :
Download full text (5.4 KiB)

The list of real entries are (at that time, it's dynamic):

Track Arch Channel Version Revision Expires at
latest all stable 0.1 124
                 candidate ^ ^
                 beta ^ ^
                 edge 0.1 170
                 edge/gnome-shell-communitheme-pr125 0.1 112 2018-05-26T13:54:16.742243
                 edge/gnome-shell-communitheme-pr128 0.1 144 2018-05-29T22:59:41.400161
                 edge/gnome-shell-communitheme-pr130 0.1 108 2018-05-26T09:21:19.157622
                 edge/gnome-shell-communitheme-pr131 0.1 125 2018-05-27T12:05:18.882819
                 edge/gnome-shell-communitheme-pr136 0.1 132 2018-05-27T21:09:57.216625
                 edge/gtk-communitheme-pr371 0.1 123 2018-05-27T10:43:32.369778
                 edge/gtk-communitheme-pr374 0.1 128 2018-05-27T16:17:18.898120
                 edge/gnome-shell-communitheme-pr143 0.1 136 2018-05-28T08:51:24.786638
                 edge/gtk-communitheme-pr384 0.1 159 2018-05-31T08:48:58.912739
                 edge/gtk-communitheme-pr385 0.1 164 2018-05-31T22:17:13.052878
                 edge/gtk-communitheme-pr387 0.1 146 2018-05-30T09:35:43.783124
                 edge/gnome-shell-communitheme-pr149 0.1 148 2018-05-30T14:05:02.010329
                 edge/gnome-shell-communitheme-pr150 0.1 150 2018-05-30T16:23:04.423498
                 edge/gnome-shell-communitheme-pr151 0.1 155 2018-05-30T22:11:56.694347
                 edge/communitheme-snap-helpers-pr9 0.1 156 2018-05-30T22:49:43.618408
                 edge/gnome-shell-communitheme-pr158 0.1 160 2018-05-31T16:11:35.365221
                 edge/gtk-communitheme-pr392 0.1 167 2018-06-01T14:24:25.782118
                 edge/gtk-communitheme-pr393 0.1 168 2018-06-01T14:46:23.289516
                 edge/gtk-communitheme-pr394 0.1 169 2018-06-01T14:46:53.708757
         amd64 stable 0.1 97
                 candidate ^ ^
                 beta ^ ^
                 edge 0.1 104
                 edge/ubuntu-communitheme-snap-helpers-1 0.1 4 2018-05-04T10:05:45.478718
                 edge/communitheme-snap-helpers-pr1 0.1 29 2018-05-05T09:31:00.421780
                 edge/blablab-branch-pr1 0.1 10 2018-05-04T14:44:43.359591
                 edge/communitheme-snap-helpers-pr2 0.1 35 2018-05-09T15:05...

Read more...

Sebastien Bacher (seb128) wrote :

Robert, is the list we display coming directly from snapd? or a bug in g-s/snapd-glib?

Michal Predotka (mpredotka) wrote :

I've reported another bug about same entries: bug #1768794

Sebastien Bacher (seb128) wrote :

k, let's keep that one about the scrolling issue then

Changed in gnome-software (Ubuntu):
importance: High → Low
assignee: Robert Ancell (robert-ancell) → nobody
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
Changed in gnome-software (Ubuntu Cosmic):
status: Confirmed → Fix Committed
Changed in gnome-software (Ubuntu Bionic):
importance: Undecided → Low
Changed in gnome-software (Ubuntu Xenial):
importance: Undecided → Low
status: New → Triaged
Changed in gnome-software (Ubuntu Bionic):
status: New → Triaged
Changed in gnome-software (Ubuntu Xenial):
status: Triaged → Fix Committed
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu Cosmic):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu Bionic):
assignee: nobody → Robert Ancell (robert-ancell)
status: Triaged → Fix Committed
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.28.1-0ubuntu6

---------------
gnome-software (3.28.1-0ubuntu6) cosmic; urgency=medium

  * debian/patches/0011-Support-snap-channels.patch:
    - Make snap channel selection list scrollable (LP: #1768779)
    - Fix channel branches all showing the same name (LP: #1768794)
    - Alphabetically sort channel branch names (LP: #1769556)

 -- Robert Ancell <email address hidden> Mon, 07 May 2018 16:31:46 +1200

Changed in gnome-software (Ubuntu Cosmic):
status: Fix Committed → Fix Released

Hello Michal, or anyone else affected,

Accepted gnome-software into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.28.1-0ubuntu4.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-bionic
Michal Predotka (mpredotka) wrote :

I'm not able to test if it scroll or not as the other bug (#1768794) was fixed and now I see only 4 entries.

Brian Murray (brian-murray) wrote :

Hello Michal, or anyone else affected,

Accepted gnome-software into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.20.5-0ubuntu0.16.04.11 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed-xenial

SRU verification for Bionic:
I have reproduced the problem with gnome-software 3.28.1-0ubuntu4 in bionic and have verified that the version of gnome-software 3.28.1-0ubuntu4.18.04.1 in -proposed fixes the issue.
However this could be improved a bit because the scrollbar overlaps with the right side of the "switch" buttons.

Marking as verification-done

tags: added: verification-done-bionic
removed: verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.28.1-0ubuntu4.18.04.1

---------------
gnome-software (3.28.1-0ubuntu4.18.04.1) bionic; urgency=medium

  * debian/patches/0011-Support-snap-channels.patch:
    - Fix incorrect default install version being shown (LP: #1767445)
    - Make snap channel selection list scrollable (LP: #1768779)
    - Fix channel branches all showing the same name (LP: #1768794)
    - Alphabetically sort channel branch names (LP: #1769556)
  * debian/control:
    - Use bionic Vcs link

 -- Robert Ancell <email address hidden> Mon, 07 May 2018 16:32:37 +1200

Changed in gnome-software (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-software has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

SRU verification for Xenial:
I have reproduced the problem with gnome-software 3.20.5-0ubuntu0.16.04.10 in xenial-updates and have verified that the version of gnome-software 3.20.5-0ubuntu0.16.04.11 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.5-0ubuntu0.16.04.11

---------------
gnome-software (3.20.5-0ubuntu0.16.04.11) xenial; urgency=medium

  * debian/patches/0019-Support-channels.patch:
    - Make snap channel selection list scrollable (LP: #1768779)
  * debian/patches/0020-Add-a-basic-permission-system.patch
  * debian/patches/0021-Add-a-Snap-plugin.patch
    - Correctly handle snap install/remove failures (LP: #1762427)
    - Fix snaps without icons not showing (LP: #1763736)
    - Add basic system for connecting/disconnecting snap interfaces
      (LP: #1597314)
    - Alphabetically sort channel branch names (LP: #1769556)
  * debian/patches/0050-snap-Support-channels.patch:
    - Fix incorrect default install version being shown (LP: #1767445)

 -- Robert Ancell <email address hidden> Tue, 08 May 2018 12:02:36 +1200

Changed in gnome-software (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers