gnome-software crashed with signal 5 in g_main_context_new → start_sync → snapd_client_list_one_sync → gs_plugin_refine_app → gs_plugin_loader_call_vfunc

Bug #1756339 reported by Togo28 on 2018-03-16
68
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
High
Robert Ancell
Bionic
High
Robert Ancell
snapd-glib (Ubuntu)
High
Robert Ancell
Bionic
High
Robert Ancell

Bug Description

Chrashed while using synaptic

Error from the error tracker:
https://errors.ubuntu.com/problem/1656a46ccf6a6facc18037559655c07980d99beb

ProblemType: Crash
DistroRelease: Ubuntu 18.04
Package: gnome-software 3.28.0-0ubuntu3
ProcVersionSignature: Ubuntu 4.15.0-12.13-generic 4.15.7
Uname: Linux 4.15.0-12-generic x86_64
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Mar 16 14:36:57 2018
ExecutablePath: /usr/bin/gnome-software
InstallationDate: Installed on 2018-03-13 (2 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180313)
InstalledPlugins:
 gnome-software-plugin-flatpak N/A
 gnome-software-plugin-limba N/A
 gnome-software-plugin-snap 3.28.0-0ubuntu3
ProcCmdline: /usr/bin/gnome-software --gapplication-service
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
Signal: 5
SourcePackage: gnome-software
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_main_context_new () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libsnapd-glib.so.1
 snapd_client_list_one_sync () from /usr/lib/x86_64-linux-gnu/libsnapd-glib.so.1
 gs_plugin_refine_app () from /usr/lib/x86_64-linux-gnu/gs-plugins-11/libgs_plugin_snap.so
Title: gnome-software crashed with signal 5 in g_main_context_new()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Togo28 (togo28) wrote :

StacktraceTop:
 g_wakeup_new () at ../../../../glib/gwakeup.c:161
 g_main_context_new () at ../../../../glib/gmain.c:656
 start_sync (data=<optimized out>, data=<optimized out>) at snapd-client-sync.c:24
 snapd_client_list_one_sync (client=client@entry=0x56014d882980, name=name@entry=0x7f81040095f0 "paintsupreme-3d", cancellable=cancellable@entry=0x56014c923910, error=error@entry=0x0) at snapd-client-sync.c:286
 gs_plugin_refine_app (plugin=plugin@entry=0x56014a6f2f60, app=app@entry=0x7f81100acea0, flags=flags@entry=2097184, cancellable=cancellable@entry=0x56014c923910, error=error@entry=0x7f8122f51878) at ../plugins/snap/gs-plugin-snap.c:844

Changed in gnome-software (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
information type: Private → Public
Changed in snapd-glib (Ubuntu):
status: New → Confirmed
summary: - gnome-software crashed with signal 5 in g_main_context_new()
+ gnome-software crashed with signal 5 in g_main_context_new → start_sync
+ → snapd_client_list_one_sync → gs_plugin_refine_app →
+ gs_plugin_loader_call_vfunc → gs_plugin_loader_run_refine_filter →
+ gs_plugin_loader_run_refine_internal → gs_plugin_loader_run_refine →
+ gs_plugin_loader_process_thread_cb
summary: gnome-software crashed with signal 5 in g_main_context_new → start_sync
→ snapd_client_list_one_sync → gs_plugin_refine_app →
- gs_plugin_loader_call_vfunc → gs_plugin_loader_run_refine_filter →
- gs_plugin_loader_run_refine_internal → gs_plugin_loader_run_refine →
- gs_plugin_loader_process_thread_cb
+ gs_plugin_loader_call_vfunc
Changed in snapd-glib (Ubuntu):
importance: Undecided → High
Changed in gnome-software (Ubuntu):
importance: Medium → High
description: updated
tags: added: rls-bb-incoming
Will Cooke (willcooke) on 2018-04-10
Changed in snapd-glib (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
tags: removed: rls-bb-incoming
Robert Ancell (robert-ancell) wrote :

Stacktrace shows:

Creating pipes for GWakeup: Zu viele offene Dateien

So this is probably bug 1760795

Iain Lane (laney) on 2018-05-24
Changed in gnome-software (Ubuntu Bionic):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Jean-Baptiste Lallement (jibel) wrote :

According to errors.u.c this is fixed in 3.28.1

Changed in snapd-glib (Ubuntu Bionic):
status: Confirmed → Fix Released
Changed in snapd-glib (Ubuntu):
status: Confirmed → Fix Released
Changed in gnome-software (Ubuntu):
status: Confirmed → Fix Released
Changed in gnome-software (Ubuntu Bionic):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers