Installing snap from command line confuses GNOME Software

Bug #1754655 reported by Robert Ancell on 2018-03-09
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
Medium
Robert Ancell
Xenial
Medium
Robert Ancell
Artful
Medium
Unassigned
Bionic
Medium
Robert Ancell

Bug Description

[Impact]
Installing snaps from the command line (or any other client) causes the state in GNOME Software to wrongly represented.

[Test Case]
1. Ensure you don't have moon-buggy installed
$ sudo snap remove moon-buggy
2. Start GNOME Software
3. Install moon-buggy from the command line:
$ sudo snap install moon-buggy
4. Search for "moon" in GNOME Software

Expected result:
Moon Buggy shows in search results as installed

Observed result:
Moon Buggy not returned in search results.

[Regression Potential]
Low, we fix a bug where were reading invalid metadata and a check that makes stops unexpected (but valid) state notification from the snap plugin.

Changed in gnome-software (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in gnome-software (Ubuntu Artful):
status: New → Triaged
Changed in gnome-software (Ubuntu Xenial):
status: New → Triaged
Changed in gnome-software (Ubuntu Artful):
importance: Undecided → Medium
Changed in gnome-software (Ubuntu Xenial):
importance: Undecided → Medium
Changed in gnome-software (Ubuntu Bionic):
status: Triaged → Fix Committed
Changed in gnome-software (Ubuntu Xenial):
status: Triaged → Fix Committed
Changed in gnome-software (Ubuntu Bionic):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu Xenial):
assignee: nobody → Robert Ancell (robert-ancell)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.27.92-0ubuntu2

---------------
gnome-software (3.27.92-0ubuntu2) bionic; urgency=medium

  * debian/patches/0001-snap-Fix-invalid-metadata-after-cancelled-refine.patch:
  * debian/patches/0015-Don-t-reject-unexpected-state-changes-external-event.patch:
    - Fix snaps not being shown correctly after install from command line
      (LP: #1754655)

 -- Robert Ancell <email address hidden> Fri, 09 Mar 2018 13:40:18 +0100

Changed in gnome-software (Ubuntu Bionic):
status: Fix Committed → Fix Released
Changed in gnome-software (Ubuntu Artful):
status: Triaged → Won't Fix

Hello Robert, or anyone else affected,

Accepted gnome-software into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.20.5-0ubuntu0.16.04.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-xenial
Robert Ancell (robert-ancell) wrote :

On a fully updated Xenial VM with -proposed enabled moon-buggy shows as installed in GNOME Software if installed from the command line.

tags: added: verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.5-0ubuntu0.16.04.10

---------------
gnome-software (3.20.5-0ubuntu0.16.04.10) xenial; urgency=medium

  * debian/patches/0020-Add-a-Snap-plugin.patch:
  * debian/patches/0015-Don-t-reject-unexpected-state-changes-external-event.patch:
    - Correctly launch snaps with multiple apps (LP: #1661590)
    - Fix snaps not being shown correctly after install from command line
      (LP: #1754655)

gnome-software (3.20.5-0ubuntu0.16.04.9) xenial; urgency=medium

  * debian/patches/0001-Make-app-name-sorting-case-insensitive.patch:
  * debian/patches/0018-Add-a-Snap-plugin.patch:
    - Show snaps in categories (LP: #1665126)
  * debian/patches/0001-trivial-Include-the-fwupd-version-in-the-useragent.patch:
    - Report fwupd version in user agent (LP: #1750030)
  * debian/patches/0050-snap-Support-channels.patch:
    - Support channels (LP: #1750288)
  * debian/README.source:
    - Update git repository to point to gitlab.gnome.org

 -- Robert Ancell <email address hidden> Wed, 28 Mar 2018 17:04:55 +1300

Changed in gnome-software (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-software has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Robert Ancell (robert-ancell) wrote :

This fix wasn't correctly applied in xenial, so will be re-uploaded

tags: removed: verification-done-xenial
Changed in gnome-software (Ubuntu Xenial):
status: Fix Released → Fix Committed

An upload of gnome-software to xenial-proposed has been rejected from the upload queue for the following reason: "Since this upload includes the same change for 'new media API' as others, I would feel much safer if we set a minimal version depenency to libsnapd-glib-dev (>= 1.45) - since it seems there was more than one snapd-glib version in xenial.".

Hello Robert, or anyone else affected,

Accepted gnome-software into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.20.5-0ubuntu0.16.04.12 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-xenial
Robert Ancell (robert-ancell) wrote :

Tested gnome-software 3.20.5-0ubuntu0.16.04.12 and was able to install moon-buggy from the command line and gnome-software showed the correct state before and afterwards.

tags: added: verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.5-0ubuntu0.16.04.12

---------------
gnome-software (3.20.5-0ubuntu0.16.04.12) xenial; urgency=medium

  * debian/patches/0001-Fix-potential-crash-when-icons-are-missing.patch:
    - Fix crash loading icons (LP: #1778135)
  * debian/patches/0020-Add-a-basic-permissions-system.patch:
    - Fix crash when have plugs with multiple slots available (LP: #1778160)
  * debian/patches/0021-Add-a-Snap-plugin.patch
    - Fix some command line warnings (LP: #1790563)
    - Use new snapd media API (LP: #1799614)
    - Allow connections on the u2f-devices interface (LP: #1738164)
  * debian/patches/0053-Don-t-reject-unexpected-state-changes-external-event.patch:
    - Fix snaps not being shown correctly after install from command line
      (LP: #1754655)
  * debian/patches/0054-Show-verified-developers.patch:
    - Show verified developers (LP: #1789336)

 -- Robert Ancell <email address hidden> Wed, 17 Apr 2019 14:39:52 +1200

Changed in gnome-software (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers