Search for Skype in GNOME Software doesn't list Skype as the first match

Bug #1746773 reported by Martin Wimpress  on 2018-02-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
High
Robert Ancell
Artful
Medium
Unassigned
Bionic
High
Robert Ancell

Bug Description

When searching for Skype in GNOME Software on Ubuntu 18.04 daily, Skype is not the first match that is listed. See the attached screenshot.

## Expected behaviour

When searching for Skype, Skype should be the first match.

## Actual behaviour

I search for Skype and the first match is not Skype.

## Steps to reproduce the behaviour

  * Open Ubuntu Software
  * Click the search icon and enter 'skype'

## Ubuntu version

  * Ubuntu 18.04 daily

## ubuntu-software version

Package: ubuntu-software
Version: 3.26.5-1ubuntu1

Will Cooke (willcooke) on 2018-02-01
Changed in gnome-software (Ubuntu):
status: New → Confirmed
Robert Ancell (robert-ancell) wrote :

Confirmed that snapd is returning skype before spreedme so must be some re-ordering going on in GNOME Software...

Changed in gnome-software (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
importance: Undecided → High
Changed in gnome-software (Ubuntu):
status: Confirmed → Triaged
Robert Ancell (robert-ancell) wrote :

This is due to a change in GNOME 3.22 which started ordering search results by "match value" (essentially a value indicating how well the result matches the search terms). This is generated by a bitfield of metadata items that matched the search terms. Snap doesn't provide this, so the snap results were getting ordered by the fallback sorting field - the app id.

I've proposed getting rid of the default sorting field, thus keeping the snaps in the order they were returned from snapd:
https://gitlab.gnome.org/GNOME/gnome-software/merge_requests/16

Robert Ancell (robert-ancell) wrote :

Actually, I misread the code - the match value is between 0 - 100, but I'm still investigating how it's generated.

Changed in gnome-software (Ubuntu Artful):
status: New → Fix Committed
importance: Undecided → Medium
Changed in gnome-software (Ubuntu Bionic):
status: Triaged → Fix Committed
Changed in gnome-software (Ubuntu Artful):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu Bionic):
status: Fix Committed → Fix Released
Changed in gnome-software (Ubuntu Artful):
assignee: Robert Ancell (robert-ancell) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers