Uninstalling VLC using Ubuntu Software does not uninstall the actual application

Bug #1746728 reported by AsciiWolf on 2018-02-01
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
Undecided
Unassigned
vlc (Debian)
Fix Released
Unknown

Bug Description

If you try to uninstall VLC using Ubuntu Software (GNOME Software), only the desktop/icon files are removed, not the actual binaries in /usr/bin. This is because VLC has them in a separate vlc-bin package and GNOME Software does not support uninstalling dependencies. Please, try to workaround this somehow.

AsciiWolf (asciiwolf) on 2018-02-01
tags: added: artful xenial zesty
Sebastian Ramacher (s-ramacher) wrote :

No, really not a vlc bug.

affects: vlc (Ubuntu) → gnome-software (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
Ken T (professorsnapper) wrote :

Confirmed - after I uninstall VLC via (Gnome) software, usr/bin still contains files called "vlc" & "vlc-wrapper".

As seen under a daily build for Ubuntu Budgie 18.04 32-bit, using Software v3.27.92

Cheers,
Ken.
***

Jeremy Bicha (jbicha) wrote :

According to the specifications, the binary should be included in the same package as the .desktop and the AppStream metadata.

Therefore, unless there is a good reason otherwise, it would be better for the vlc-bin package to be dropped and its contents moved to the vlc package.

(There are rare exceptions to this policy.)

Would someone be willing to file a bug against the vlc package in Debian for this issue?

References
----------
https://wiki.debian.org/AppStream/Guidelines
https://www.freedesktop.org/software/appstream/docs/sect-Quickstart-Distros.html
https://wiki.ubuntu.com/Debian/Bugs

AsciiWolf (asciiwolf) wrote :

Done.

Changed in vlc (Debian):
status: Unknown → New
Changed in vlc (Debian):
status: New → Won't Fix
Changed in vlc (Debian):
status: Won't Fix → Fix Released
AsciiWolf (asciiwolf) wrote :

It was not fixed in Debian, the correct status is "Won't Fix".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.